Zim

Special characters break links, and worse

Bug #1575743 reported by Frost on 2016-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zim
Undecided
Unassigned

Bug Description

Hi,

I'm using Zim 0.65 on Python 2.7 for OS X 10.11.4.

I'm not *entirely* sure I managed to install it properly as the install instructions on the Zim website are out of date and did not work. Therefore every time I want to launch Zim it launches a Python Launcher, Python (proper), and the Terminal. Is that right?

I managed to install dependencies with Homebrew OK though. On a side note, your install page could definitely do with a re-write for people who are less savvy.

THE MAIN ISSUE:

Using special characters (any kind) in a link breaks the link. Not only that, it will either duplicate a page (if a special character is in the title) or delete it. I have learned that the hard way - two day's worth of work vanished because my page had a 'ā' in the title. Even using brackets () in links seems to break them.

It's just really frustrating and inconvenient. Can Zim please patch a fix? Or is it me?

Cheers.

Sorry to ask, but can you give a more concrete example of the issue? E.g.
what steps do I need to do to reproduce the issue?

Regards,

Jaap

On Wed, Apr 27, 2016 at 5:50 PM Frost <email address hidden> wrote:

> Public bug reported:
>
> Hi,
>
> I'm using Zim 0.65 on Python 2.7 for OS X 10.11.4.
>
> I'm not *entirely* sure I managed to install it properly as the install
> instructions on the Zim website are out of date and did not work.
> Therefore every time I want to launch Zim it launches a Python Launcher,
> Python (proper), and the Terminal. Is that right?
>
> I managed to install dependencies with Homebrew OK though. On a side
> note, your install page could definitely do with a re-write for people
> who are less savvy.
>
> THE MAIN ISSUE:
>
> Using special characters (any kind) in a link breaks the link. Not only
> that, it will either duplicate a page (if a special character is in the
> title) or delete it. I have learned that the hard way - two day's worth
> of work vanished because my page had a 'ā' in the title. Even using
> brackets () in links seems to break them.
>
> It's just really frustrating and inconvenient. Can Zim please patch a
> fix? Or is it me?
>
> Cheers.
>
> ** Affects: zim
> Importance: Undecided
> Status: New
>
>
> ** Tags: character link mac
>
> --
> You received this bug notification because you are subscribed to Zim.
> https://bugs.launchpad.net/bugs/1575743
>
> Title:
> Special characters break links, and worse
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zim/+bug/1575743/+subscriptions
>

Frost (lapsang-leaf) wrote :
Download full text (3.6 KiB)

It only seems to apply to certain special characters I’m finding, and to brackets.

Try a link with a ć for instance, or an ā. Either as a new page/sub page or a hyperlink within the page. Any form of link, it doesn’t matter. You will probably see some odd behaviour.

I wish I could give you step-by-step method to reproduce the error but it’s sporadic, unreliable, with different or no results each time. What I have noticed, however, is that if I stop using special characters then the software runs smoothly and stably.

> On 27 Apr 2016, at 20:59, Jaap Karssenberg <email address hidden> wrote:
>
> Sorry to ask, but can you give a more concrete example of the issue? E.g.
> what steps do I need to do to reproduce the issue?
>
> Regards,
>
> Jaap
>
>
> On Wed, Apr 27, 2016 at 5:50 PM Frost <email address hidden> wrote:
>
>> Public bug reported:
>>
>> Hi,
>>
>> I'm using Zim 0.65 on Python 2.7 for OS X 10.11.4.
>>
>> I'm not *entirely* sure I managed to install it properly as the install
>> instructions on the Zim website are out of date and did not work.
>> Therefore every time I want to launch Zim it launches a Python Launcher,
>> Python (proper), and the Terminal. Is that right?
>>
>> I managed to install dependencies with Homebrew OK though. On a side
>> note, your install page could definitely do with a re-write for people
>> who are less savvy.
>>
>> THE MAIN ISSUE:
>>
>> Using special characters (any kind) in a link breaks the link. Not only
>> that, it will either duplicate a page (if a special character is in the
>> title) or delete it. I have learned that the hard way - two day's worth
>> of work vanished because my page had a 'ā' in the title. Even using
>> brackets () in links seems to break them.
>>
>> It's just really frustrating and inconvenient. Can Zim please patch a
>> fix? Or is it me?
>>
>> Cheers.
>>
>> ** Affects: zim
>> Importance: Undecided
>> Status: New
>>
>>
>> ** Tags: character link mac
>>
>> --
>> You received this bug notification because you are subscribed to Zim.
>> https://bugs.launchpad.net/bugs/1575743
>>
>> Title:
>> Special characters break links, and worse
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/zim/+bug/1575743/+subscriptions
>>
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1575743
>
> Title:
> Special characters break links, and worse
>
> Status in Zim:
> New
>
> Bug description:
> Hi,
>
> I'm using Zim 0.65 on Python 2.7 for OS X 10.11.4.
>
> I'm not *entirely* sure I managed to install it properly as the
> install instructions on the Zim website are out of date and did not
> work. Therefore every time I want to launch Zim it launches a Python
> Launcher, Python (proper), and the Terminal. Is that right?
>
> I managed to install dependencies with Homebrew OK though. On a side
> note, your install page could definitely do with a re-write for people
> who are less savvy.
>
> THE MAIN ISSUE:
>
> Using special characters (any kind) in a link breaks the link. Not
> only that, it will either duplicate a page ...

Read more...

Frost (lapsang-leaf) wrote :

This also applies to any link with a closed parenthesis at the end (it will drop the last bracket and therefore break the link). It's really annoying! Can we not have a patch?

Changed in zim:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Zim because there has been no activity for 60 days.]

Changed in zim:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions