Zim

Table Editor install problem

Bug #1538808 reported by Lauri on 2016-01-28

This bug report was converted into a question: question #283826: Table Editor install problem.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zim
Undecided
Unassigned

Bug Description

I tried to unsuccessfully install the Table Editor plugin on Debian 8 with 3.16.0-4-amd64 kernel and gnome 3.14.1 desktop. So basically I ran the command bzr branch lp:~beutlin/zim/table-plugin, located the codes for Table Editor (tableeditor.py), copied it to ~/.local/share/zim/plugins/ restarted first zim and then the entire computer, but still could not see the table editor in the plugins list. zim -D says the following

ERROR: Could not load plugin tableeditor
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/zim/gui/preferencesdialog.py", line 303, in __init__
    klass = self.plugins.get_plugin_class(key)
  File "/usr/lib/python2.7/dist-packages/zim/plugins/__init__.py", line 208, in get_plugin_class
    mod = get_module(modname)
  File "/usr/lib/python2.7/dist-packages/zim/utils.py", line 33, in get_module
    mod = __import__(name)
  File "/usr/lib/python2.7/dist-packages/zim/plugins/tableeditor.py", line 32, in <module>
    from zim.gui.objectmanager import CustomObjectWidget
ImportError: No module named objectmanager

DEBUG: Gtk version is (2, 24, 25)
DEBUG: Pygtk version is (2, 24, 0)

I get the same error also when the tableeditor.py is in the ~/.local/share/zim/plugins/ directory.

Could anyone help me with this problem?

p.s. Zim is really an awesome tool

- Lars

Lauri (larsnurminen) on 2016-01-28
Changed in zim:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions