Zim

Version control with git does not work without a set identity

Bug #1133645 reported by Bernard Schendstok on 2013-02-26
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Zim
Medium
Unassigned

Bug Description

I run Ubuntu 12.04 LTS with Zim 0.59 and git 1.8.1.1.

When using git as version control backend in Zim, I noticed that it does not work out of the box after installing the packages because you haven't set your identy in git yet.
After you save a version "File->Save Version..." and then check the versions "File->Versions...", you will get an error:
Failed to run application: git
git "commit" "-a" "-m" "Saved version from zim"
returned non-zero exit status 128

If you run "git status", you see that this is because the identity isn't set in git ( that can be set using the commands like "git config --global user.name <NAME>" and "git config --global user.email <EMAIL>" ).

Maybe Zim should check if the identity is set? Or maybe you should just mention this step in the manual for the use of version control? For people with experience with git this isn't a big deal, but people who haven't used it may not know how to solve it easily.

Will at least add it to the manual. Checking and prompting the user
for details would be perfect but requires a little more work.

Regards,

Jaap

1.John@seznam.cz (neozvuck) wrote :

>Will at least add it to the manual.

There is another thing for the manual.

After a clean install following the steps above I get the same error,

but "git status" says: fatal: Not a git repository (or any of the parent directories): .git

pisztrang (fox-qohfvj) wrote :

It would be also nice to display stdout/stderr instead of the exit code.

Changed in zim:
status: New → Confirmed
importance: Undecided → Medium
Changed in zim:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers