GError: Unable to trash file: internal error

Reported by Eduardo Matillano on 2012-11-16
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Zim
Medium
Unassigned

Bug Description

This is zim 0.56
Python version is sys.version_info(major=2, minor=7, micro=2, releaselevel='final', serial=0)
Gtk version is (2, 24, 10)
Pygtk version is (2, 24, 0)
Platform is nt
Zim revision is:
  branch: trunk
  revision: 534 <email address hidden>
  date: 2012-04-03 00:07:40 -0400

======= Traceback =======
  File "zim\gui\__init__.pyo", line 826, in _action_handler
  File "zim\gui\__init__.pyo", line 1674, in delete_page
  File "zim\notebook.pyo", line 1688, in trash_page
  File "zim\notebook.pyo", line 1712, in _delete_page
  File "zim\stores\files.pyo", line 175, in trash_page
  File "zim\fs.pyo", line 790, in trash
GError: Unable to trash file: internal error

Can you give a little bit more information, e.g. is this error repeatable?
does it happen always or only for certain files? and what type of file
system, or storage do you use?

Thanks,
Jaap

On Fri, Nov 16, 2012 at 5:37 AM, Eduardo Matillano <email address hidden>wrote:

> Public bug reported:
>
> This is zim 0.56
> Python version is sys.version_info(major=2, minor=7, micro=2,
> releaselevel='final', serial=0)
> Gtk version is (2, 24, 10)
> Pygtk version is (2, 24, 0)
> Platform is nt
> Zim revision is:
> branch: trunk
> revision: 534 <email address hidden>
> date: 2012-04-03 00:07:40 -0400
>
> ======= Traceback =======
> File "zim\gui\__init__.pyo", line 826, in _action_handler
> File "zim\gui\__init__.pyo", line 1674, in delete_page
> File "zim\notebook.pyo", line 1688, in trash_page
> File "zim\notebook.pyo", line 1712, in _delete_page
> File "zim\stores\files.pyo", line 175, in trash_page
> File "zim\fs.pyo", line 790, in trash
> GError: Unable to trash file: internal error
>
> ** Affects: zim
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to Zim.
> https://bugs.launchpad.net/bugs/1079524
>
> Title:
> GError: Unable to trash file: internal error
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/zim/+bug/1079524/+subscriptions
>

Scott Bridges (sabridges) wrote :

This error is repeatable for me. When I try to delete a subpage from the sidepane, and then choose NO in the delete confirmation dialog, it throws the error.

If I confirm the delete, it works fine.

Using Windows 7 Pro (NTFS)

Thanks for all your hard work. I use Zim ALL the time.

Scott Bridges
Port-de-Paix, Haiti

This is zim 0.57
Python version is sys.version_info(major=2, minor=7, micro=3, releaselevel='final', serial=0)
Gtk version is (2, 24, 10)
Pygtk version is (2, 24, 0)
Platform is nt
Zim revision is:
  branch: zim
  revision: 600 <email address hidden>
  date: 2012-10-08 21:17:51 +0200

======= Traceback =======
  File "zim\gui\__init__.pyo", line 797, in _action_handler
  File "zim\gui\__init__.pyo", line 1678, in delete_page
  File "zim\notebook.pyo", line 1700, in trash_page
  File "zim\notebook.pyo", line 1724, in _delete_page
  File "zim\stores\files.pyo", line 175, in trash_page
  File "zim\fs.pyo", line 851, in trash
GError: Unable to trash file: internal error

On Fri, Nov 23, 2012 at 3:11 PM, Scott Bridges
<email address hidden>wrote:

> This error is repeatable for me. When I try to delete a subpage from the
> sidepane, and then choose NO in the delete confirmation dialog, it
> throws the error.
>
> If I confirm the delete, it works fine.
>
> Using Windows 7 Pro (NTFS)
>

Ah, you didn't say the first time that you need to say "No" to trigger this
- that helps :)

Will test when I'm on my windows system.

-- Jaap

Confirmed - seems windows does not cancel nicely but just errors instead :(

Changed in zim:
status: New → Confirmed
importance: Undecided → Medium
Changed in zim:
status: Confirmed → Fix Committed

Fix released in zim 0.60.

Changed in zim:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers