add a getExtensions method

Bug #693861 reported by Jeremy Whiting on 2010-12-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Wishlist
Markus Korn

Bug Description

Bindings libraries need to have a way to know which extensions are installed/running/etc. so they know what aspects to expose bindings for. A method getExtensions would do nicely for this.

Related branches

Seif Lotfy (seif) wrote :

I think its also good for applications that depend on certaing extension to know if an extension is there or not...

Changed in zeitgeist:
assignee: nobody → Seif Lotfy (seif)
milestone: none → 0.7.0
assignee: Seif Lotfy (seif) → nobody
status: New → Confirmed
Seif Lotfy (seif) on 2010-12-24
Changed in zeitgeist:
assignee: nobody → Seif Lotfy (seif)
importance: Undecided → Wishlist
status: Confirmed → In Progress
Seif Lotfy (seif) on 2010-12-25
Changed in zeitgeist:
assignee: Seif Lotfy (seif) → Markus Korn (thekorn)

Since we are applying your patch not mine I assigned you as the person who
fixed it :)

On Sat, Dec 25, 2010 at 3:34 PM, Seif Lotfy <email address hidden>wrote:

> ** Changed in: zeitgeist
> Assignee: Seif Lotfy (seif) => Markus Korn (thekorn)
>
> --
> You received this bug notification because you are subscribed to
> Zeitgeist Framework.
> https://bugs.launchpad.net/bugs/693861
>
> Title:
> add a getExtensions method
>
> Status in Zeitgeist Framework:
> In Progress
>
> Bug description:
> Bindings libraries need to have a way to know which extensions are
> installed/running/etc. so they know what aspects to expose bindings for. A
> method getExtensions would do nicely for this.
>
>
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

Markus Korn (thekorn) wrote :

------------------------------------------------------------
revno: 1650
fixes bug(s): https://launchpad.net/bugs/693861
committer: Markus Korn <email address hidden>
branch nick: trunk
timestamp: Sun 2010-12-26 10:18:11 +0100
message:
  * added a read-only DBus property "extensions" to org.gnome.zeitgeist.Log
    (LP: #693861)
  * added helper methods for this property to ZeitgeistDBusInterface and
    ZeitgeistClient
  * added helper function to get an extension's name
  * fixed bug in RemoteInterface.Quit(): make sure to close connection to the
    used bus if this method gets called, this is needed if RemoteInterface
    does not know anything about the loop it is running in.
------------------------------------------------------------

Changed in zeitgeist:
status: In Progress → Fix Committed
Seif Lotfy (seif) on 2011-01-18
Changed in zeitgeist:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers