zeitgeist crashes in case of non existing .cache folder (KDE)

Bug #686674 reported by Seif Lotfy on 2010-12-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Undecided
Siegfried Gevatter

Bug Description

When trying to run trunk on a fresh KDE install I get

seif@Wumbo-VM:~$ zeitgeist-daemon --replace
Traceback (most recent call last):
  File "/usr/local/bin/zeitgeist-daemon", line 158, in <module>
    setup_logger(_config.options.log_level)
  File "/usr/local/bin/zeitgeist-daemon", line 142, in setup_logger
    os.mkdir(os.path.dirname(log_file))
OSError: [Errno 2] No such file or directory: '/home/seif/.cache/zeitgeist'

This is due to our latest change for logging outputs

Related branches

Seif Lotfy (seif) on 2010-12-07
Changed in zeitgeist:
milestone: none → 0.7.0

Easy to fix

Changed in zeitgeist:
assignee: nobody → Manish Sinha (manishsinha)
Seif Lotfy (seif) on 2010-12-07
Changed in zeitgeist:
status: New → Confirmed
Changed in zeitgeist:
status: Confirmed → In Progress
Markus Korn (thekorn) wrote :

Ohh? Is KDE (or the distro you are using) not using xdg, or why is ~/.cache not there? And if KDE uses something else for such kind of `local log files` we should use this location instead of creating XDG_CACHE with a big hammer.

Seif Lotfy (seif) wrote :

<seiflotfy> ivan|home, u there
<seiflotfy> is there a cache directory for kde
<seiflotfy> ?
* urkud has quit (Read error: Connection reset by peer)
<ivan|home> seiflotfy: .kde/cache
<seiflotfy> ok cool
<ivan|home> cache-hostname - to be precis
<ivan|home> e
<seiflotfy> huh
<seiflotfy> so if we want cache for zeitgeist
<seiflotfy> how woudl it look like
<seiflotfy> .kde/cache-seif/zeitgeist
<seiflotfy> for me ?
<ivan|home> seiflotfy: yes

Wait. KDE doesn't follow xdg basedir?

nope

On Tue, Dec 7, 2010 at 9:54 PM, Manish Sinha <email address hidden>wrote:

> Wait. KDE doesn't follow xdg basedir?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/686674
>
> Title:
> zeitgeist crashes in case of non existing .cache folder (KDE)
>
> Status in Zeitgeist Framework:
> In Progress
>
> Bug description:
> When trying to run trunk on a fresh KDE install I get
>
> seif@Wumbo-VM:~$ zeitgeist-daemon --replace
> Traceback (most recent call last):
> File "/usr/local/bin/zeitgeist-daemon", line 158, in <module>
> setup_logger(_config.options.log_level)
> File "/usr/local/bin/zeitgeist-daemon", line 142, in setup_logger
> os.mkdir(os.path.dirname(log_file))
> OSError: [Errno 2] No such file or directory: '/home/seif/.cache/zeitgeist'
>
> This is due to our latest change for logging outputs
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/zeitgeist/+bug/686674/+subscribe
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

Siegfried Gevatter (rainct) wrote :

Fixed.

The code is using os.makedirs now, instead of os.mkdir.

Changed in zeitgeist:
status: In Progress → Fix Released
Siegfried Gevatter (rainct) wrote :

2010/12/7 Markus Korn <email address hidden>:
> Ohh? Is KDE (or the distro you are using) not using xdg, or why is
> ~/.cache not there?

«KDE supports the base directory specification and the various
environment variables it prescribes in addition to the KDE filesystem
hierarchy.»
http://techbase.kde.org/KDE_System_Administration/XDG_Filesystem_Hierarchy

> And if KDE uses something else for such kind of
> `local log files` we should use this location instead of creating
> XDG_CACHE with a big hammer.

Disagree, the location of stuff shouldn't change depending on with
which session you're logged in (or what directories already exist).

Seif Lotfy (seif) on 2010-12-07
Changed in zeitgeist:
status: Fix Released → Fix Committed
Siegfried Gevatter (rainct) wrote :

(There is no released version affected by this)

Changed in zeitgeist:
status: Fix Committed → Fix Released

Not fixed by me. Siegfried, please put the assign to yourself

Changed in zeitgeist:
assignee: Manish Sinha (manishsinha) → nobody
Seif Lotfy (seif) wrote :

changed it to "fix commited" since it was a bug in trunk and to follow the same line as
https://bugs.launchpad.net/zeitgeist/+bug/683146

Changed in zeitgeist:
status: Fix Released → Fix Committed
assignee: nobody → Siegfried Gevatter (rainct)
Seif Lotfy (seif) on 2011-01-18
Changed in zeitgeist:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers