DB upgrades not backwards compatible (even when their are)

Bug #665607 reported by Siegfried Gevatter on 2010-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Medium
Unassigned

Bug Description

Not sure if we already fixed this, but just in case.

INFO:zeitgeist.sql:Upgrading database 'core' from version 2 to 1. This may take a while
CRITICAL:zeitgeist.sql:Failed to upgrade database 'core' from version 2 to 1: No module named core_2_1

Related branches

Siegfried Gevatter (rainct) wrote :

Proposed fix:

=== modified file '_zeitgeist/engine/sql.py'
--- _zeitgeist/engine/sql.py 2010-09-21 16:15:14 +0000
+++ _zeitgeist/engine/sql.py 2010-10-23 15:41:34 +0000
@@ -114,7 +114,7 @@
        # See if we have the right schema version, and try an upgrade if needed
        core_schema_version = _get_schema_version(cursor, constants.CORE_SCHEMA)
        if core_schema_version is not None:
- if core_schema_version == constants.CORE_SCHEMA_VERSION:
+ if core_schema_version >= constants.CORE_SCHEMA_VERSION:
                        return True
                else:
                        try:

Changed in zeitgeist:
milestone: none → 0.7
milestone: 0.7 → 0.6
importance: Undecided → Medium
status: New → Confirmed
Seif Lotfy (seif) wrote :

Do we want them to be backwards compatible ? Why would someone downgrade zeitgeist ?

Siegfried Gevatter (rainct) wrote :

Because of using a system-wide Zeitgeist installation but testing a Zeitgeist running from trunk.

Oh... this means we need 2_1 scripts for example... right?

On Sat, Oct 23, 2010 at 8:05 PM, Siegfried Gevatter <email address hidden>wrote:

> Because of using a system-wide Zeitgeist installation but testing a
> Zeitgeist running from trunk.
>
> --
> DB upgrades not backwards compatible (even when their are)
> https://bugs.launchpad.net/bugs/665607
> You received this bug notification because you are subscribed to
> Zeitgeist Framework.
>
> Status in Zeitgeist Framework: Confirmed
>
> Bug description:
> Not sure if we already fixed this, but just in case.
>
> INFO:zeitgeist.sql:Upgrading database 'core' from version 2 to 1. This may
> take a while
> CRITICAL:zeitgeist.sql:Failed to upgrade database 'core' from version 2 to
> 1: No module named core_2_1
>
>
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

Siegfried Gevatter (rainct) wrote :

2010/10/23 Seif Lotfy <email address hidden>:
> Oh... this means we need 2_1 scripts for example... right?

No, that's too much of a mess. But for database examples which aren't
backwards-incompatible (like all so far) Zeitgeist should just work
and not crash on this.

Seif Lotfy (seif) wrote :

ah ok :) +1 for ur fix then

On Sat, Oct 23, 2010 at 8:28 PM, Siegfried Gevatter <email address hidden>wrote:

> 2010/10/23 Seif Lotfy <email address hidden>:
> > Oh... this means we need 2_1 scripts for example... right?
>
> No, that's too much of a mess. But for database examples which aren't
> backwards-incompatible (like all so far) Zeitgeist should just work
> and not crash on this.
>
> --
> DB upgrades not backwards compatible (even when their are)
> https://bugs.launchpad.net/bugs/665607
> You received this bug notification because you are subscribed to
> Zeitgeist Framework.
>
> Status in Zeitgeist Framework: Confirmed
>
> Bug description:
> Not sure if we already fixed this, but just in case.
>
> INFO:zeitgeist.sql:Upgrading database 'core' from version 2 to 1. This may
> take a while
> CRITICAL:zeitgeist.sql:Failed to upgrade database 'core' from version 2 to
> 1: No module named core_2_1
>
>
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

Seif Lotfy (seif) on 2010-10-25
Changed in zeitgeist:
status: Confirmed → Fix Committed
Markus Korn (thekorn) on 2010-11-01
Changed in zeitgeist:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers