Check for 'rapper' in configure (raptor-utils)

Bug #595577 reported by Daniel Fore on 2010-06-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Low
Markus Korn

Bug Description

I downloaded 0.4 from this link: http://edge.launchpad.net/zeitgeist/0.4/0.4.0/+download/zeitgeist-0.4.0.tar.gz

./configure

make fails. I needed raptor-utils.

after installing raptor-utils, everything worked fine :)

Markus Korn (thekorn) wrote :

Hi Daniel,
thanks for reporting this issue.
However autogen.sh is checking if you have rapper-utils installed, and should ask you to install rapper-utils if this is not the case.
So I don't think this is a valid bugreport, please reopen if I'm missing something.

Thanks,
Markus

Changed in zeitgeist:
status: New → Invalid

seif@Gary:~/Desktop/zeitgeist-0.4.0$ ./autogen.sh
bash: ./autogen.sh: No such file or directory

Seems like he is right. autogen.sh is not there
but i can do ./configure and it does not check for raptor utils

On Thu, Jun 17, 2010 at 7:09 PM, Markus Korn <email address hidden> wrote:

> Hi Daniel,
> thanks for reporting this issue.
> However autogen.sh is checking if you have rapper-utils installed, and
> should ask you to install rapper-utils if this is not the case.
> So I don't think this is a valid bugreport, please reopen if I'm missing
> something.
>
> Thanks,
> Markus
>
> ** Changed in: zeitgeist
> Status: New => Invalid
>
> --
> compilation fails for 0.4
> https://bugs.launchpad.net/bugs/595577
> You received this bug notification because you are subscribed to The
> Zeitgeist Project.
>
> Status in Zeitgeist Framework: Invalid
>
> Bug description:
> I downloaded 0.4 from this link:
> http://edge.launchpad.net/zeitgeist/0.4/0.4.0/+download/zeitgeist-0.4.0.tar.gz
>
> ./configure
>
> make fails. I needed raptor-utils.
>
> after installing raptor-utils, everything worked fine :)
>
>
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

Hey Markus,

going to go ahead and make this confirmed because both Seif and I don't have autogen.sh :)

Changed in zeitgeist:
status: Invalid → Confirmed

Yeah it's ./configure which should check for it. (autogen.sh isn't
supposed to be in the tarball, that's correct).

Let's get this fixed for 0.4.1

Changed in zeitgeist:
importance: Undecided → Low
milestone: none → 0.4.1
summary: - compilation fails for 0.4
+ Check for 'rapper' in configure (raptor-utils)
Markus Korn (thekorn) wrote :

I will read the docs and find out which macros to use to get a check for rapper in configure.

Changed in zeitgeist:
assignee: nobody → Markus Korn (thekorn)
Markus Korn (thekorn) on 2010-06-18
Changed in zeitgeist:
status: Confirmed → In Progress
Markus Korn (thekorn) on 2010-06-21
Changed in zeitgeist:
status: In Progress → Fix Committed
Seif Lotfy (seif) on 2010-07-14
Changed in zeitgeist:
status: Fix Committed → Fix Released
Changed in zeitgeist:
milestone: 0.4.1 → 0.5.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers