RecentlyUsed data-source crashes trying to access a broken symlink

Bug #523761 reported by Seif Lotfy on 2010-02-18
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Fix Released
Low
Siegfried Gevatter

Bug Description

rtz sent me this bug
DEBUG:zeitgeist.blacklist:No existing blacklist config found
DEBUG:zeitgeist.extension:Loading extension 'DataSourceRegistry'
DEBUG:zeitgeist.datasource_registry:Loaded data-source data from /home/rico/.local/share/zeitgeist/datasources.pickle
DEBUG:root:Checking for another running instance...
DEBUG:root:No running instances found.
INFO:root:Zeitgeist-Service wird gestartet ...
DEBUG:root:Aktualisierung der Datenbank mit neuen Recently Used Documents Objekten
Traceback (most recent call last):
  File "/usr/bin/zeitgeist-datahub", line 108, in _update_db_async
    events = self._sources_queue[0].get_items()
  File "/usr/share/zeitgeist/_zeitgeist/loggers/zeitgeist_base.py", line 84, in get_items
    return self._get_items()
  File "/usr/share/zeitgeist/_zeitgeist/loggers/datasources/recent.py", line 286, in _get_items
    desktopfile = self._find_desktop_file_for_application(application)
  File "/usr/share/zeitgeist/_zeitgeist/loggers/datasources/recent.py", line 260, in _find_desktop_file_for_application
    for line in open(fullname):
IOError: [Errno 2] No such file or directory: '/usr/share/applications/openoffice.org3-startcenter.desktop'

Rico Tzschichholz (ricotz) wrote :

This error is invalid, sorry. Seems to be an installation problem of openoffice 3.2 build.

Changed in zeitgeist:
status: New → Invalid
diazsp (diazsp) wrote :

I'm not a super skilled linux user, but I had this problem too and solved it. If you go and look in the folder '/usr/share/applications/openoffice.org3-startcenter.desktop' you'll see that it's a link that's broken. I was able to see where it was supposed to link to by looking at the file properties. Went and checked there and sure enough that file was missing. Must not be part of OOo 3.2. So I copied one of the .desktop files their and put in the command 'soffice' (assuming that is startcenter) and renamed it "startcenter.desktop" That fixed the broken link and now zeitgeist-daemon is running. The only things showing in activity journal are from today. But my guess is it will start tracking from today forward. I had Activity journal working just fine until I upgraded to OOo 3.2 ... I missed it so I got down fixing it today! I hope this helps someone!

Siegfried Gevatter (rainct) wrote :

Thank you both for reporting and tracing down this problem; now that we know its cause I am re-opening this, as while it is indeed caused by an error with some OpenOffice.org package, zeitgeist-datahub should be more resilient and not crash because of it. I'll fix the problem this afternoon once I arrive home.

Changed in zeitgeist:
assignee: nobody → Siegfried Gevatter (rainct)
importance: Undecided → Low
milestone: none → 0.3.3
status: Invalid → Confirmed
Changed in zeitgeist:
status: Confirmed → Fix Released
summary: - Error logging from recentlyused
+ RecentlyUsed data-source crashes trying to access a broken symlink
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers