zeitgeist-daemon errors with "No module named notify"

Bug #497140 reported by Jamal Fanaian on 2009-12-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Framework
Invalid
Undecided
Unassigned

Bug Description

make install doesn't seem to be copying _zeitgeist/engine/notify.py as it can't be found by zeitgeist-daemon. Copying it manually to /usr/local/share/zeitgeist/_zeitgeist/engine/ fixes the issue.

Traceback (most recent call last):
  File "/usr/local/bin/zeitgeist-daemon", line 47, in <module>
    from _zeitgeist.engine.remote import RemoteInterface
  File "/usr/local/share/zeitgeist/_zeitgeist/engine/remote.py", line 28, in <module>
    from _zeitgeist.engine.notify import MonitorManager
ImportError: No module named notify

Changed in zeitgeist:
milestone: none → 0.3.1
Markus Korn (thekorn) wrote :

Siegfried, do yo happen to know what's going on here. In my understanding everything should work just fine, as notify.py is in _zeitgeist/engine/Makefile.am

2009/12/15 Markus Korn <email address hidden>:
> Siegfried, do yo happen to know what's going on here.

No, not really.

Jamal, have you run ./autogen.sh before running "make; sudo make install"?

Jamal Fanaian (jamalta) wrote :

Oh, apparently that was the issue. Silly me. I didn't realize you had to run
./autogen.sh. I did run ./configure to make sure that wasn't the issue, but
apparently that wasn't enough.

Thanks!

On Tue, Dec 15, 2009 at 4:05 PM, Siegfried Gevatter <email address hidden>wrote:

> 2009/12/15 Markus Korn <email address hidden>:
> > Siegfried, do yo happen to know what's going on here.
>
> No, not really.
>
>
> Jamal, have you run ./autogen.sh before running "make; sudo make install"?
>
> --
> zeitgeist-daemon errors with "No module named notify"
> https://bugs.launchpad.net/bugs/497140
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in zeitgeist:
status: New → Confirmed
status: Confirmed → Won't Fix
status: Won't Fix → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers