fts can SIGSEGV ZG during reindex

Bug #617309 reported by Michal Hruby on 2010-08-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Extensions
High
Mikkel Kamstrup Erlandsen
zeitgeist-extensions (Ubuntu)
Undecided
Unassigned

Bug Description

Any search query while FTS is reindexing the DB will cause a SIGSEGV.

Changed in zeitgeist-extensions:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → High
status: New → Triaged

revno: 67
fixes bug(s): https://launchpad.net/bugs/617309
committer: Mikkel Kamstrup Erlandsen <email address hidden>
branch nick: MASTER
timestamp: Mon 2011-09-05 11:51:19 +0200
message:
  Fix bug "fts can SIGSEGV ZG during reindex". This was caused by searching while rebuilding the index. The Xapian API is not thread safe in any shape or form so protect all read and write access with a lock.

Changed in zeitgeist-extensions:
status: Triaged → Fix Committed

If you want to try and help verify that this bug is indeed fixed you need at least r67 of the fts extension. Then open d-feet and run the ForceReindex() method on the index - and quickly open Synapse or the Unity dash and type a search string.

As this is a race it may or may not be elusive. So run the above a few times.

Changed in zeitgeist-extensions:
milestone: none → fts-0.0.12
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeitgeist-extensions - 0.0.12-0ubuntu1

---------------
zeitgeist-extensions (0.0.12-0ubuntu1) oneiric; urgency=low

  * New upstream release:
    - fts can SIGSEGV ZG during reindex (LP: #617309)
    - zeitgeist-daemon crashed with RuntimeError in _check_index():
      basic_string::assign (LP: #839740)
    - Blowing Xapian max term length corrupts index (LP: #843668)
    - Can't recover from FTS index corruption (LP: #705944)
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 11:25:16 +0200

Changed in zeitgeist-extensions (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers