Firefox extension doesn't work with FF5

Bug #800169 reported by Artem on 2011-06-21
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Zeitgeist Data-Sources
High
Mark Tully

Bug Description

TypeError: Components.classes['@zeitgeist-project.com/DATAPROVIDER/firefox-xpcom;1'] is undefined
looks like XPCOM API has been changed again

Looks like Mozilla has no objection to breaking hundreds and thousands of Addons which made it so much popular

More information
https://groups.google.com/forum/#!topic/mozilla.dev.extensions/LWlCxE8wO2I

Artem (leipreachan) wrote :

bsmedberg pointed out that not that many addon has binary component.

My usage of the term thousand was just a joke. I know there are not thousand
binary addons, but I guess there might be around hundred
On Jun 22, 2011 12:41 PM, "tricote" <email address hidden> wrote:
> bsmedberg pointed out that not that many addon has binary component.
>
> --
> You received this bug notification because you are subscribed to
> Zeitgeist Data-Sources.
> https://bugs.launchpad.net/bugs/800169
>
> Title:
> Firefox extension doesn't work with FF5
>
> Status in Zeitgeist Data-Sources:
> New
>
> Bug description:
> TypeError: Components.classes['@
zeitgeist-project.com/DATAPROVIDER/firefox-xpcom;1'] is undefined
> looks like XPCOM API has been changed again
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/zeitgeist-datasources/+bug/800169/+subscriptions

It has been a week since firefox 5. 5 more weeks to firefox 6 when the API
will break again.

The bigger questions is that till when can we deal with Firefox shifting the
goalposts? I am no XPCOM API expert, but is the firefox datasource feasible?
It would be too bad if it turns into a unmaintained codebase :(

Artem (leipreachan) wrote :

Any chance this issue will be fixed.. ever?

Firefox 6 will again break the XPCOM API and this extension will again break. Looking at the extraordinary release schedule of Firefox, would it be feasible to keep it maintained? The root of the problem is constantly breaking XPCOM API (not ABI)

Mark Tully (markjtully) wrote :

I've been looking at js-ctypes (https://developer.mozilla.org/en/js-ctypes, https://developer.mozilla.org/en/js-ctypes/Using_js-ctypes) as a solution to the problem of the changing XPCOM API, and have managed to create a version of the dataprovider which uses them.

Js-ctypes have a number of advantages over using C++ components in the extension:
  1: The extension doesn't require building as it is all Javascript. Creating the .xpi is a matter of compressing the files, renaming it an .xpi and copying it to the required location.
  2: The extension should need minimal maintenance as the Firefox version increases (mainly just bumping the max version in its install.rdf file)
  3: The method used should be able to be reused to create extensions for other Mozilla products (Thunderbird and Lightning) with minimal difficulty compared to using XPCOM

Js-ctypes were introduced in Firefox 4, so the existing XPCOM extension would still need to be maintained for Firefox 3.6.

Attached is a new version of the Firefox extension which works (at least, it does on my system). The main requirement is that "/usr/lib/libzeitgeist-1.0.so" exists on the system (either as a file or as a link to another file). I am uncertain if this is the most appropriate file to point the extension at. It exists as a link to "/usr/lib/libzeitgeist-1.0.so.1.0.3", but it seems the most generically named libzeitgeist file in my lib folder, so I'm assuming it's the most likely to exist everywhere. I've tried to retain all the features of the original extension, but I'm unsure if the ignored_uris and enable_googlemail parts work correctly.

Artem (leipreachan) wrote :

Hi Mark!

I'm testing your version and it seems it's working great!

Thanks!

Mark Tully (markjtully) on 2011-08-24
Changed in zeitgeist-datasources:
status: New → In Progress
assignee: nobody → Teester (markjtully)

Teester, I am on Firefox 7 and this doesn't seem to work. Can you check it out

Just checked. It actually works. Looks like activity-journal isnt working on my computer

Changed in zeitgeist-datasources:
importance: Undecided → High

Fixed. This and Firefox 3.5 datasource will make it into next release

Changed in zeitgeist-datasources:
milestone: none → 0.8.1
status: In Progress → Fix Committed

Tested this on firefox 6 and it worked great. Thanks for your work!

Not to mention that I have merged it. It is surely an amazing work.

Next up the line is improving the Thunderbird addon which he created

Changed in zeitgeist-datasources:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers