Don't log *.part files in Downloads folder

Bug #940907 reported by Omar Campagne on 2012-02-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zeitgeist Datahub
Medium
Siegfried Gevatter

Bug Description

Hello:

I really like Downloads folder being monitored, really handy! The problem is that FF
creates a *.part file until the download is finished, so in the end you get two files in the DB, yet
the *.part one has ceased to exist and is redundant.

I'll humbly recommend:

a) Just keep the $filename*.part file in DB until $filename appears/is complete, which I guess
can be a PITA since you'll have to do checks and DB deletions.

b) Don't log *.part files at all. Since most cannot be opened anyway, being incomplete files,
I don't think not-logging *.part files will be a loss.

Related branches

Hi Omar,

Nice catch, I agree b) would make sense.

Michal, what do you think?

Michal Hruby (mhr3) wrote :

Yep, b) sounds reasonable.

Changed in zeitgeist-datahub:
status: New → Confirmed
importance: Undecided → Medium
Changed in zeitgeist-datahub:
assignee: nobody → Siegfried Gevatter (rainct)
status: Confirmed → Fix Committed
Michal Hruby (mhr3) on 2012-03-20
Changed in zeitgeist-datahub:
milestone: none → 0.8.2
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers