Buildout -- Software for automating application assembly

versions aren't fetched intelligent

Reported by mr_savage on 2008-07-30
4
Affects Status Importance Assigned to Milestone
Buildout
Undecided
Unassigned

Bug Description

buildout seems to fetch dependencies when running buildout without intelligence. Example:

buildout config containing eggs package.x, package.y

package.x requires package.z <0.2
package.y requires package.z

running buildout:

buildout now may fetch the latest version of package.z ( e.g. 0.3) when proceding package.y
proceding package.x will lead to a version conflict.

Suggestion:
buildout should download <0.2 as package.y doesn't state a version number

Domen Kožar (ielectric+) wrote :

Could you make a gist that represents this issue?

Changed in zc.buildout:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers