Failed to add mysql db as pool

Bug #1334470 reported by Feilong Wang on 2014-06-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zaqar
High
Feilong Wang
Juno
High
Feilong Wang

Bug Description

When adding pool with mysql database, user will run into 400 error, and below error message. Though the connection uri is correct.

{
"title":"Invalid request body",
"description":"cannot connect to mysql://root:passw8rd@localhost"
}

Feilong Wang (flwang) on 2014-06-26
Changed in marconi:
importance: Undecided → Critical
assignee: nobody → Fei Long Wang (flwang)
peng fei wang (wpf) wrote :

if mysql = xxx mapping in setup.cfg which like sqlite is not the best way, then we need to map sqlite & mysql to sqlalchemy in code level

Changed in marconi:
status: New → Confirmed
Kurt Griffiths (kgriffs) wrote :

We need to decide if fixing this is worth the effort right now. I'd like to propose the following:

1. Decouple pool management from data storage (two separate drivers)
2. Keep pool management driver for sqla, but drop the sqla data storage driver.

Feilong Wang (flwang) on 2014-06-26
Changed in marconi:
importance: Critical → High
Feilong Wang (flwang) wrote :

I'm setting this as 'Won't Fix', since the sql driver for pool node will be disabled. see https://blueprints.launchpad.net/marconi/+spec/disable-sqlalchemy-as-pool

Changed in marconi:
status: Invalid → Won't Fix
milestone: juno-3 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers