Remove argument enforce_type for method set_override/set_default

Bug #1712255 reported by ChangBo Guo(gcb) on 2017-08-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cue
Undecided
Rajat Sharma
Poppy
Undecided
zhangyangyang
Vitrage
New
Undecided
Rajat Sharma
bilean
Undecided
Rajat Sharma
networking-dpm
Undecided
Rajat Sharma
oslo.config
Medium
Rajat Sharma
zaqar
Undecided
Rajat Sharma

Bug Description

kwarg enforce_type is deprecated for removal in 3a8ba0f8ea5a691cc0cb4cd83f07feb26b4d1267 and will be removed in version 5.0.

http://codesearch.openstack.org/?q=enforce_type&i=nope&files=&repos=

This is part of https://etherpad.openstack.org/p/oslo-queens-tasks
please use add gerrit topic oslo-debt-cleanup, that's easy to track the reviews

Rajat Sharma (tajar29) on 2017-08-22
Changed in cue:
assignee: nobody → Rajat Sharma (tajar29)
Changed in bilean:
assignee: nobody → Rajat Sharma (tajar29)
Changed in oslo.config:
assignee: nobody → Rajat Sharma (tajar29)
maxinjian (maxinjian) wrote :

In rally, method enforce_type only exists in release notes, so it is not a bug in rally:
doc/release_notes/archive/v0.2.0.rst
149 * #1517839: Make CONF.set_override with parameter enforce_type=True by default

Changed in rally:
assignee: nobody → maxinjian (maxinjian)
Rajat Sharma (tajar29) on 2017-08-24
Changed in poppy:
assignee: nobody → Rajat Sharma (tajar29)
Changed in vitrage:
assignee: nobody → Rajat Sharma (tajar29)
Changed in zaqar:
assignee: nobody → Rajat Sharma (tajar29)
Rajat Sharma (tajar29) on 2017-08-24
Changed in networking-dpm:
assignee: nobody → Rajat Sharma (tajar29)
description: updated
Rajat Sharma (tajar29) on 2017-08-25
Changed in poppy:
assignee: Rajat Sharma (tajar29) → nobody
Andrey Kurilin (andreykurilin) wrote :

@maxinjian: thanks for checking

Changed in rally:
status: New → Invalid
no longer affects: rally

The networking-dpm fix has merged: https://review.openstack.org/#/c/497104/

Changed in networking-dpm:
status: New → Fix Committed
Changed in poppy:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in solum:
assignee: nobody → zhangyangyang (zhangyangyang)
Changed in solum:
status: New → In Progress

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/501990

no longer affects: solum
Changed in networking-dpm:
status: Fix Committed → Fix Released
Ben Nemec (bnemec) on 2018-05-09
Changed in oslo.config:
status: New → Triaged
importance: Undecided → Medium
Ben Nemec (bnemec) wrote :

It looks like the only remaining reference to this is in poppy: https://review.openstack.org/#/c/501989

Unfortunately, that project has seen one commit in the past year and a half so I'm not sure it will ever merge. At this point I don't think we would block on one project. If someone starts working on it again they just need to merge the very simple patch to unblock things.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers