token authorization failing at zaqar-server using zaqarclient

Bug #1495982 reported by Venkata Mahesh Jonnalagadda on 2015-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zaqar
Undecided
Unassigned

Bug Description

I have a setup like - kilo devstack on one vm and zaqar-server (kilo) & zaqarclient (0.1.1) on another vm. And enabled keystone authtoken configuration in zaqar.conf.

When I tried to get the list of queues using zaqarclient, I am seeing "Invalid user token - rejecting request" error in zaqar logs. zaqarclient token authorization failing at zaqar-server.

For more details, I am providing below configuration & logs -

# keystone auth configuration in zaqar.conf

http://paste.openstack.org/show/443964/

# zaqar-server console output :

2015-09-03 08:16:11.781 1698 INFO keystonemiddleware.auth_token [-] Invalid user token - rejecting request
10.10.0.8 - - [03/Sep/2015 08:16:11] "GET /v1/queues HTTP/1.1" 401 23

# zaqarclient output :

http://paste.openstack.org/show/443965/

Further, I didn't found an option to see how zaqarclient sending GET request with headers to zaqar-server to verify why this keystone authorization is failing!

description: updated
Feilong Wang (flwang) wrote :

Can you reproduce it without zaqar client? Like using curl or any http client plugin of browser? Technically, I don't think it's related to the data driver, since now the queues are saved in control plane. BTW, are you enabling pooling? Thanks.

Its working fine using curl.
I am seeing issue only when I run using zaqar client.
Didn't enabled pooling.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers