ValueError occuring while debugging Zaqar tests

Bug #1407786 reported by Shaifali Agrawal on 2015-01-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
zaqar
Low
Unassigned

Bug Description

While debugging tests/unit/storage/test_pool_queues.py and tests/unit/storage/test_impl_mongodb.py test cases "ValueError: Duplicate test id detected: zaqar.tests.unit.transport.wsgi.v1.test_auth.TestAuth.test_auth_install" occurs.

Could you provide more details on how to reproduce this? Also add... expected behavior and actual behavior. Thanks for reporting, good catch!

Changed in zaqar:
status: New → Incomplete

Without any break point, when I tried to run testr command *python -m testtools.run discover --load-list tests/unit/storage/test_pool_queues.py* --> got duplicate test id issue rather normal output of success.

Also I have tried to use testr with adding few break points using pdb.set_trace and also with nose.tools.set_trace() inside methods test_ping() and tearDown(); but all the time getting same Error.

Changed in zaqar:
status: Incomplete → Confirmed
importance: Undecided → Low
Tamer Tas (tamertas) wrote :

I have also encountered this bug when I pushed a documentation related change in jenkins gate logs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers