Return 403 response when deleting a message with an invalid claim

Bug #1354513 reported by prashanth raghu on 2014-08-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zaqar
Undecided
peng fei wang

Bug Description

Deleting a message with an invalid claim currently returns with a 204 response code. It would be more appropriate to return a 403 NotPermitted response.

Changed in marconi:
status: New → Confirmed
peng fei wang (wpf) on 2014-08-12
Changed in marconi:
assignee: nobody → peng fei wang (wpf)
peng fei wang (wpf) wrote :

I cannot reproduce by

<wpf> 1 , put a queue
<wpf> 2, post messages
<wpf> 3 create a claim
<wpf> 3 delete messages with /messages?{valid_message_id}?claim_id={invalid_claim_id}
<wpf> 4 then 403 returned with the explanation

Changed in marconi:
status: Confirmed → Invalid
status: Invalid → Incomplete
peng fei wang (wpf) wrote :

204 returned with the successful deletion

wangxiyuan (wangxiyuan) on 2017-05-15
tags: added: bugsmash
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers