[queues/mongodb] Use a single namespace for catalogue and shards DBs

Bug #1246373 reported by Allele Dev on 2013-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zaqar
Low
Cindy Pallares

Bug Description

Just as the name says. Instead of using:

    @property
    def shards_database():

    @property
    def catalogue_database():

Just use self.mongo_conf.database directly.

Zhihao Yuan (zyuan) wrote :

+1

Changed in marconi:
assignee: nobody → Cindy Pallares (cindy-pallaresq)
Changed in marconi:
importance: Undecided → Low

Fix proposed to branch: master
Review: https://review.openstack.org/64719

Changed in marconi:
status: New → In Progress

Reviewed: https://review.openstack.org/64719
Committed: https://git.openstack.org/cgit/openstack/marconi/commit/?id=1d47c602b0cfb3e68226bef05ae7af05cfb97155
Submitter: Jenkins
Branch: master

commit 1d47c602b0cfb3e68226bef05ae7af05cfb97155
Author: cpallares <email address hidden>
Date: Thu Jan 2 13:49:40 2014 -0600

    Change shards & catalogue db into single property

    Refactoring the shards and catalogue mongo database methods into a
    single method because there's no need for these to access different
    logical databases.

    Change-Id: Ia75df73dcdb31e88473878f6c55abcf159f1aa44
    Closes-Bug: #1246373

Changed in marconi:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2014-01-22
Changed in marconi:
milestone: none → icehouse-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-04-17
Changed in marconi:
milestone: icehouse-2 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers