Autoreconnect not handled in all cases

Bug #1214973 reported by Kurt Griffiths
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zaqar
Fix Released
Medium
Kurt Griffiths
Icehouse
Fix Released
Medium
Kurt Griffiths

Bug Description

MongoDB Driver should automatically retry on AutoReconnect exceptions for at least message inserts and deletes.

Kurt Griffiths (kgriffs)
Changed in marconi:
importance: Undecided → High
Kurt Griffiths (kgriffs)
Changed in marconi:
status: New → Confirmed
status: Confirmed → Triaged
Changed in marconi:
assignee: nobody → Flavio Percoco (flaper87)
Kurt Griffiths (kgriffs)
Changed in marconi:
assignee: Flavio Percoco (flaper87) → Kurt Griffiths (kgriffs)
Kurt Griffiths (kgriffs)
Changed in marconi:
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to marconi (master)

Fix proposed to branch: master
Review: https://review.openstack.org/51006

Kurt Griffiths (kgriffs)
Changed in marconi:
milestone: none → icehouse-2
Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Fix proposed to branch: master
Review: https://review.openstack.org/75165

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to marconi (master)

Reviewed: https://review.openstack.org/75165
Committed: https://git.openstack.org/cgit/openstack/marconi/commit/?id=c13fb6f93eba49f88d88820d0c06b3d4be89d558
Submitter: Jenkins
Branch: master

commit c13fb6f93eba49f88d88820d0c06b3d4be89d558
Author: kgriffs <email address hidden>
Date: Thu Jan 30 11:09:31 2014 -0600

    fix(MongoDB): Driver does not retry on AutoReconnect errors

    When a primary MongoDB node fails over to a secondary, pymongo raises an
    AutoReconnect error. Let's catch that and retry the operation so that
    we truly are Highly Available (in the sense that the user will never notice
    the few ms of "downtime" caused by a failover).

    This is particularly important when hosting backend with a DBaaS that
    routinely fails over the master as a way of compacting shards.

    NOTE: In order to get all MongoDB tests green, a tiny unrelated bug in
    test_shards was fixed as part of this patch.

    Closes-Bug: 1214973
    Change-Id: Ibf172e30ec6e7fa0bbb8fdcebda9e985d1e49714

Changed in marconi:
status: In Progress → Fix Committed
Thierry Carrez (ttx)
Changed in marconi:
status: Fix Committed → Fix Released
Thierry Carrez (ttx)
Changed in marconi:
milestone: icehouse-rc1 → 2014.1
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers