remove gunicorn and use wsgiref

Bug #1187280 reported by Flavio Percoco
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zaqar
Fix Released
High
Flavio Percoco

Bug Description

Lets let deployers chose whatever they prefer, gunicorn shouldn't be a dependency.

Changed in marconi:
importance: Undecided → High
assignee: nobody → Flavio Percoco (flaper87)
milestone: none → havana-2
status: New → Confirmed
status: Confirmed → Triaged
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to marconi (master)

Fix proposed to branch: master
Review: https://review.openstack.org/31620

Changed in marconi:
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to marconi (master)

Reviewed: https://review.openstack.org/31620
Committed: http://github.com/stackforge/marconi/commit/61765db141f058aff2b48c1e5d06b8e44c8042b3
Submitter: Jenkins
Branch: master

commit 61765db141f058aff2b48c1e5d06b8e44c8042b3
Author: Flaper Fesp <email address hidden>
Date: Tue Jun 4 10:02:25 2013 +0200

    Replace gunicorn with wsgiref

    The patch replaces gunicorn with wsgiref since it doesn't make sense to
    have gunicorn as dependency. Lets let deployers choose whatever the
    prefer to use as container.

    The patch also removes lib/* since marconi_paste is not needed anymore,
    the wsgi app can now be accessed through:

        `marconi.transport.wsgi.app:app`

    Backward incompatible change: bind refers now to the host and a new
    config variable was introduced to specify the port it should bind to.

    Fixes bug: #1187280
    Implements blueprint: transport-wsgi

    Change-Id: I9f7767ace5c6553e75e2f4587032d7d64b9537c4

Changed in marconi:
status: In Progress → Fix Committed
Changed in marconi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers