'scope' attribute for wizard modal is deprecated

Bug #1647995 reported by Shu Muto
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Zaqar-ui
Critical
Shu Muto

Bug Description

'scope' option in 'horizon.framework.widgets.modal.wizard-modal.service' is deprecated in Ocata.
This will be removed in Queens.

Shu Muto (shu-mutou)
Changed in zaqar-ui:
importance: Undecided → High
Shu Muto (shu-mutou)
Changed in zaqar-ui:
importance: High → Critical
Shu Muto (shu-mutou)
Changed in zaqar-ui:
milestone: none → queens-1
status: New → Triaged
Shu Muto (shu-mutou)
Changed in zaqar-ui:
assignee: nobody → Shu Muto (shu-mutou)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to zaqar-ui (master)

Fix proposed to branch: master
Review: https://review.openstack.org/497127

Changed in zaqar-ui:
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to zaqar-ui (master)

Reviewed: https://review.openstack.org/497127
Committed: https://git.openstack.org/cgit/openstack/zaqar-ui/commit/?id=d4b03832ed86500f2f26ea2041b422b1b87bdaac
Submitter: Jenkins
Branch: master

commit d4b03832ed86500f2f26ea2041b422b1b87bdaac
Author: Shu Muto <email address hidden>
Date: Thu Aug 24 17:00:52 2017 +0900

    Un-use 'scope' attribute for wizard modal service

    'scope' attribute for wizard modal service is deprecated.
    It will be removed on Queens.
    So this patch changes not to use 'scope' attribute.

    Change-Id: Id716858468fcb05dcce9160809308b4213da923c
    Closes-Bug: #1647995

Changed in zaqar-ui:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to zaqar-ui (master)

Fix proposed to branch: master
Review: https://review.openstack.org/500673

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to zaqar-ui (master)

Reviewed: https://review.openstack.org/500673
Committed: https://git.openstack.org/cgit/openstack/zaqar-ui/commit/?id=89e908c5a2eb968230a799b48fff2c88c1fb1702
Submitter: Jenkins
Branch: master

commit 89e908c5a2eb968230a799b48fff2c88c1fb1702
Author: Shu Muto <email address hidden>
Date: Tue Sep 5 13:55:55 2017 +0900

    Fix queue create/update without metadata modification

    When metadata is not modified in queue create/update, the operation
    failed. This problem was caused by the patch that changing `$scope`
    handling[1]. This patch fixes it.

    [1] https://review.openstack.org/#/c/497127/

    Change-Id: Ia7a524c5991c63caa24be7effc1a3bdfb8f914c4
    Closes-Bug: #1647995

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/zaqar-ui 4.0.0.0b1

This issue was fixed in the openstack/zaqar-ui 4.0.0.0b1 development milestone.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to zaqar-ui (stable/pike)

Fix proposed to branch: stable/pike
Review: https://review.openstack.org/552426

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to zaqar-ui (stable/pike)

Reviewed: https://review.openstack.org/552426
Committed: https://git.openstack.org/cgit/openstack/zaqar-ui/commit/?id=8ff71dc31f1f7ad0ecd812f8d84b16b274da0bef
Submitter: Zuul
Branch: stable/pike

commit 8ff71dc31f1f7ad0ecd812f8d84b16b274da0bef
Author: Shu Muto <email address hidden>
Date: Tue Sep 5 13:55:55 2017 +0900

    Fix queue create/update without metadata modification

    When metadata is not modified in queue create/update, the operation
    failed. This problem was caused by the patch that changing `$scope`
    handling[1]. This patch fixes it.

    [1] https://review.openstack.org/#/c/497127/

    Change-Id: Ia7a524c5991c63caa24be7effc1a3bdfb8f914c4
    Closes-Bug: #1647995
    (cherry picked from commit 89e908c5a2eb968230a799b48fff2c88c1fb1702)

tags: added: in-stable-pike
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/zaqar-ui 3.0.1

This issue was fixed in the openstack/zaqar-ui 3.0.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers