Using Super<p> to play/pause causes time left to change randomly

Bug #1393027 reported by Prashant L Rao on 2014-11-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Yarock
Medium
SebastienAmar

Bug Description

The song lengths are listed correctly in the playlist but for the currently playing song wrong values are reported and these change when you pause/stop and play. E.g. I'm playing Dancing Queen which is listed as 3:51 in the playlist but it's showing 5:09 to begin with in the bottom bar. When I hit pause it changes to 36:23. Press play and now it shows 54:34. I built yarock from source on Ubuntu 14.04 using the gstreamer1.0 phonon backend.

description: updated
description: updated

Hi,

thanks for testing my player and for your feedback. I don't have this issue
on my system.
So if you want to help me, can you test again with the yarock snapshot I
send to you.

You can just build it to see if problem is solved. If it's ok I will put
this bugfix for the next release.

Have a good day,
Regards,
Sebastien

2014-11-15 17:14 GMT+01:00 Prashant L Rao <email address hidden>:

> ** Description changed:
>
> - While playing back music I use Super<p> (default shortcut) to
> - play/pause. Till then the display of the song's length is correct. Once
> - I pause and restart playback (Super <p> twice), the number changes to an
> - incorrect one and it keeps on changing randomly every time the shortcut
> - key is pressed.
> + The song lengths are listed correctly in the playlist but for the
> + correctly playing song wrong values are reported and these change when
> + you pause/stop and play. E.g. I'm playing Dancing Queen which is listed
> + as 3:51 in the playlist but it's showing 5:09 to begin with in the
> + bottom bar. When I hit pause it changes to 36:23. Press play and now it
> + shows 54:34. I built yarock from source on Ubuntu 14.04 using the
> + gstreamer1.0 phonon backend.
>
> ** Description changed:
>
> The song lengths are listed correctly in the playlist but for the
> - correctly playing song wrong values are reported and these change when
> + currently playing song wrong values are reported and these change when
> you pause/stop and play. E.g. I'm playing Dancing Queen which is listed
> as 3:51 in the playlist but it's showing 5:09 to begin with in the
> bottom bar. When I hit pause it changes to 36:23. Press play and now it
> shows 54:34. I built yarock from source on Ubuntu 14.04 using the
> gstreamer1.0 phonon backend.
>
> --
> You received this bug notification because you are subscribed to Yarock.
> https://bugs.launchpad.net/bugs/1393027
>
> Title:
> Using Super<p> to play/pause causes time left to change randomly
>
> Status in Yarock Qt4 Modern Music Player:
> New
>
> Bug description:
> The song lengths are listed correctly in the playlist but for the
> currently playing song wrong values are reported and these change when
> you pause/stop and play. E.g. I'm playing Dancing Queen which is
> listed as 3:51 in the playlist but it's showing 5:09 to begin with in
> the bottom bar. When I hit pause it changes to 36:23. Press play and
> now it shows 54:34. I built yarock from source on Ubuntu 14.04 using
> the gstreamer1.0 phonon backend.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/yarock/+bug/1393027/+subscriptions
>

Prashant L Rao (prashant-rao) wrote :
Download full text (4.5 KiB)

Hi,

First off, thanks for building such a beautiful app. It is one of the
nicest looking music players I have seen on any platform.

I compiled and ran the version that you attached. The problem is partially
fixed.

Now what happens is that when I start playback, the length is incorrect.
Then I press pause and it corrects itself to the right value. Press play
and again it goes wrong. Pause, again it is right. Play, again wrong. Then
a couple of toggles, it's correct. Then again wrong.

The primary change I can see is pressing pause always fixes the length
value in this new version.

Do let me know if I can help with any further testing/information.

Regards

Prashant L Rao

On Sun, Nov 16, 2014 at 12:15 PM, SebastienAmar <email address hidden>
wrote:

> Hi,
>
> thanks for testing my player and for your feedback. I don't have this issue
> on my system.
> So if you want to help me, can you test again with the yarock snapshot I
> send to you.
>
> You can just build it to see if problem is solved. If it's ok I will put
> this bugfix for the next release.
>
> Have a good day,
> Regards,
> Sebastien
>
>
> 2014-11-15 17:14 GMT+01:00 Prashant L Rao <email address hidden>:
>
> > ** Description changed:
> >
> > - While playing back music I use Super<p> (default shortcut) to
> > - play/pause. Till then the display of the song's length is correct. Once
> > - I pause and restart playback (Super <p> twice), the number changes to
> an
> > - incorrect one and it keeps on changing randomly every time the shortcut
> > - key is pressed.
> > + The song lengths are listed correctly in the playlist but for the
> > + correctly playing song wrong values are reported and these change when
> > + you pause/stop and play. E.g. I'm playing Dancing Queen which is listed
> > + as 3:51 in the playlist but it's showing 5:09 to begin with in the
> > + bottom bar. When I hit pause it changes to 36:23. Press play and now it
> > + shows 54:34. I built yarock from source on Ubuntu 14.04 using the
> > + gstreamer1.0 phonon backend.
> >
> > ** Description changed:
> >
> > The song lengths are listed correctly in the playlist but for the
> > - correctly playing song wrong values are reported and these change when
> > + currently playing song wrong values are reported and these change when
> > you pause/stop and play. E.g. I'm playing Dancing Queen which is listed
> > as 3:51 in the playlist but it's showing 5:09 to begin with in the
> > bottom bar. When I hit pause it changes to 36:23. Press play and now it
> > shows 54:34. I built yarock from source on Ubuntu 14.04 using the
> > gstreamer1.0 phonon backend.
> >
> > --
> > You received this bug notification because you are subscribed to Yarock.
> > https://bugs.launchpad.net/bugs/1393027
> >
> > Title:
> > Using Super<p> to play/pause causes time left to change randomly
> >
> > Status in Yarock Qt4 Modern Music Player:
> > New
> >
> > Bug description:
> > The song lengths are listed correctly in the playlist but for the
> > currently playing song wrong values are reported and these change when
> > you pause/stop and play. E.g. I'm playing Dancing Queen which is
> > listed as 3:51 in the playlist but...

Read more...

Download full text (5.9 KiB)

Thanks you, I appreciate. I try to do my best, but it's not so easy
something, especially when I can not reproduced bugs.

You will find another snapshot with a better solution (I hope) for the
track length.

Thanks you for helping.

2014-11-16 12:16 GMT+01:00 Prashant L Rao <email address hidden>:

> Hi,
>
> First off, thanks for building such a beautiful app. It is one of the
> nicest looking music players I have seen on any platform.
>
> I compiled and ran the version that you attached. The problem is partially
> fixed.
>
> Now what happens is that when I start playback, the length is incorrect.
> Then I press pause and it corrects itself to the right value. Press play
> and again it goes wrong. Pause, again it is right. Play, again wrong. Then
> a couple of toggles, it's correct. Then again wrong.
>
> The primary change I can see is pressing pause always fixes the length
> value in this new version.
>
> Do let me know if I can help with any further testing/information.
>
>
> Regards
>
> Prashant L Rao
>
> On Sun, Nov 16, 2014 at 12:15 PM, SebastienAmar <
> <email address hidden>>
> wrote:
>
> > Hi,
> >
> > thanks for testing my player and for your feedback. I don't have this
> issue
> > on my system.
> > So if you want to help me, can you test again with the yarock snapshot I
> > send to you.
> >
> > You can just build it to see if problem is solved. If it's ok I will put
> > this bugfix for the next release.
> >
> > Have a good day,
> > Regards,
> > Sebastien
> >
> >
> > 2014-11-15 17:14 GMT+01:00 Prashant L Rao <email address hidden>:
> >
> > > ** Description changed:
> > >
> > > - While playing back music I use Super<p> (default shortcut) to
> > > - play/pause. Till then the display of the song's length is correct.
> Once
> > > - I pause and restart playback (Super <p> twice), the number changes to
> > an
> > > - incorrect one and it keeps on changing randomly every time the
> shortcut
> > > - key is pressed.
> > > + The song lengths are listed correctly in the playlist but for the
> > > + correctly playing song wrong values are reported and these change
> when
> > > + you pause/stop and play. E.g. I'm playing Dancing Queen which is
> listed
> > > + as 3:51 in the playlist but it's showing 5:09 to begin with in the
> > > + bottom bar. When I hit pause it changes to 36:23. Press play and now
> it
> > > + shows 54:34. I built yarock from source on Ubuntu 14.04 using the
> > > + gstreamer1.0 phonon backend.
> > >
> > > ** Description changed:
> > >
> > > The song lengths are listed correctly in the playlist but for the
> > > - correctly playing song wrong values are reported and these change
> when
> > > + currently playing song wrong values are reported and these change
> when
> > > you pause/stop and play. E.g. I'm playing Dancing Queen which is
> listed
> > > as 3:51 in the playlist but it's showing 5:09 to begin with in the
> > > bottom bar. When I hit pause it changes to 36:23. Press play and now
> it
> > > shows 54:34. I built yarock from source on Ubuntu 14.04 using the
> > > gstreamer1.0 phonon backend.
> > >
> > > --
> > > You received this bug notification because you are subscribed to
> Yarock.
> > > https...

Read more...

Prashant L Rao (prashant-rao) wrote :
Download full text (7.8 KiB)

You're welcome.

I tried the second snapshot. I'm afraid this one does not help at all. It
shows a song length of over 40 minutes (the number varies between 40 and a
bit over 50 depending on which song I click on. It stays the same within
the particular song). Pressing pause has no effect here.

Also, now the time elapsed number flashes and a large number is shown
briefly before it is overwritten by the correct value for time elapsed.

Hope this helps.

Regards

Prashant L Rao

On Sun, Nov 16, 2014 at 8:50 PM, SebastienAmar <email address hidden>
wrote:

> Thanks you, I appreciate. I try to do my best, but it's not so easy
> something, especially when I can not reproduced bugs.
>
> You will find another snapshot with a better solution (I hope) for the
> track length.
>
> Thanks you for helping.
>
>
> 2014-11-16 12:16 GMT+01:00 Prashant L Rao <email address hidden>:
>
> > Hi,
> >
> > First off, thanks for building such a beautiful app. It is one of the
> > nicest looking music players I have seen on any platform.
> >
> > I compiled and ran the version that you attached. The problem is
> partially
> > fixed.
> >
> > Now what happens is that when I start playback, the length is incorrect.
> > Then I press pause and it corrects itself to the right value. Press play
> > and again it goes wrong. Pause, again it is right. Play, again wrong.
> Then
> > a couple of toggles, it's correct. Then again wrong.
> >
> > The primary change I can see is pressing pause always fixes the length
> > value in this new version.
> >
> > Do let me know if I can help with any further testing/information.
> >
> >
> > Regards
> >
> > Prashant L Rao
> >
> > On Sun, Nov 16, 2014 at 12:15 PM, SebastienAmar <
> > <email address hidden>>
> > wrote:
> >
> > > Hi,
> > >
> > > thanks for testing my player and for your feedback. I don't have this
> > issue
> > > on my system.
> > > So if you want to help me, can you test again with the yarock snapshot
> I
> > > send to you.
> > >
> > > You can just build it to see if problem is solved. If it's ok I will
> put
> > > this bugfix for the next release.
> > >
> > > Have a good day,
> > > Regards,
> > > Sebastien
> > >
> > >
> > > 2014-11-15 17:14 GMT+01:00 Prashant L Rao <email address hidden>:
> > >
> > > > ** Description changed:
> > > >
> > > > - While playing back music I use Super<p> (default shortcut) to
> > > > - play/pause. Till then the display of the song's length is correct.
> > Once
> > > > - I pause and restart playback (Super <p> twice), the number changes
> to
> > > an
> > > > - incorrect one and it keeps on changing randomly every time the
> > shortcut
> > > > - key is pressed.
> > > > + The song lengths are listed correctly in the playlist but for the
> > > > + correctly playing song wrong values are reported and these change
> > when
> > > > + you pause/stop and play. E.g. I'm playing Dancing Queen which is
> > listed
> > > > + as 3:51 in the playlist but it's showing 5:09 to begin with in the
> > > > + bottom bar. When I hit pause it changes to 36:23. Press play and
> now
> > it
> > > > + shows 54:34. I built yarock from source on Ubuntu 14.04 using the
> > > > + gstreamer1.0 phonon backend.
> > > >
> ...

Read more...

Changed in yarock:
milestone: none → 1.0.1
assignee: nobody → SebastienAmar (sebastien-amardeilh)
importance: Undecided → Medium
Lukas Zavodny (suchoi) wrote :

I have exactly same problem

Changed in yarock:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers