Interaction in InteractionContainer saved twice?

Bug #569169 reported by Václav Šmilauer on 2010-04-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Yade
Fix Released
Critical
Václav Šmilauer

Bug Description

Running 1000 steps TriaxialTest, there is O.interactions.countReal()==1061. In saved .xml file, count was 1061, but one interaction was duplicated (which means that another one was already lost). When loaded, only 1060 interactions was present.

Seems to be trivially reproducible.

Possibly duplicate of bug #563894.

Related branches

Václav Šmilauer (eudoxos) wrote :

PS Thanks to Frank Lominé for his report at http://<email address hidden>/msg03492.html and to Anton for bug #563894, if related.

Changed in yade:
importance: Undecided → High
milestone: none → 0.5
assignee: nobody → Václav Šmilauer (eudoxos)
status: New → Confirmed
Václav Šmilauer (eudoxos) wrote :

Fixed in r2180. Thanks Frank, it was serious.

Changed in yade:
importance: High → Critical
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers