Help is not showing in GUI

Bug #1598174 reported by Anton Gladky
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Yade
Fix Released
Undecided
Unassigned

Bug Description

Hello,

I recently installed yade (2016-06-26) from source on ubuntu 16.04 (Xenial Xerus) AMD64.
cmake and make both finished without errors, but I have a problem with the graphical interface: it shows up but seems not to work properly.

For example:

- when I click on the blue links which are supposed to provide help in the browser I get this message error in the terminal
'module' object has no attribute 'QWebView'

- when I try to save from the graphical interface, I get this message error in the terminal
output stream error

I went back to check the cmake output, and found these messages which may be linked to such malfunctioning:

-- Found unsuitable Qt version "5.5.1" from /usr/bin/qmake

-- The imported target "vtkRenderingPythonTkWidgets" references the file
   "/usr/lib/x86_64-linux-gnu/libvtkRenderingPythonTkWidgets.so"
but this file does not exist. Possible reasons include:
* The file was deleted, renamed, or moved to another location.
* An install or uninstall procedure did not complete successfully.
* The installation package was faulty and contained
   "/usr/lib/cmake/vtk-6.2/VTKTargets.cmake"
but not all the files it references.

-- The imported target "vtk" references the file
   "/usr/bin/vtk"
but this file does not exist. Possible reasons include:
* The file was deleted, renamed, or moved to another location.
* An install or uninstall procedure did not complete successfully.
* The installation package was faulty and contained
   "/usr/lib/cmake/vtk-6.2/VTKTargets.cmake"
but not all the files it references.

The *.so file seems like no longer exixts in ubuntu 16.04

Have anyone experienced the same problem after the installation of yade on Xenial? do you think such malfunctioning will disappear if the system were to be -i386?

Any help you could provide for this request would be appreciated.

Nejib

Revision history for this message
Anton Gladky (gladky-anton) wrote :

Should be fixed in [1].

Thanks for pointing this out.

[1] https://github.com/yade/trunk/commit/2bee700259ac4bcfb3151d0fb95cd45be491e114

Anton

Changed in yade:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions