Y reports backup success when a backup is not created

Reported by Morgen on 2011-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Y PPA Manager
Medium
Unassigned

Bug Description

The default location for backups is /home, for which the user does not have write access. If you don't notice that the location is /home vs. /home/<username> the program reports success through Notify OSD but the backup file is not created. Found this out the hard way, lost all my repos on a reinstall. :(

Alin Andrei (nilarimogard) wrote :

That's weird, for me it asks to save the backup in /home/myusername. But I'll change the way it retrieves the home folder. I'll also add a check to make sure the notification is correct. Thanks!

Changed in y-ppa-manager:
status: New → Confirmed
importance: Undecided → Medium
Alin Andrei (nilarimogard) wrote :

Hmmm it seems this is harder than I thought: it's easy to check if a backup is successful if it's created in the default folder, but if the user saves it somewhere else... then I can't check it. I'm not sure I can fix that part of the bug.

Alin Andrei (nilarimogard) wrote :

I've managed to fix it, a new version should be available in the PPA in a few minutes.

Thanks for the report!

Changed in y-ppa-manager:
status: Confirmed → Fix Committed
Changed in y-ppa-manager:
status: Fix Committed → Fix Released

Wow! That was the quickest bug fix I have ever seen. I got the update
this morning and now backup defaults to the correct location. Also
when I intentionally saved to a write protected location an error pops
up indicating backup failure. Thanks for quick response and a great
program!

On Tue, Nov 8, 2011 at 4:57 PM, Alin Andrei <email address hidden> wrote:
> ** Changed in: y-ppa-manager
>       Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/887812
>
> Title:
>  Y reports backup success when a backup is not created
>
> Status in Y PPA Manager:
>  Fix Released
>
> Bug description:
>  The default location for backups is /home, for which the user does not
>  have write access. If you don't notice that the location is /home vs.
>  /home/<username> the program reports success through Notify OSD but
>  the backup file is not created. Found this out the hard way, lost all
>  my repos on a reinstall. :(
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/y-ppa-manager/+bug/887812/+subscriptions
>

Alin Andrei (nilarimogard) wrote :

Thanks for the confirmation!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers