Error in serch if locale is "et" (estonian)

Bug #1036626 reported by arvom on 2012-08-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Y PPA Manager
High
Alin Andrei

Bug Description

Type in Search box for example openshot and click on OK. Error message: Your search is not valid! (all nonalphanumeric characters except "-" and space are disallowed. Tested with Ubuntu 12.04 and 12.10. If locale is english all works.

Alin Andrei (nilarimogard) wrote :

You are right, I'll try to fix it asap!

Changed in y-ppa-manager:
status: New → Confirmed
importance: Undecided → High
Alin Andrei (nilarimogard) wrote :

I've uploaded a new version to the PPA which fixes this bug, it should be available in a few minutes. Let me know if it works ok for you or if you encounter any other issues.

Thank you for the bug report!

Changed in y-ppa-manager:
assignee: nobody → Alin Andrei (nilarimogard)
status: Confirmed → Fix Released

Tested on 64-bit Ubuntu 12.04. Search "openshot" works. I'm not sure
about deep sesrch. If program name is
openshot_1.4.2+0+680+62+259~precise1_all.deb what I must type in search
box? Anyway thanks for rapid bug fix.

On 14.08.2012 17:16, Alin Andrei wrote:
> I've uploaded a new version to the PPA which fixes this bug, it should
> be available in a few minutes. Let me know if it works ok for you or if
> you encounter any other issues.
>

Alin Andrei (nilarimogard) wrote :

Thanks for the confirmation!

For the deep search, you must type the package name, in this case "openshot" (without the quotes). You don't have to enter the version, etc.

Basically, for the regular search you can use ambiguous searches, like "file manager", "lens" and so on, which are not package names but for the deep search you must enter the exact package name, for instance: "nautilus", "openshot", "unity-lens-news" and so on.

arvom (arvom) wrote :

This bug is fixed in 0.0.9.3-1 precise but is again present in 0.0.9.3-1 quantal.

Alin Andrei (nilarimogard) wrote :

Are you sure you've entered a valid search? I've tested it Quantal with Estonian language and it works just fine here: http://i.imgur.com/jjlDL.jpg

arvom (arvom) wrote :

I tested again, typed Openshot and Nautilus. Error message: Your search is not valid! (all nonalphanumeric characters except "-" and space are disallowed on Quanatal. On Precise the same search is OK.

Alin Andrei (nilarimogard) wrote :

Are you sure you have the latest Y PPA Manager from the official PPA? Because I can't replicate this behaviour so I can't fix it...

arvom (arvom) wrote :

Repository is ppa://launchpad.net/webupd8team/y-ppa-manager/ubuntu
quantal. Package is y-ppa-manager_0.0.9.3-1~webupd8~3_all.deb

On 05.11.2012 14:56, Alin Andrei wrote:
> Are you sure you have the latest Y PPA Manager from the official PPA?
> Because I can't replicate this behaviour so I can't fix it...
>

arvom (arvom) wrote :

Y PPA Manager search works on Quantal Live CD. I upgraded from Precise.
Probably some configuration files problems.

On 05.11.2012 14:56, Alin Andrei wrote:
> Are you sure you have the latest Y PPA Manager from the official PPA?
> Because I can't replicate this behaviour so I can't fix it...
>

Alin Andrei (nilarimogard) wrote :

I've installed it too in VirtualBox and still no error. I want to fix it as you can imagine, but I have no idea how if I can't replicate the bug :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers