Update minimum system requirements on the Xubuntu website

Bug #1201841 reported by amjjawad 
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xubuntu Website
Fix Released
Medium
Unassigned

Bug Description

Following up with this thread on the mailing list: https://lists.ubuntu.com/archives/xubuntu-devel/2013-July/009109.html

Please note that the website of Xubuntu says:

To install or try Xubuntu within the Desktop/Live CD, you need 256 MB of memory. Installing with the Alternate CD (for 12.04 only) requires 64 MB. Once installed, it is strongly recommended to have at least 512 MB of memory.

As per the tests I have done, with 256MB RAM, the Installer will Crash and logout from the Live Session - please see the above link for the mailing list thread.

Also, it does not make sense to say:

"Installing with the Alternate CD (for 12.04 only) requires 64 MB. Once installed, it is strongly recommended to have at least 512 MB of memory."

First of all, I greatly doubt the Alternative Installer can be installed on 64MB ONLY!!! - I must check that and confirm or someone needs to do that maybe?

Second of all, if someone has 64MB of RAM to install Xubuntu 12.04 from the alternate ISO, then how come he/she will suddenly have 512MB (the strongly recommended RAM to have as per the website)?
If someone, say, managed to install Xubuntu 12.04 from the alternate ISO on a machine with 64MB RAM, that means he/she does not have MORE RAM to begin with :)
Then how come after the installation, he needs 512MB RAM the minimum recommended???

Summary:
To make Life easier:

Suggestion 1: Please set the Minimum System Requirement to 512MB RAM. This is much more easier for everyone specially the users who may have much less technical knowledge than others.

Suggestion 1: Add zRAM by default (zram-config is available on the official repository) if you wish or plan to go below 512MB RAM.

Thank you!

amjjawad  (amjjawad)
description: updated
affects: ubuntu → xubuntu-website
Pasi Lallinaho (knome)
Changed in xubuntu-website:
status: New → Confirmed
status: Confirmed → Won't Fix
status: Won't Fix → Triaged
Revision history for this message
Elizabeth K. Joseph (lyz) wrote :

The site was updated to list 512M as the recommended minimum for an installed system, but we should dig into this more and confirm that other things are correct so we're in a good spot for appropriate recommendations come 14.04.

I've written a proposed testing methodology for community members to push this along: https://lists.ubuntu.com/archives/xubuntu-devel/2013-November/009468.html

Please report results to the xubuntu-devel mailing list so we can keep this bug strictly about the website.

Changed in xubuntu-website:
importance: Undecided → Medium
Revision history for this message
amjjawad  (amjjawad) wrote :

Hello Lyz,

The main reason for me to report this bug was: "To install or try Xubuntu within the Desktop/Live CD, you need 256 MB of memory."

IMHO, this must be changed to:

[To install or try Xubuntu within the Desktop/Live CD, you need minimum 512 MB of memory.]

In that case, you are 100% in the safe side and NO one will ever complain :)

Also, the bug with the report I sent previously states that you can NOT 'install', as the website suggested - "To install or try Xubuntu within the Desktop/Live CD, you need 256 MB of memory. - if you have 256MB RAM. IMHO, the only possible way is to create a SWAP partition and this can't be done by everyone. Newcomers will not create swap partition to install Xubuntu on 256MB RAM. They should not on the first place to use Xubuntu.

Let's be clear with with the 'minimum' system requirements for Xubuntu so everyone is aware of the 'minimum' requirements.

I have installed Xubuntu 13.10 recently on this: https://www.facebook.com/photo.php?fbid=584198638299847&set=o.240872812628300&type=1

Installation was fine because the PC was using less than 512MB RAM but below that, it will never be installed, at least on 'my' hardware :)

Let me know if you require more information :)

Pasi Lallinaho (knome)
summary:
summary: - Xubuntu Minimum System Requirements on the Web Site needs to be
- corrected
+ Update minimum system requirements on the Xubuntu website
Revision history for this message
Elizabeth K. Joseph (lyz) wrote :

We've updated the requirements and added a new page here: http://xubuntu.org/getxubuntu/requirements/

Changed in xubuntu-website:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers