XSPLASH: Displays incorrectly on multi-monitor setups

Bug #463769 reported by Nicholas Christian Langkjær Ipsen on 2009-10-29
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xsplash
Wishlist
Unassigned
Ubuntu
Undecided
Unassigned
Declined for Lucid by Robert Collins

Bug Description

There are three fairly big problems with multi-screen Xsplash(Using nVidia TwinView with two monitors at 1920x1080)

1. The wallpaper is stretched across all sceens, even though the logo, throbber and login dialog only appear on the primary screen.

2. The throbber and logo look... weird. Try it using my setup yourself, you'll see. I'll take a picture if you find it impossible to reproduce.

3. I can see my desktop loading.

> 2. The throbber and logo look... weird. Try it using my setup yourself,
> you'll see. I'll take a picture if you find it impossible to reproduce.

Please attach a picture - it would help.

Thanks,
Rob

description: updated
description: updated
description: updated
description: updated
Cody Russell (bratsche) wrote :

"1. The wallpaper is stretched across all sceens, even though the logo, throbber and login dialog only appear on the primary screen."

This is not actually xsplash. That's the desktop background being drawn by gnome-settings-daemon.

The video was interesting. It seems like xsplash is not loading the background image for you. Can you open up a terminal and run:
   sudo -u gdm xsplash

And confirm that it does the same thing?

Also, please post the contents of /var/log/gdm/xsplash-user.log here after you've reproduced the issue (e.g., if you run xsplash from the terminal and the problem doesn't happen then don't post xsplash-user.log, logout/login first).

Cody Russell (bratsche) wrote :

Also, before doing that can you post the xsplash version you're using and make sure you're up-to-date?

I will do all of it as soon as I've finished doing a clean install to make
sure it's not just leftover stuff from the pre-release versions

Nicholas Ipsen,
sent from a phone powered by Google Android LINUX.

On Oct 30, 2009 4:26 p.m., "Cody Russell" <email address hidden> wrote:

Also, before doing that can you post the xsplash version you're using
and make sure you're up-to-date?

-- Xsplash is very ugly with multi-screen setups
https://bugs.launchpad.net/bugs/463769 You receiv...
There are three fairly big problems with multi-screen Xsplash(Using nVidia
TwinView with two monitors at 1920x1080)

1. The wallpaper is stretched across all sceens, even though the logo,
throbber and login dialog on...

3. I can see my desktop loading.

After a clean isntall, this went away. I guess it was a remnant from somewhere in the Alpha period.

Changed in ubuntu:
status: New → Invalid
Changed in xsplash:
status: New → Invalid

Actually, the grey box clip region still appears here exactly as in the linked video.

I wouldn't mark this as invalid just yet.

Running Xinerama off of dual ATI cards, so it appears to be something regarding implementation as opposed to video card related specifics.

Changed in ubuntu:
status: Invalid → Incomplete
Changed in xsplash:
status: Invalid → Incomplete
Robert Collins (lifeless) wrote :

Troy, please supply the data that Cody was asking for then (the manual test results and the log and xsplash version info).

How odd... Apparently I'm not subscribed to this bug. Sorry for the late response. Give me a few...

"It seems like xsplash is not loading the background image for you. Can you open up a terminal and run:

sudo -u gdm xsplash

And confirm that it does the same thing?"

Answer: Confirmed. A grey rectangle appears in the upper left of my leftof screen.

Information: xsplash output from apt-cache show:

Package: xsplash
Priority: optional
Section: misc
Installed-Size: 104
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 0.8.4-0ubuntu1sudo -u su
pool/main/x/xsplash/xsplash_0.8.4-0ubuntu1_amd64.deb

MMarking (cpt-mocha) wrote :

I have this exact same problem on my Ubuntu 32 bit, upgraded from Jaunty, never had Karmic alpha/beta installed. Nvidia card running in TwinView mode using the latest 190.42 driver manually installed. Nvidia card 9500GT. Problem is exactly like the YouTube video link. When I run "sudo -u gdm xsplash" it looks the same way as during boot up. xsplash 0.8.5 from Karmic updates repo is installed.

$ apt-cache show xsplash
Package: xsplash
Priority: optional
Section: misc
Installed-Size: 96
Maintainer: Ubuntu Developers <email address hidden>
Architecture: i386
Version: 0.8.5-0ubuntu1
Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.3.6-6~), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2.1), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.14.0), libpango1.0-0 (>= 1.14.0), libxcomposite1 (>= 1:0.3-1), ubuntu-xsplash-artwork | xsplash-artwork
Filename: pool/main/x/xsplash/xsplash_0.8.5-0ubuntu1_i386.deb
Size: 17056
MD5sum: a47cf6a05bb45a6cba01e48f27babd9e
SHA1: a9090834278ae3d9cec91b4c566251243aacd839
SHA256: 4006c09a5670b14dc7828cf267ec20956d54797ba51610ef681a5b6b33ccbedf
Description: X based bootsplash
 xsplash is a userspace application that uses the X interface
 to draw a splash screen at boot.
Homepage: https://launchpad.net/xsplash
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Task: ubuntu-desktop, edubuntu-desktop, xubuntu-desktop, mythbuntu-backend-master, mythbuntu-backend-slave, mythbuntu-desktop, mythbuntu-frontend, ubuntu-netbook-remix

MMarking (cpt-mocha) wrote :

Here is the log after running "sudo -u gdm xsplash". My TwinView screens are setup as 1280x1024 (primary DFP) and 800x600 (NTSC TV) to the "right of" the DFP. Nvidia sees my screen in xorg as 2080x1024. I have some other metamodes setup but only used for fullscreen games, see below.

$ sudo cat /var/log/gdm/xsplash-user.log
[13:52:08:-1302313063 - MSG] xsplash started
[13:52:08:-1302312947 - MSG] get_logo_filename(): looking for the best logo for screen width...
[13:52:08:-1302312933 - MSG] ** Chose `medium'
[13:52:08:-1302312923 - MSG] ** logo filename is: /usr/share/images/xsplash/logo_medium.png
[13:52:08:-1302312913 - MSG] get_throbber_filename(): looking for the best throbber for screen width...
[13:52:08:-1302312902 - MSG] ** Chose `medium'
[13:52:08:-1302312893 - MSG] ** throbber filename is: /usr/share/images/xsplash/throbber_medium.png
[13:52:08:-1302312882 - MSG] background_image = /usr/share/images/xsplash/bg_2560x1600.jpg
[13:52:08:-1302312872 - MSG] logo_image = /usr/share/images/xsplash/logo_medium.png
[13:52:08:-1302312863 - MSG] throbber_image = /usr/share/images/xsplash/throbber_medium.png
[13:52:08:-1301995081 - MSG] get_logo_filename(): user provided a logo on the command line; using that
[13:52:08:-1301993306 - MSG] get_throbber_filename(): user provided a throbber on the command line; using that
[13:52:08:-1301894326 - MSG] throbber started (50 frames)
[13:52:11:-1305260204 - MSG] ESC interrupt
[13:52:11:-1304448435 - MSG] fade finished
[13:52:11:-1304448218 - MSG] exiting...

$ xrandr
Screen 0: minimum 640 x 480, current 2080 x 1024, maximum 2080 x 1024
default connected 2080x1024+0+0 0mm x 0mm
   2080x1024 50.0*
   1280x1024 51.0
   640x480 52.0

Hi,
I have this exact same problem on my Ubuntu 64 bit, upgraded from Jaunty yesterday (xsplash 0.8.5-0ubuntu1).

The log in terminal for ''sudo -u gdm xsplash":

(xsplash:19142): Gdk-CRITICAL **: _gdk_pixmap_new: assertion `(drawable != NULL) || (depth != -1)' failed
(xsplash:19142): Gdk-CRITICAL **: gdk_draw_pixbuf: assertion `GDK_IS_DRAWABLE (drawable)' failed

The log in /var/log/gdm/xsplash-user.log :

[22:26:49:-1259530008015709 - MSG] xsplash started
[22:26:49:-1259530008015566 - MSG] get_logo_filename(): looking for the best logo for screen width...
[22:26:49:-1259530008015544 - MSG] ** Chose `large'
[22:26:49:-1259530008015527 - MSG] ** logo filename is: /usr/share/images/xsplash/logo_large.png
[22:26:49:-1259530008015511 - MSG] get_throbber_filename(): looking for the best throbber for screen width...
[22:26:49:-1259530008015494 - MSG] ** Chose `large'
[22:26:49:-1259530008015478 - MSG] ** throbber filename is: /usr/share/images/xsplash/throbber_large.png
[22:26:49:-1259530008015463 - MSG] background_image = /usr/share/images/xsplash/bg_2560x1600.jpg
[22:26:49:-1259530008015447 - MSG] logo_image = /usr/share/images/xsplash/logo_large.png
[22:26:49:-1259530008015432 - MSG] throbber_image = /usr/share/images/xsplash/throbber_large.png
[22:26:50:-1259530009782721 - MSG] get_logo_filename(): user provided a logo on the command line; using that
[22:26:50:-1259530009781244 - MSG] get_throbber_filename(): user provided a throbber on the command line; using that
[22:26:50:-1259530009771099 - MSG] throbber started (50 frames)
[22:27:05:-1259530024999428 - MSG] ** timeout **
[22:27:05:-1259530024186353 - MSG] fade finished
[22:27:05:-1259530024186004 - MSG] exiting...

regards

screenshoot

Changed in xsplash:
status: Incomplete → Confirmed
summary: - Xsplash is very ugly with multi-screen setups
+ XSPLASH: Displays incorrectly on multi-monitor setups
Suzy Jackson (suzy-jackson) wrote :

It's not only multi-screen setups that are affected. I'm running a single screen (1440x900), with nVidia drivers version 185.18.36, and am getting the grey rectangle on boot and when running sudo -u gdm xsplash.

Logs follow:

suzy@gzunda:~$ sudo -u gdm xsplash

(xsplash:2887): Gdk-CRITICAL **: _gdk_pixmap_new: assertion `(drawable != NULL) || (depth != -1)' failed

(xsplash:2887): Gdk-CRITICAL **: gdk_draw_pixbuf: assertion `GDK_IS_DRAWABLE (drawable)' failed

suzy@gzunda:~$ sudo more /var/log/gdm/xsplash-user.log
[14:59:33:1790247342 - MSG] xsplash started
[14:59:33:1790247425 - MSG] get_logo_filename(): looking for the best logo for s
creen width...
[14:59:33:1790247436 - MSG] ** Chose `medium'
[14:59:33:1790247443 - MSG] ** logo filename is: /usr/share/images/xsplash/logo
_medium.png
[14:59:33:1790247450 - MSG] get_throbber_filename(): looking for the best throbb
er for screen width...
[14:59:33:1790247457 - MSG] ** Chose `medium'
[14:59:33:1790247464 - MSG] ** throbber filename is: /usr/share/images/xsplash/
throbber_medium.png
[14:59:33:1790247472 - MSG] background_image = /usr/share/images/xsplash/bg_2560
x1600.jpg
[14:59:33:1790247479 - MSG] logo_image = /usr/share/images/xsplash/logo_medium.p
ng
[14:59:33:1790247485 - MSG] throbber_image = /usr/share/images/xsplash/throbber_
medium.png
[14:59:33:1790423873 - MSG] get_logo_filename(): user provided a logo on the com
mand line; using that
[14:59:33:1790425010 - MSG] get_throbber_filename(): user provided a throbber on
 the command line; using that
[14:59:33:1790434426 - MSG] throbber started (50 frames)
[14:59:48:1775676308 - MSG] ** timeout **
[14:59:49:1774488183 - MSG] fade finished
[14:59:49:1774488510 - MSG] exiting...

Cody Russell (bratsche) on 2010-03-10
Changed in xsplash:
importance: Undecided → Wishlist
Peter Hurley (phurley) wrote :

Here's a patch for this bug against the karmic/lucid source package xsplash-0.8.5-0ubuntu1.

The approach I took was to wipe the whole X screen (in TwinView, this is both monitors) with the background image, and then display the logo and throbber (that's what it's called...) on monitor 0 (the default monitor). The background image is isotropically scaled to match the largest dimension and centered in the other dimension.

Also, the original source allowed the source background image dimensions to vary and I preserved this behavior. This means if you are running dual 1920x1280 monitors in TwinView, you can supply a 3840x1280 jpg and the image won't be scaled. (Although since I didn't test this, there might be an off-by-one error in which case it will scale).

I tested this on a dual-monitor NVidia in TwinView, single monitor and separate X screens, running driver version 185.18.36 (stock karmic but rebuilt for custom kernel).

tags: added: patch
Nigel Babu (nigelbabu) wrote :

I'm closing the Ubuntu task, since there is already an xsplash task.

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers