xsplash doesn't handle several screens on intel GM965

Bug #441391 reported by Fred on 2009-10-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xsplash
Wishlist
Unassigned
xsplash (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xsplash

Here is my setup :
My laptop is an Acer TravelMate 6292 with an integrated graphics chipset INTEL 965GM.
It is docked in an ACER docking station.
An external LCD monitor is plugged on the docking station (using the VGA connector).
The laptop's lid is closed.

Actual behavior:
Grub shows up on the external monitor
xsplash shows up on the laptop panel
gdm shows up on the laptop panel
session if not customized shows up on the laptop panel
The external monitor is only used by grub.

Expected behavior :
Grub shows up on the external monitor
xsplash shows up on the external monitor
gdm shows up on the external monitor
session if not customized shows up on the external monitor

If the laptop is opened, the behavior is exactly the same.

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 3 15:41:03 2009
DistroRelease: Ubuntu 9.10
Package: xsplash 0.8.2-0ubuntu1
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: xsplash
Uname: Linux 2.6.31-11-generic x86_64

Fred (frederic-lespez) wrote :
Daniel Lee (longinus00) wrote :

This sounds like a problem with X rather than xsplash specifically since gdm is also only displaying on one screen.

Fred (frederic-lespez) wrote :

Daniel,

May be, may be not. Before the introduction of xsplash (around Karmic alpha 3), everything was almost working perfectly : gdm showed up on the external screen. The only problem remaining was that gdm also showed up on the laptop panel even with the lid closed. See this bug report and my comments : https://bugs.launchpad.net/ubuntu/+bug/272669

May be the flaw lies in the intel driver (enabling clone mode by default is not a good choice IMHO).

Daniel Lee (longinus00) wrote :

xsplash doesn't do anything that would affect which monitor gdm shows up on. xsplash just displays on the default screen, something gdm probably also does. If the default screen is not being set correctly xsplash can't really do anything about it.

Fred (frederic-lespez) wrote :

Daniel,
I don't know which program setup the monitor layout. I found a workaround which confirms that xsplash does not affect monitor layout.

As a workaround, I have added some xrandr commands in gdm init script. The logic is the following one : if an external screen is connected and laptop lid is closed, only the external is used. Otherwise only the laptop panel is used.
Here is the beginning of my customized /etc/gdm/Init/Default. Add lines are between ### BEGIN SETUP SCREEN ### and ### END SETUP SCREEN ###

#!/bin/sh
# Stolen from the debian kdm setup, aren't I sneaky
# Plus a lot of fun stuff added
# -George

PATH=/usr/bin:$PATH
OLD_IFS=$IFS

### BEGIN SETUP SCREEN ###
# Disable TV Output.
xrandr --output TV1 --off
xrandr | grep VGA1 | grep " connected "
if [ "$?" = 0 ]; then
 if grep -q "closed" /proc/acpi/button/lid/LID/state; then
  # VGA1 is connected and the lid is closed"
  xrandr --output VGA1 --auto --output LVDS1 --off
 else
  # VGA1 is connected and the lid is opened"
  xrandr --output LVDS1 --auto --output VGA1 --off
 fi
else
 # VGA1 is disconnected"
 xrandr --output LVDS1 --auto --output VGA1 --off
fi
### END SETUP SCREEN ###

if [ -x '/usr/bin/xsplash' ];
then

You need to adapt the script according to your video card and setup. Use with caution, it may break the video setup.
With this workaround the only I don't see is usplash boot screen.

David Barth (dbarth) wrote :

@Fred: thanks for the workaround

xsplash uses the default monitor, I don't think there is a way to make an informed choice and provide the behavior you would expect, either at xsplash level, or gdm.

Changed in xsplash (Ubuntu):
status: New → Invalid
Fred (frederic-lespez) wrote :

@David,

Yes, xsplash and gdm uses the default monitor.
After digging a bit, the default monitor is setup by the kermel modules that enable "Kernel Mode Settings". But I didn't find a way to force a monitor configuration when modules are loaded or just before usplash is started. And I don't know against which packages this bug should be reported (linux kernel ?).
Fixing bug #145501 (it has been fixed upstream) may have a positive impact on this bug.

Cody Russell (bratsche) wrote :

We actually always use monitor #0 in xsplash right now, because we didn't have API available to query the primary monitor. I'm planning to add the new API to gtk+ in time for Lucid, so xsplash should be able to handle this at that time. But in terms of Karmic, I'm afraid there's nothing really to do right now.

I'd like to reopen this bug, but target it for Lucid.

Changed in xsplash (Ubuntu):
status: Invalid → New
Changed in xsplash:
importance: Undecided → Wishlist
Changed in xsplash (Ubuntu):
importance: Undecided → Wishlist
Changed in xsplash:
assignee: nobody → Cody Russell (bratsche)
Changed in xsplash (Ubuntu):
assignee: nobody → Cody Russell (bratsche)
Cody Russell (bratsche) on 2010-03-11
Changed in xsplash (Ubuntu):
assignee: Cody Russell (bratsche) → nobody
Changed in xsplash:
assignee: Cody Russell (bratsche) → nobody
Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in xsplash (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers