ubuntu-xsplash-artwork contains redundant graphics

Bug #438244 reported by Steve Langasek on 2009-09-28
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xsplash
Wishlist
Unassigned
Baltix
Undecided
Unassigned
xsplash (Ubuntu)
Wishlist
Unassigned
Karmic
Wishlist
Unassigned
Lucid
Wishlist
Unassigned

Bug Description

Binary package hint: xsplash

The ubuntu-xsplash-artwork recently grew to add an additional 500KB to our CDs. The four largest files in this package are:

/usr/share/images/xsplash/bg_1440x900.jpg
/usr/share/images/xsplash/bg_1680x1050.jpg
/usr/share/images/xsplash/bg_1920x1200.jpg
/usr/share/images/xsplash/bg_2560x1600.jpg

These files all have the same aspect ratio and look identical. There is no good reason to ship three copies of this image - we should have a single image at the highest desired resolution, and downscale that image when running at the other resolutions with matching aspect ratio.

The same applies to the 800x600 image, which duplicates the 1024x768 image.

ProblemType: Bug
Architecture: amd64
Date: Mon Sep 28 09:32:27 2009
Dependencies:

DistroRelease: Ubuntu 9.10
Package: ubuntu-xsplash-artwork 0.8.1-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: xsplash
Uname: Linux 2.6.31-11-generic x86_64

Steve Langasek (vorlon) on 2009-09-28
Changed in xsplash (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Mat Tomaszewski (mat.t.) on 2009-09-28
Changed in xsplash (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Cody Russell (bratsche)
Daniel Lee (longinus00) wrote :

If you wanted to keep all the different resolution files after it installs (because you want to reading extra data to a minimum), is it possible to just generate the smaller resolution images from a larger one during install?

Steve Langasek (vorlon) wrote :

That wouldn't help for keeping the size of the liveCD under control; and I think the size differences between the individual images are small enough that we shouldn't optimize for this.

Cody Russell (bratsche) wrote :

I'm going to remove the other images and put the scaling code back into xsplash.

Cody Russell (bratsche) on 2009-09-29
Changed in xsplash:
status: New → In Progress
assignee: nobody → Cody Russell (bratsche)
Cody Russell (bratsche) wrote :

Is it really important to keep the 1024x768 one as well? gnome-settings-daemon doesn't get to choose which one it's using, and we're now using that for the desktop background in gdm. In order to keep it consistent then shouldn't xsplash only keep the 2560x1600 image and try to display it the same way g-s-d does?

Daniel Lee (longinus00) wrote :

If the login screen only uses one image then xsplash probably should only use one image. If it's the same image this should also helps keep redundant reads down.

Steve Langasek (vorlon) wrote :

Cody, who is this question addressed to? I'm not going to presume to say that we should be using a single image for displays with different aspect ratios - that's not my area of expertise. Scaling images for screens of the same aspect ratio, OTOH, is clearly something we can do without impacting the aesthetics. :)

Dana Goyette (danagoyette) wrote :

Hmm, I know Fedora does some interesting stuff with their "Leonidas" wallpaper -- it's actually an XML file that selects different images depending on the aspect ratio of the display. Perhaps we could do the same here.

Andreas Schildbach (schildbach) wrote :

We could also use SVG instead of bitmap graphics.

Cody Russell (bratsche) on 2009-10-27
Changed in xsplash:
status: In Progress → Fix Committed
Cody Russell (bratsche) on 2009-10-27
Changed in xsplash:
status: Fix Committed → Fix Released

This seems to break xsplash for 1024x768 ( 1.3_ ) - and other aspects that don't match 2560x1600 (1.6 ). Also this causes a wasteful amount of memory to be used during the processing of the image. I noticed this on my netbook, and then found this discussion here that seems to be the cause. It would be best to expose options passed to xsplash for custom theming. That way we won't be forced into dealing with your hacks. If you really wanted to fix your live cd problem ship a solid color background with a variable logo and trobber, and let people customize their machine as they see fit.

I just want to use a 1024x768 image for my xsplash on my tablet without having to alter xsplash source or make a hacked up 2560x1600 bg image as I'm unable to find a way to pass options into xsplash via a config file anywhere.

I made my xsplash theme by replacing files in /usr/share/images/xsplash, since there is support for theming as yet.

Steve Langasek (vorlon) wrote :

> This seems to break xsplash for 1024x768

Well, what breaks xsplash is that the package in karmic-proposed has dropped *all* images other than the largest, when what was requested was only to drop those with the same aspect ratio. This is a regression, yes; marking as such.

tags: added: regression-potential
tags: added: regression-proposed
removed: regression-potential
tags: added: regression-update
removed: regression-proposed
Changed in xsplash (Ubuntu Karmic):
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → High
milestone: none → karmic-updates
status: New → Triaged
Changed in xsplash (Ubuntu Lucid):
status: In Progress → Triaged
importance: Medium → High
Changed in xsplash:
status: Fix Released → Confirmed
Robert Collins (lifeless) wrote :

I've set the upstream priority to match that of Ubuntu.

Changed in xsplash:
importance: Undecided → High
status: Confirmed → Triaged

As Andreas Schildbach said, we could use svg instead of jpg. That would fit on all screens.

Does XSplash support svg?

Theburn7 (theburn7) wrote :

it is there so it can achieve that 20 second start goal, if you just have the high resolution picture, it has to render and downsize rather than just loading like normal.

Cody Russell (bratsche) on 2010-03-10
Changed in xsplash:
importance: High → Wishlist
Changed in xsplash (Ubuntu Karmic):
importance: High → Wishlist
Changed in xsplash (Ubuntu Lucid):
importance: High → Wishlist
Cody Russell (bratsche) on 2010-03-11
Changed in xsplash (Ubuntu Karmic):
assignee: Cody Russell (bratsche) → nobody
Changed in xsplash (Ubuntu Lucid):
assignee: Cody Russell (bratsche) → nobody
Changed in xsplash:
assignee: Cody Russell (bratsche) → nobody
Rolf Leggewie (r0lf) on 2011-10-02
Changed in xsplash (Ubuntu Karmic):
status: Triaged → Won't Fix
Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in xsplash (Ubuntu):
status: Triaged → Invalid
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in xsplash (Ubuntu Lucid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers