Wait for user icons and wallpaper before fading out

Bug #435692 reported by David Prieto on 2009-09-24
98
This bug affects 19 people
Affects Status Importance Assigned to Milestone
xsplash
Wishlist
Unassigned
xsplash (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xsplash

I have noticed the new xsplash screen fades out nicely when you log in.

Sometimes the fade out happens when the user's wallpaper and desktop icons are already loaded, which results in a very pleasant effect, like saying "your computer is ready to be used".

But other times the fade happens too soon, when the wallpaper and icons haven't been loaded yet. Then those appear suddenly, without a fade or anything, and that's quite ugly.

Can the splash always wait for the user's icons and wallpaper to be loaded before fading out?

Cody Russell (bratsche) wrote :

Can you confirm if this is still a problem? I believe it may have been fixed recently.

I can confirm this on an up-to-date Karmic.

Changed in xsplash (Ubuntu):
status: New → Confirmed
Cody Russell (bratsche) wrote :

How much time are we talking about until this happens?

Can you modify /etc/gdm/PreSession/Default so that it adds --timeout=120 (just picked an arbitrarily high number here) to the xsplash command?

What I'm getting at here is that I'm unsure whether xsplash is fading out because it's received signals from gnome-panel and nautilus, or if it's fading out because it has timed out. If it's timing out then --timeout=120 should increase the timeout so that it will wait longer and receive the signals from nautilus and gnome-panel. If it's fading because it's receiving those earlier than your icons are visible, that means we need to investigate our Nautilus patch and see if it can be improved.

I modified /etc/gdm/PreSession/Default as you suggested but there is not much change.
This is especially noticeable during the "cold" boot. Xspash exits early every time for me in that case (I am attaching a poor resolution video of the login, taken with my phone). You can see that the desktop doesn't show until several seconds after the xsplash exits.
Sometimes, on a "warm" login (if I logout and back in) it will work fine and sometimes it will exit abruptly without fading out or waiting for the desktop to be ready (that's a different bug I think).

Andreas Schildbach (schildbach) wrote :

Adding the timeout has no effect on my system either. Confirmed with latest karmic.

Botond Szász (boteeka) wrote :

Also, as can be seen in Igor's video, xsplash isn't running smoothly. There are sudden jumps in the animation which degrade the user experience a lot. The animation should be as smooth as it can, without any frame-dropping occurring.

Cody Russell (bratsche) wrote :

Please, let's keep bug reports on topic please, otherwise there's no way to track progress. If you find new issues, please report them in a separate bug report (although this is already known and I'm sure there is at least one bug describing it at this point).

Nicolò Chieffo (yelo3) wrote :

I have this problem too.
This happens every time (I only do cold boots with autologin), exactly as in the video posted.
I wanted to say that there was a period in which the fade was correct, there was a bug but I lost the link.

Nicolò Chieffo (yelo3) wrote :

(of course that bug now is fix released)

Rob Speer (rspeer) wrote :

Here's a screenshot of what it looks like for me shortly after xsplash disappears. My wallpaper, Nautilus icons, and most components of the GNOME panel are not yet visible or usable.

(I don't know what the "Untitled window" is; it may be an artifact of taking the screenshot.)

David Barth (dbarth) on 2009-10-22
Changed in xsplash:
status: New → Triaged
assignee: nobody → Cody Russell (bratsche)
milestone: none → ubuntu-9.10
importance: Undecided → High
Changed in xsplash (Ubuntu):
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → Low
David Barth (dbarth) on 2009-10-23
Changed in xsplash:
importance: High → Medium

I have two installs: One with three launchers and one folder on the desktop (with default everything else) and my personal computer with a tomboy applet, gnome-system-monitor applet, and lots of launcher icons at the top.

The first install fades 85-90 percent of the time, and the second install fades 5 percent of the time.

Just curious.... would the I/O scheduler possibly affect this? I know that Ubuntu has problems with the CFQ scheduler when doing mass I/O actions. Would Noop or Deadline help ease this?

Cody Russell (bratsche) on 2010-03-10
Changed in xsplash:
importance: Medium → Wishlist
Changed in xsplash (Ubuntu):
importance: Low → Wishlist

Isn't this an actual bug, not a feature request? The intended behavior is to fade, and it only sometimes does that. Why is this Wishlist? Is it because Xsplash has such been discarded for Plymouth?

Cody Russell (bratsche) on 2010-03-11
Changed in xsplash (Ubuntu):
assignee: Cody Russell (bratsche) → nobody
Changed in xsplash:
assignee: Cody Russell (bratsche) → nobody
Cody Russell (bratsche) wrote :

Yes.

Cody Russell (bratsche) on 2010-04-01
Changed in xsplash:
milestone: ubuntu-9.10 → none
Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in xsplash (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers