[Karmic] [i945] Screen flickers due to constantly changing brightness level

Bug #413399 reported by István Miklós Antal on 2009-08-14
This bug report is a duplicate of:  Bug #415023: brightness is broken on MSI WIND U100. Edit Remove
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
New
Undecided
Unassigned
xsplash
Undecided
Unassigned
displayconfig-gtk (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by István Miklós Antal
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by István Miklós Antal
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by István Miklós Antal

Bug Description

I have an MSI Wind U90X 037EU netbook with an Intel card, I had previously Jaunty Ubuntu Netbook Remix, I upgraded to Karmic. After the upgrade the screen flickered. After login, I opened "Display", I did not set anything since every setting was ok , so I just pressed the OK, button, this stopped the flickering after login, but it still exists at login, I looked at the xorg.conf and found nothing that can cause this issue.

I assume there must be something wrong with the default refresh rate or something similar.

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03)
     Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]

Architecture: i386
DistroRelease: Ubuntu 9.10
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.31-5-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected

Architecture: i386
DistroRelease: Ubuntu 9.10
MachineType: MICRO-STAR INTERNATIONAL CO., LTD U-100
Package: xserver-xorg-video-intel 2:2.8.0-0ubuntu2
PackageArchitecture: i386
ProcCmdLine: root=UUID=fb540d5d-b207-40c4-8f40-6613344ba761 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.5-1ubuntu1
 libdrm2 2.4.12-1ubuntu1
 xserver-xorg-video-intel 2:2.8.0-0ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu5
Tags: ubuntu-unr
Uname: Linux 2.6.31-5-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/16/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.3
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: U-100
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: Ver.001
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.chassis.version: Ver.001
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.3:bd07/16/2008:svnMICRO-STARINTERNATIONALCO.,LTD:pnU-100:pvrVer.001:rvnMICRO-STARINTERNATIONALCO.,LTD:rnU-100:rvrVer.001:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvrVer.001:
dmi.product.name: U-100
dmi.product.version: Ver.001
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-5-generic

Geir Ove Myhr (gomyhr) on 2009-08-15
tags: added: 945gme flicker karmic
summary: - Screen flickers after jaunty update
+ [i945] Screen flickers after jaunty update

Could you try to add the boot option drm.debug=0x05 (see http://<email address hidden>/msg41488.html for explanation of the debug levels) and attach the output of `dmesg` with this enabled.

Also, if you move away your ~/.config/monitors.xml, does the monitor still flicker after login? If it does, could you attach the output of `xrandr --verbose` for that case? If I understand correctly the screen flickers from right after boot until right after you log in, right? I suspect this may be connected to bug 398026, but maybe not.

Geir Ove Myhr (gomyhr) wrote :

Actually, I don't think the debugging code I referenced above has made it into Karmic (I think it is scheduled for linux kernel 2.6.32). In that case, it might be that the only debug option that will work for now is drm.debug=1.

Sorry for the late reply, well none of the debug methods actually worked for me. But I can supply more details about this.

I moved my monitors.xml, and the screen flickers after login, and sometimes the overlay that indicates the change in brightness remain on the screen also. But after I right click the display icon from the systray both of these issues simply go away, the overlay disappears and the screen doesn't flicker anymore.

I don't think these bugs are connected because of the thing I found out.

Could you run `xrandr --verbose` in a terminal after you log in and
when the screen flickers and attach it to this bug report?

Bryce Harrington (bryce) on 2009-08-18
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-08-19
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete

Here is xrandr's output when it flickers.

Geir Ove Myhr (gomyhr) wrote :

Thank you. The xrandr output is identical to the one without the flicker. That is interesting, but I was hoping that the mode would be slightly different in the flickering case. I think we have all the information we need to take this further, so I'm setting the status to Triaged.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
Geir Ove Myhr (gomyhr) wrote :

This is possibly the same bug as bug 412492. There should be a test kernel available at that bug report soon.

Geir Ove Myhr (gomyhr) wrote :

A test kernel is reported to fix the flickering at bug 412492. Could you test that kernel and mark this as a duplicate of that bug report if it fixes your flickering as well?

Sure I can test it, where can I get that kernel?

Geir Ove Myhr (gomyhr) wrote :
Cody Russell (bratsche) on 2009-08-26
Changed in xsplash:
status: New → Invalid

I didn't install the test kernel, I upgraded all packages today and finally I see the cause the the flickering, for some reason at the login screen the brightness keeps shifting up and down, if I tune it down with my laptop key, it stops. I didn't restarted yet to see that if it fixes it permanently, but I guess this is a good hint to the source of the problem.

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty

Architecture: i386
CurrentDmesg:
 [ 30.624287] agpgart-via 0000:00:00.0: AGP 2.0 bridge
 [ 30.624309] agpgart-via 0000:00:00.0: putting AGP V2 device into 4x mode
 [ 30.624352] nvidia 0000:01:00.0: putting AGP V2 device into 4x mode
 [ 37.280058] eth0: no IPv6 routers present
DistroRelease: Ubuntu 9.10
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: VIA Technologies, Inc. VT8367-8233
NonfreeKernelModules: nvidia
Package: xserver-xorg-video-intel 2:2.8.1-1ubuntu1
PackageArchitecture: i386
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: root=UUID=efe2eb86-9283-451c-90ee-7d0c8b741247 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
 libdrm2 2.4.12+git20090801.45078630-0ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
Uname: Linux 2.6.31-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
Xrandr: Error: command ['xrandr', '--verbose'] failed with exit code 1: Can't open display
dmi.bios.date: 11/26/2002
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: VT8367-8233
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd11/26/2002:svnVIATechnologies,Inc.:pnVT8367-8233:pvr:rvn:rnVT8367-8233:rvr:cvn:ct3:cvr:
dmi.product.name: VT8367-8233
dmi.sys.vendor: VIA Technologies, Inc.
fglrx: Not loaded
glxinfo: Error: command ['glxinfo'] failed with exit code 255: Error: unable to open display
setxkbmap: Error: command ['setxkbmap', '-print'] failed with exit code 255: Cannot open display "default display"
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-9-generic
xdpyinfo: Error: command ['xdpyinfo'] failed with exit code 1: xdpyinfo: unable to open display "".

Same issue here on a MSI Wind U100 with 945GME as DjDarkman describes it

The osd brightness keeps shifting up and down - if I tune it down with my laptop key, it stops.
also the lcd brightness switches between levels (flickering)

What it looks like: youtube.com/watch?v=ipD2rQwJpM0

The video shows exactly what I'm experiencing. And my Karmic installation is up to date.

Geir Ove Myhr (gomyhr) on 2009-09-07
tags: removed: jaunty
summary: - [i945] Screen flickers after jaunty update
+ [i945] Screen flickers after upgrade to karmic
Geir Ove Myhr (gomyhr) on 2009-09-07
tags: added: backlight
Bryce Harrington (bryce) on 2009-10-10
description: updated

If I right click something like the panel, the flickering stops after the context menu appears, but it could sometimes make the gnome settings deamon crash.

Jonathan Thomas (echidnaman) wrote :

displayconfig has not been around since Hardy.

Changed in displayconfig-gtk (Ubuntu):
status: New → Invalid

What component is responsible for calibrating the screen brightness then? This IMHO is an important issue, it makes Ubuntu look absolutely useless to average consumers, no average person would ever guess that they have to right click something to stop this insane flickering.

I have an up to date system, and I even reinstalled Ubuntu using the Beta CD image, to make sure, that the problem is not some upgrade problem, this even happens on a live CD session.

summary: - [i945] Screen flickers after upgrade to karmic
+ [Karmic] [i945] Screen flickers due to constantly changing brightness
+ level
Jonathan Reeve (jon-reeve) wrote :

I'm having a similar issue, I think. In GDM, the brightness fluxuates between roughly 80-90%, and only stops when I'm fully logged in. Once I'm logged in, the brightness will stay the same (usually very low) and if I attempt to change it, it will fluxuate between values. For example, if I tune the brightness down to around 30%, it will fluxuate between roughly 30-40%, and same goes for every setting. I haven't tried manually setting the brightness levels with a command yet, because I don't know what that command would be.

Jonathan Reeve (jon-reeve) wrote :

Oh, I meant to say that I also have an Intel 945M running on an MSI Wind U100.

#Ernesto (akeymer) wrote :

MSI wind with intel 945. No problem with Jaunty, screen flickers with Karmic update.
Problem apears when connecting/disconnecting power source or closing the lid (dim screen). It goes away by killing and restarting gnome-power-manager.

Isn't this the same buag as bug412492 ?

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/412492

That bug apears as "Fix released"...

budgie100 (pburges) wrote :

Medion Akoya E1210 (msi u100 wind clone)
Screen brightness still flickers until right click over panel.

Christian González (droetker) wrote :

Using an upgraded Karmic RC on a MSI Wind U100, the screen flickers too after login.
Only thing that helps is killing gnome-power.manager and starting it again.

This is a serious bug - Ubuntu is very unusable for the average user of a Wind.

I agree this, highly degrades UNR on MSI Wind, an since netbooks are playing a critical role these days, I find it really strange that this bug is ignored by the developers.

This looks to be a bug of the gnome-power-manager.

cob (cobbjbc) wrote :

I had the same problem once on my Wind U100. It happened when I used the hotkey (Fn+F4) to lower the brightness. It was already all the way down, then it started to automatically bounce up one level and back down repeatedly. I had to reboot to normalize the system.

    I figured out a solution that works indefinitely, at least till an
update comes along anyway. Go to applications>settings>Xfce 4 Settings
Manager>Power Management and all settings for monitor and brightness to
never. So far this has worked, as long as I don't try to adjust the
brightness because that would trigger our little problem again which I don't
wanna do. So until there is a fix this works fine, actually I'll keep my
settings this way just in case. Hope this helps.

On Mon, Nov 2, 2009 at 8:59 PM, cob <email address hidden> wrote:

> *** This bug is a duplicate of bug 415023 ***
> https://bugs.launchpad.net/bugs/415023
>
> I had the same problem once on my Wind U100. It happened when I used
> the hotkey (Fn+F4) to lower the brightness. It was already all the way
> down, then it started to automatically bounce up one level and back down
> repeatedly. I had to reboot to normalize the system.
>
> --
> [Karmic] [i945] Screen flickers due to constantly changing brightness level
> https://bugs.launchpad.net/bugs/413399
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (via bug 415023).
>
> Status in X.org xf86-video-intel: New
> Status in XSplash: Invalid
> Status in “displayconfig-gtk” package in Ubuntu: Invalid
> Status in “gnome-settings-daemon” package in Ubuntu: New
> Status in “xserver-xorg-video-intel” package in Ubuntu: Triaged
>
> Bug description:
> I have an MSI Wind U90X 037EU netbook with an Intel card, I had previously
> Jaunty Ubuntu Netbook Remix, I upgraded to Karmic. After the upgrade the
> screen flickered. After login, I opened "Display", I did not set anything
> since every setting was ok , so I just pressed the OK, button, this stopped
> the flickering after login, but it still exists at login, I looked at the
> xorg.conf and found nothing that can cause this issue.
>
> I assume there must be something wrong with the default refresh rate or
> something similar.
>
> [lspci]
> 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME
> Express Integrated Graphics Controller [8086:27ae] (rev 03)
> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
>
>

Uwe Mock (u-mock) wrote :

I have this issue with Karmic on an Asus laptop which has the i830 graphics chip. Unfortunately, Robert's suggestion (#60) didn't work for me.

So I have the flickering, and my screen is moved to the right. The funny thing is that I have to click to the places where things are supposed to be, not where they appear on the shifted screen. That means I have to click somewhat left to activate a button or menu item that appears to be a little more to the right.

Uwe Mock (u-mock) wrote :

I was now successful by adding the nomodeset option to my kernel options in menu.lst. Everything is back in order with this option.

Commoner (commoner51) wrote :

I followed Uwe's advice and added nomodeset option. Immediately my screen ceased to flicker. Thanks a lot! I have an old HP Omibook XE3L laptop.

To post a comment you must log in.