xsplash doesn't timeout to reveal the user session

Reported by David Barth on 2009-08-12
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xsplash
High
Cody Russell
gnome-panel (Ubuntu)
High
Unassigned
Karmic
High
Unassigned
nautilus (Ubuntu)
Medium
Unassigned
Karmic
Medium
Unassigned
xsplash (Ubuntu)
High
Cody Russell
Karmic
High
Cody Russell

Bug Description

If something goes wrong while opening the user session, xsplash should timeout so that it reveals the desktop even if it does not receive the 2 signals it is waiting for.

David Barth (dbarth) on 2009-08-12
affects: ubuntu → xsplash (Ubuntu)
Changed in xsplash:
assignee: nobody → Cody Russell (bratsche)
Steve Langasek (vorlon) on 2009-08-12
Changed in xsplash (Ubuntu Karmic):
importance: Undecided → High
milestone: none → karmic-alpha-4
Changed in xsplash:
importance: Undecided → High
Steve Langasek (vorlon) on 2009-08-12
Changed in xsplash (Ubuntu Karmic):
assignee: nobody → Cody Russell (bratsche)
Cody Russell (bratsche) on 2009-08-12
Changed in xsplash:
status: New → Fix Committed
Ken VanDine (ken-vandine) wrote :

Fixed in 0.4, packaging updated in lp:~xsplash-team/xsplash/ubuntu

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xsplash - 0.4-0ubuntu1

---------------
xsplash (0.4-0ubuntu1) karmic; urgency=low

  * New version
    - Fallback to a timer if the signals aren't received (LP: #412455)

 -- Ken VanDine <email address hidden> Wed, 12 Aug 2009 12:27:18 -0400

Changed in xsplash (Ubuntu Karmic):
status: New → Fix Released
Changed in xsplash:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

I understand (as mentioned in the duplicate bug #412555) that the flipside of this bug is that the timeout is never supposed to be reached because something is supposed to signal xsplash that the desktop is set up, and this isn't currently happening. Opening a task on gnome-session, which seems to be the most probable package to do this.

Changed in gnome-session (Ubuntu Karmic):
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
importance: Undecided → High
milestone: none → karmic-alpha-5
status: New → Triaged
Martin Pitt (pitti) wrote :

Cody, what exact signal needs to be sent to xsplash? D-Bus/SIGUSR1/etc? Do you have an example (dbus-send/kill/etc.) which triggers the xsplash shutdown? Thanks!

Changed in gnome-session (Ubuntu Karmic):
assignee: Ubuntu Desktop (ubuntu-desktop) → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2009-08-24
summary: - xsplash doesn't timeout to reveal the user session
+ shut down xsplash when session is ready

dbus-send --system --type=method_call --dest=com.ubuntu.BootCurtain /com/ubuntu/BootCurtain com.ubuntu.BootCurtain.SignalLoaded string:nautilus

dbus-send --system --type=method_call --dest=com.ubuntu.BootCurtain /com/ubuntu/BootCurtain com.ubuntu.BootCurtain.SignalLoaded string:gnome-panel

Martin Pitt (pitti) wrote :

This was discussed on
  http://mail.gnome.org/archives/desktop-devel-list/2009-August/msg00064.html

It seems we don't currently have a way to do this signalling from gnome-session, so we need to patch gnome-panel and nautilus for now. Eventually gnome-session should grow that feature, of course.

affects: gnome-session (Ubuntu Karmic) → gnome-panel (Ubuntu Karmic)
Changed in nautilus (Ubuntu Karmic):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
status: New → Triaged
milestone: none → karmic-alpha-5
importance: Undecided → Medium
Changed in gnome-panel (Ubuntu Karmic):
assignee: Canonical Desktop Team (canonical-desktop-team) → Robert Ancell (robert-ancell)
Changed in nautilus (Ubuntu Karmic):
assignee: Canonical Desktop Team (canonical-desktop-team) → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

I am confused about what this bug is about. It was originally reported as adding a method for xsplash to uncurtain if gnome-panel/nautilus take too long to load. This needs to be implemented in xsplash.
It seems to be changed to "the session is not sending the loaded signals". These signals were implemented in the sprint and work afaik.
What is required here?

Martin Pitt (pitti) wrote :

Robert says that gnome-panel and nautilus already send those d-bus signals.

Changed in gnome-panel (Ubuntu Karmic):
assignee: Robert Ancell (robert-ancell) → nobody
milestone: karmic-alpha-5 → none
status: Triaged → Fix Released
summary: - shut down xsplash when session is ready
+ xsplash doesn't timeout to reveal the user session
Changed in nautilus (Ubuntu Karmic):
assignee: Robert Ancell (robert-ancell) → nobody
milestone: karmic-alpha-5 → none
status: Triaged → Fix Released

On Tue, Aug 25, 2009 at 11:51:40PM -0000, Robert Ancell wrote:
> I am confused about what this bug is about. It was originally reported as adding a method for xsplash to uncurtain if gnome-panel/nautilus take too long to load. This needs to be implemented in xsplash.
> It seems to be changed to "the session is not sending the loaded signals". These signals were implemented in the sprint and work afaik.
> What is required here?

Bug 412555 (which was "the session is not sending the loaded signals" on
UNR) was marked as a duplicate of this one. If this bug is about something
else, please undupe that one and make sure that it has been looked after.

--
 - mdz

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers