X.org xf86-video-intel

[sandybridge-m-gt2] False GPU lockup render.IPEHR: 0x7a000002

Reported by jhn on 2012-04-09
106
This bug affects 22 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Happens when running gmsh on a asus N43SN ubuntu 12.04

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Chipset: sandybridge-m-gt2
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Sun Apr 8 09:15:11 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature: [sandybridge-m-gt2] GPU lockup render.IPEHR: 0x7a000002 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
InterpreterPath: /usr/bin/python2.7
MachineType: ASUSTeK Computer Inc. N43SN
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=b5d7825a-b60f-4a9b-b125-15923ace618b ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-m-gt2] False GPU lockup render.IPEHR: 0x7a000002
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 02/15/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: N43SN.302
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: N43SN
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN43SN.302:bd02/15/2011:svnASUSTeKComputerInc.:pnN43SN:pvr1.0:rvnASUSTeKComputerInc.:rnN43SN:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: N43SN
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.7.4-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

jhn (jenshnielsen) wrote :
jhn (jenshnielsen) wrote :

See #977282 for the gmsh side of the bug.

tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
MikeRich (bigmeanmikerich) wrote :

This bug affects me when using google maps in firefox. Every time I select a different route, the screen flashes black for a moment and then comes back with a crash notification.

jhn (jenshnielsen) wrote :

I see the same issue when running grim fandango in residualvm www.residualvm.org. Happens
at the same point every time.

Forwarding this bug from Ubuntu reporter jhn:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/977281

[Problem]
Another 0x7... bug, and possibly dupe of the WebGL/google maps bug, but occurs when using gmsh.

[Original Description]
Happens when running gmsh on a asus N43SN ubuntu 12.04

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Chipset: sandybridge-m-gt2
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Sun Apr 8 09:15:11 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature: [sandybridge-m-gt2] GPU lockup render.IPEHR: 0x7a000002 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
InterpreterPath: /usr/bin/python2.7
MachineType: ASUSTeK Computer Inc. N43SN
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=b5d7825a-b60f-4a9b-b125-15923ace618b ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-m-gt2] False GPU lockup render.IPEHR: 0x7a000002
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 02/15/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: N43SN.302
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: N43SN
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN43SN.302:bd02/15/2011:svnASUSTeKComputerInc.:pnN43SN:pvr1.0:rvnASUSTeKComputerInc.:rnN43SN:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: N43SN
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.7.4-0ubuntu3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Created attachment 60133
BootDmesg.txt

Created attachment 60134
CurrentDmesg.txt

Created attachment 60135
i915_error_state.txt

Created attachment 60136
XorgLog.txt

Bryce Harrington (bryce) wrote :

jhn - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=48795 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Confirmed
MikeRich (bigmeanmikerich) wrote :

Can confirm that this crash is occuring whenever WebGL is used. Google maps is causing this crash every time I use it, before I am able to click the "disable" button on the MapsGL feature.

The same of MikeRich happened to me. When i was enabling MapsGL, my screen blinked.

vlad (i-design-you-use) wrote :

I could use google mapsGL a few weeks ago, but now this issue occurs.
Running ubuntu x64 12.04, with latest updates, kernel: 3.3.2-030302-generic x64 on HP-ProBook-4530s

asmodey (pavel-finkelshtein) wrote :

same problem as vlad's. Using Samsung RC530 (optimus) + bumblebee.

Yeah, the 0x7a000002 isn't super helpful...it's PIPE_CONTROL a.k.a. flush. In other words, the GPU was doing something and it died. :)

It'd be worth checking if the kernel fix for MapsGL/Google Earth/gzdoom/etc. fixes this. My guess is that it does. If not, I'll certainly be glad to try and debug it further.

Presumably fixed in Linux v3.4. If problems persist, feel free to reopen.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

Upstream thinks this has been fixed with kernel 3.4. If you still reproduce it, feel free to reopen the upstream bug report.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.