Xorg crash automatic logout

Bug #899890 reported by Enternix on 2011-12-04
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
New
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Maybe this is a duplicate of Bug #887794:
Since I removed Ubuntu 11.04 and installed 11.10 it is a disaster: nearly everyday my system crashes and I am logged out automatically and all my unsaved documents are lost. So I made a new installation but the problem remains. So I tried out Gnome 3 and LXDE instead of Unity. In Gnome 3 the logouts remained but in LXDE the system seems to be stable. I will try XFCE as well, but I would rather use Unity!

P.S.: I made this apport-bug right after a crash today.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Sun Dec 4 13:08:45 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21c5]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: LENOVO 021722G
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=1cf33934-292a-4fc1-a2e6-3bde580869b5 ro noplymouth
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/13/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 84ET21WW (1.05 )
dmi.board.name: 021722G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr84ET21WW(1.05):bd10/13/2010:svnLENOVO:pn021722G:pvrThinkPadEdge:rvnLENOVO:rn021722G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 021722G
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Enternix (enternix) wrote :
tags: added: logout
description: updated
Dave Gilbert (ubuntu-treblig) wrote :

Backtrace:
[ 343.970] 0: /usr/bin/X (xorg_backtrace+0x26) [0x460566]
[ 343.970] 1: /usr/bin/X (0x400000+0x64b7a) [0x464b7a]
[ 343.970] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f83899bf000+0x10060) [0x7f83899cf060]
[ 343.970] 3: /usr/lib/xorg/modules/extensions/librecord.so (0x7f838736c000+0x26a8) [0x7f838736e6a8]
[ 343.971] 4: /usr/bin/X (_CallCallbacks+0x34) [0x434264]
[ 343.971] 5: /usr/bin/X (WriteToClient+0x21a) [0x4635aa]
[ 343.971] 6: /usr/lib/xorg/modules/extensions/libdri2.so (ProcDRI2WaitMSCReply+0x52) [0x7f8386d53c62]
[ 343.971] 7: /usr/lib/xorg/modules/extensions/libdri2.so (DRI2WaitMSCComplete+0x53) [0x7f8386d523a3]
[ 343.971] 8: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f8386aff000+0x25fd4) [0x7f8386b24fd4]
[ 343.971] 9: /usr/lib/x86_64-linux-gnu/libdrm.so.2 (drmHandleEvent+0xa3) [0x7f8386f5d3c3]
[ 343.971] 10: /usr/bin/X (WakeupHandler+0x5b) [0x433a6b]
[ 343.971] 11: /usr/bin/X (WaitForSomething+0x1b6) [0x45e016]
[ 343.971] 12: /usr/bin/X (0x400000+0x2f912) [0x42f912]
[ 343.971] 13: /usr/bin/X (0x400000+0x232fe) [0x4232fe]
[ 343.971] 14: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7f83888fb30d]
[ 343.971] 15: /usr/bin/X (0x400000+0x235ed) [0x4235ed]
[ 343.971] Segmentation fault at address 0x7f838247e010
[ 343.972]
Caught signal 11 (Segmentation fault). Server aborting

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Enternix (enternix) wrote :

Still the same problem. I tried out ubuntu 11.10 32-Bit and 64-Bit a few days ago and nothing changed: the system crashes regulary. So I am using Xubuntu 11.10 again, which had not a single crash since I installed it before two month.
I hope, the problem will be fixed in Ubuntu 12.04 with Unity!!!!!

flusi100 (flusi100) wrote :

Same Problem here.

Chris Wilson (ickle) wrote :

The librecord bug! Update Xorg.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers