[i945] Xorg freezes

Bug #445056 reported by Christopher Tozzi on 2009-10-07
104
This bug affects 18 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
xserver-xorg-video-intel (Ubuntu)
Undecided
Vinicius Marx
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: xserver-xorg-video-intel

Running the Karmic beta release in a live session, my screen freezes entirely (no mouse movement, no keyboard input) about a minute after the desktop appears if desktop effects are enabled. With desktop effects disabled, there is no problem.

I highly suspect that the bug is the same one described at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/400934 ; however that report has been marked invalid due to lack of information. I have obtained the requested information in that thread, including dmesg and Xorg.0.log after the crash, and am posting them here. Note that dmesg and Xorg.0.log didn't seem to have changed after the crash, so I'm not sure how helpful they'll actually be in diagnosing the problem.

I used an ssh session to pull the logs from the machine after the crash. The system running the live session was perfectly responsive in my ssh session, but X remained frozen.

Please let me know if I can provide any other information to help get this fixed.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub [8086:2770] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)

Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Christopher Tozzi (cjt34) wrote :
Bryce Harrington (bryce) on 2009-10-07
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Antioch (sesshomaru-2k3) wrote :

Might this be a clone of (https://bugs.launchpad.net/bugs/433541)? Worth seeing if the new kernel and Intel Xorg drivers do the trick. Check the last few posts of that thread.

Bryce Harrington (bryce) on 2009-10-09
summary: - [i945] (UXA) Intel Corporation 82945G/GZ Integrated Graphics Controller
- [8086:2772] (rev 02) freezes
+ [i945] [i945] (UXA) Intel Corporation 82945G/GZ Integrated Graphics
+ Controller [8086:2772] (rev 02) freezes
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Bryce Harrington (bryce) on 2009-10-10
description: updated

Antioch: thanks for the suggestion. Unfortunately I tested it again an hour ago on a fully upgraded Karmic system (installed to hard disk) and the behavior has not changed. It still freezes about a minute after enabling desktop effects, and neither dmesg nor Xorg.0.log shows anything afterwards that looks relevant to the crash. I will keep applying the Karmic updates and rebooting daily to see if there's a difference; in the meantime I'm happy to provide any other information that will help get this fixed before the final release.

Christopher Tozzi (cjt34) wrote :

Just an update that as of today, on a fully upgraded Karmic system, I now experience the following new behavior:

1. with compiz enabled, X freezes within three seconds of Gnome loading. It used to take up to a minute

2. on the other hand, I can now use alt-printscreen-r-e to restart X. Before, this did not work, as the system seemed to accept no keyboard input at all after X froze

So in one respect things have gotten worse, in another they're slightly better. I will keep reporting back; please let me know if there's anything else I can do to help fix this--this is relatively popular hardware, I think, so I suspect it will be a show-stopper for many users upgrading to Karmic (unless they disable compiz, which many probably won't want to/know how to do). Has a report been filed upstream?

Still nothing relevant in dmesg or Xorg.log after the crash.

M (mzmcgrat) wrote :

I have been experiencing the same symptoms (hard lock up/freeze) on the same graphics hardware in a live session with Ubuntu Karmic-- I've tried Alpha 5, Alpha 6, and Beta. I would love to see this issue resolved, but I'm not sure how I can help when the live session freezes right as the desktop becomes visible.

[lspci]
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

I am running into a similar situation: after a fresh Karmic install (lpia architecture) in my machine, the screen froze completely seconds after logging in (including the mouse).
The only solution was to enter in safe mode via grub and disable desktop effects. If I enable them, things work for a few seconds until the screen freezes. For example, I can click on a few menus, move windows, etc. and I see the right effects (fade in, fade out, etc.) until it freezes.

I have the same graphics (82945G/GZ), in a CoolBox Minidesk 2002 computer (Atom 330, 2GB Ram, FoxConn motherboard).

I installed Ubuntu Karmic 9.10 with the alternate installer for lpia architecture.
My xserver-xorg-video-intel package version is 2:2.9.0-1ubuntu2

The "compiz-check" script prints this:

Gathering information about your system...

 Distribution: Ubuntu 9.10
 Desktop environment: GNOME
 Graphics chip: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
 Driver in use: intel
 Rendering method: AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap... [ OK ]
 Checking for non power of two support... [ OK ]
 Checking for composite extension... [ OK ]
 Checking for FBConfig... [ OK ]
 Checking for hardware/setup problems... [ OK ]

And lspci -v prints this:

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
        Subsystem: Foxconn International, Inc. Device 0d4b
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>
        Kernel driver in use: agpgart-intel
        Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
        Subsystem: Foxconn International, Inc. Device 0d4b
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at dc00 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at fea40000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

Sorry, forgot to include this: my current kernel is:
2.6.31-14-lpia
I also installed "linux-backports-modules-2.6.31-14-lpia" later via sinaptic but it did not help.

Christopher Tozzi (cjt34) wrote :

As a workaround, I've discovered that switching to EXA acceleration seems to work. To do that, open the file /etc/X11/xorg.conf and make sure you have a section that looks like:

Section "Device"
 Identifier "Configured Video Device"
        Option "AccelMethod" "exa"
EndSection

Then restart X and you should be able to enable desktop effects without a freeze.

Unfortunately, UXA acceleration continues not to work. If there's any information I can provide to figure this out, please let me know.

Christopher Tozzi (cjt34) wrote :

Unfortunately, the workaround mentioned above seems not actually to have helped. When I first tried it, I was able to use desktop effects for about an hour with no problems. I then rebooted, however, and X froze again within a minute of the desktop appearing. I haven't been able to reproduce the stable behavior.

I also noticed that X.org.log says "(WW) intel(0): Option "AccelMethod" is not used," so apparently this option is no longer valid, which explains why it didn't actually help as a workaround. Is there any other way to disable UXA acceleration in Karmic, or other thoughts on how we might work around this issue?

isecore (isecore) wrote :

For what it's worth I have the same symptoms on a Dell Inspiron 6000 series laptop. It's got an ATI x300 Radeon Mobility, so it's as far as I can tell not limited to Intel graphics. It uses the open-source ATI driver (since when I ask it to look for proprietary drivers it says none is available).

With desktop effects enabled X freezes after about 2-3 minutes. It freezes after about 1 minute if I use it, 2-3 if I just let it idle. Turn off desktop effects and everythings peachy.

Petar Velkovski (pvelkovski) wrote :

I have the same graphic, same revision etc. and NO problems at all.

[lspci -v]

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
 Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device 3140
 Flags: bus master, fast devsel, latency 0
 Capabilities: <access denied>
 Kernel driver in use: agpgart-intel
 Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
 Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device 3140
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fdf00000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at ff00 [size=8]
 Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Memory at fdf80000 (32-bit, non-prefetchable) [size=256K]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

Notice the

Memory at fdf00000 (32-bit, non-prefetchable) [size=512K]

difference from post #14. Is this of any relevance?

Christopher Tozzi (cjt34) wrote :

My lspci is:

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
 Subsystem: Elitegroup Computer Systems Device 2624
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at dc00 [size=8]
 Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Memory at fea40000 (32-bit, non-prefetchable) [size=256K]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

My "Memory at..." line is also different than the one in post #19 and the same as in #14, so this may well have something to do with it. Does anyone know what that value means or how to change it?

On another note, I have discovered that there are no freezes if I start compiz with the --indirect-rendering flag. I've been using it this way for several days with no problems. This appears to be an effective workaround.

However, I just tried starting desktop effects from gnome-appearance-properties and as expected, it resulted in a frozen desktop within less than a minute, so the original problem persists for me.

Petar Velkovski (pvelkovski) wrote :

I had to use the --indirect-rendering flag when I was using Compiz in Ubunty 9.04 (Jaunty) because of the memory corruption bug. But again it seams that I was lucky with 9.10 because I haven't experienced any freezes on my system with the default intel drivers that came with it. By the way, I am currently using drivers from xorg-edgers ppa (https://launchpad.net/~xorg-edgers/+archive/ppa), not because I really needed them, but because I got used to using this repository with Jaunty because it solved my intel graphic problems. But if you decide to give it a try, make sure you learn how to return your system in a working condition, when some of the updates break your graphic system (it can happen from time to time). But doing this, you can actively participate in testing the development versions of intel drivers and X.org, which I hope will result with better drivers with the future releases.

summary: - [i945] [i945] (UXA) Intel Corporation 82945G/GZ Integrated Graphics
- Controller [8086:2772] (rev 02) freezes
+ [i945] (UXA) Intel Corporation 82945G/GZ Integrated Graphics Controller
+ [8086:2772] (rev 02) freezes

Exactly the same here. Same graphic card and same problem.

I tried to solve the problem with some combinations of kernel and drivers. And the results:

kernel 2.6.31-15 + default driver set = freeze
kernel 2.6.31-15 + ubuntu-x-swat set = freeze
kernel 2.6.31-15 + xorg-edgers set = freeze
kernel 2.6.32-rc8 + default driver set = freeze
kernel 2.6.32-rc8 + ubuntu-x-swat driver set = freeze
kernel 2.6.32-rc8 + xorg-edgers driver set = freeze

And my `sudo lspci -v`:

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
 Subsystem: Hewlett-Packard Company Device 2a60
 Flags: bus master, fast devsel, latency 0
 Capabilities: [e0] Vendor Specific Information <?>
 Kernel driver in use: agpgart-intel
 Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
 Subsystem: Hewlett-Packard Company Device 2a60
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at ffa80000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at ec00 [size=8]
 Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Memory at ffa40000 (32-bit, non-prefetchable) [size=256K]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
 Capabilities: [d0] Power Management version 2
 Kernel driver in use: i915
 Kernel modules: i915

It's the same controller than Christopher and David. And exactly same problem.

Petar Velkovski (pvelkovski) wrote :

Has any one of you considered reporting this bug upstream? You can do it at https://bugs.freedesktop.org/. I suspect this has something to do with that "Memory at" portion.

Download full text (3.8 KiB)

This is a bug report taken from https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/445056.

If you follow the reports from the link above at least three of the users are having the same problem. The problem is that their desktops freeze as soon as they log in.

This is their lspci output:

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
        Subsystem: Foxconn International, Inc. Device 0d4b
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>
        Kernel driver in use: agpgart-intel
        Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
        Subsystem: Foxconn International, Inc. Device 0d4b
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at dc00 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at fea40000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915
------------------------------------------------------------------------
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
 Subsystem: Elitegroup Computer Systems Device 2624
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fea80000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at dc00 [size=8]
 Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Memory at fea40000 (32-bit, non-prefetchable) [size=256K]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915
-------------------------------------------------------------------------
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
 Subsystem: Hewlett-Packard Company Device 2a60
 Flags: bus master, fast devsel, latency 0
 Capabilities: [e0] Vendor Specific Information <?>
 Kernel driver in use: agpgart-intel
 Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
 Subsystem: Hewlett-Packard Company Device 2a60
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at ffa80000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at ec00 [size=8]
 Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Memory at ffa40000 (32-bit, non-prefetchable) [size=256K]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
 Capabilities: [d0] Power Management version 2
 Kernel driver in use: i915
 Kernel modules: i915
------------------------------------------------------------------------------
I on the other hand have NO FREEZING PROBLEMS AT ALL!

This is my lspci output:

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
 Subsystem: Holco Enterprise Co, Ltd/Shuttle Computer Device 3140
 Flags: bus master, fast devsel, latency 0
 Capabilities: <access denied>
 Kernel driver in use: agpgart-intel
 Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Int...

Read more...

This problem has reached a reasonable amount of people and at least 6 bugs have been reported on Launchpad:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/400934
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/445056
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/445719
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/450853
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/475429
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/485576

Steps to reproduce the problem:

1. Just start a session on a newly installed system.

After a few seconds, the X server freezes. When you try to restart it with "Alt + SysRq + E", it starts and freezes soon after.

The mouse and the keyboard does not respond. Only when the whole system is restarted, it becomes usable.

With the default driver (pre-compiled, which is in the repository), the problem seems to happen "randomly".

But it seems that this problem is related to transparency. I think this is because when a tool tip disappears (with an effect of translucency), the X server freezes.

This hypothesis gained strength when I tried to compile a driver and, when tested, the images simply do not have transparency: where would be transparent, was black. And yes, the problem persisted.

Even trying to debug the freeze, no useful log was obtained by any of the users.

In the link posted by the reporter of the bug there are some useful files (logs, etc.) that can help. But the problem seems to be related to the memory address of the video card. Attached is a small table with information from different video cards.

Created an attachment (id=31558)
Comparative table

I made a report for this bug upstream. You can find it at http://bugs.freedesktop.org/show_bug.cgi?id=25345.
If you have any interest that this bug is resolved or at least worked on, register at https://bugs.freedesktop.org/ and start participating by giving any information that you have related to this bug.

Ok Petar. Thank you for the help.

Hi Peter,

When reporting a bug against the Intel driver, here are some of the
most essential pieces of information:

    * GPU model

    * Driver version

    * Kernel version

A big advantage of submitting bug reports with the Xorg.0.log file is
that it contains all of these.

Anyway, your bug here mentions the GPU (945) but neither the kernel
nor driver version.

I did follow some of the provided links looking for driver versions
and found one mention of driver 2.8.1. Is that the driver used in all
cases? Has anyone attempted using a newer driver, (such as 2.9.0 or
the very recent 2.9.99.901 snapshot?). If so, it would be interesting
to know if there is any change in the behavior there.

-Carl

Sorry about the incomplete info: This is a report #22 from launchpad:

Marco Biscaro wrote on 2009-11-28:

Exactly the same here. Same graphic card and same problem.

I tried to solve the problem with some combinations of kernel and drivers. And the results:

kernel 2.6.31-15 + default driver set = freeze
kernel 2.6.31-15 + ubuntu-x-swat set = freeze
kernel 2.6.31-15 + xorg-edgers set = freeze
kernel 2.6.32-rc8 + default driver set = freeze
kernel 2.6.32-rc8 + ubuntu-x-swat driver set = freeze
kernel 2.6.32-rc8 + xorg-edgers driver set = freeze

These are the intel driver versions contained in the explanation above:

default driver
2.9.0

xorg-edgers
2.9.0~git20091007.03e8e64f probably to 2.9.0+git20091130.2.6729b508

I read more carefully launchpad bug reports and noticed this report:
-----------------------------------------------------------------------------
As a workaround, I've discovered that switching to EXA acceleration seems to work. To do that, open the file /etc/X11/xorg.conf and make sure you have a section that looks like:

Section "Device"
 Identifier "Configured Video Device"
        Option "AccelMethod" "exa"
EndSection

Then restart X and you should be able to enable desktop effects without a freeze.

Unfortunately, UXA acceleration continues not to work. If there's any information I can provide to figure this out, please let me know.
------------------------------------------------------------------------------
Since I am not hit by this bug I might have been somehow misguided with the launchpad reports. The reports state that this is freeze is happening when desktop effects (Compiz) are activated. Isn't this more related to libdrm-intel or libdrm2?

Created an attachment (id=31668)
Xorg.0.log from the original bug reporter

Created an attachment (id=31669)
dmesg output from the original bug reporter

Created an attachment (id=31670)
glxinfo from original reporter

Created an attachment (id=31671)
lshal drom the original reporter

Created an attachment (id=31672)
lsmod from the original reporter

Created an attachment (id=31673)
lspci from the original reporter

Created an attachment (id=31674)
uname from the original reporter

Created an attachment (id=31675)
xdpyinfo from the priginal reporter

libdrm-intel in Ubuntu 9.10 is 2.4.14

and those that used xorg-edgers repository might have tested with

2.4.15+git20091201.8ffd2e14

Same versions for libdrm2

And adding the system freezes when using any application that involves 3D acceleration (compiz, games, blender, etc).

And the EXA acceleration does not solve (it really is taken into account or is simply discarded?).

Created an attachment (id=31695)
My `lspci -vvnn`output

I am the original reporter of the on Launchpad. Everything posted above by Petar and Marco is consistent with my experience.

I wold like to add two points that may be useful. First, I have discovered that when compiz is started with the --indirect-rendering flag, the freeze does NOT occur and the video driver functions with no problem.

Also, to clarify on EXA acceleration issue: I originally stated in the Launchpad bug report that adding 'Option "AccelMethod" "exa"' to xorg.conf solved the problem. I later realized this was not the case--the X server still ended up freezing shortly after I made that comment in the bug report--and furthermore that according to the Xorg.0.log, the "AccelMethod" option was not even recognized when X started (presumably this option has been deprecated by X in the latest version of Ubuntu; it used to be valid). So I assume that editing my xorg.conf file didn't actually do anything and there is currently no reason to believe that enabling EXA acceleration solves the problem. I apologize for the confusion about this.

Please let me know if I can provide any other pertinent information.

Since I am not hit by this bug, can all of the bug reporters make something clear to me?
Are you experiencing this freezes only when you have Compiz activated?

Christopher Tozzi (cjt34) wrote :

Petar: yes, it only happens when compiz is activated.

Thanks also for all your work reporting the bug upstream. When I get a freer moment I will subscribe there as well and help to provide information; I see that they're asking for some information that you're not well qualified to find since the bug isn't affecting you.

In fact, the system freezes when using any kind of 3D acceleration, not only Compiz (eg, games, blender).

And, no. EXA doesn't solve the problem.

@Petar: yes, these freezes only happen if Compiz is activated. I have to run the system without Compiz in order to be able to work with it.

Xlego6 (xlego6) wrote :

Same bug here, and it freezes when using any 3d accel in less than a minute (cannot play games and etc.)

Geir Ove Myhr (gomyhr) wrote :

We have had several reports of freezes (GPU hangs) on i945 chipsets
(945G, 945GM and 945GME, all of which uses the GMA950 graphics core)
in Karmic. I would like to get some testing going so that we may
identify the cause and give upstream all the information they need
(and possibly some they do not need) so that they can fix this before
Lucid is out. I have set up a wiki page to coordinate the effort:
https://wiki.ubuntu.com/X/Lucidi945Freezes . There is a list of test
that I think will be useful in order to isolate where the problem is
and a table where you can fill in your test results. If we're lucky
there is only one underlying problem, and we will probably get
consistent test results. Otherwise, different test results may group
the problems in different categories.

I realize that doing all the tests can be quite time consuming (it
calls for tests on both Karmic and Lucid), and if you are only able to
do some of the tests it would be nice if you could fill in those cells
in the test result table.

My initial guess is that the bug is in mesa, since it seems to be
related to 3D operations. It would be nice if we could also get some
testing of different mesa versions, but I'm not aware of any that are
pre-built yet.

tags: added: 945g freeze
Geir Ove Myhr (gomyhr) wrote :

I have uploaded an older version of mesa to my "old" PPA: https://launchpad.net/~gomyhr/+archive/old/+packages . By testing this, we can find out if this is caused by a bug in mesa which is introduced after version 7.5.

Unfortunately, installing it is probably not as easy as just adding the PPA to /etc/apt/sources and do `sudo apt-get update; sudo apt-get upgrade`, since the version in the PPA is older than then one in karmic and I didn't do any PPA magic to make it want to upgrade anyway. The easiest way I can think about is probably to download all the deb-files for your architecture (*i386.deb) to an empty folder and do a `dpkg -i -O *.deb` in that folder. That will install only the packages that already have an installed version on your system.

If Karmic freezes with this version, I can try to go all the way back to the Jaunty version.

PS: I don't have a Karmic installation (I only have Jaunty and Lucid) so I haven't had a chance to test that the packages even work.

Well, I've tried this set of packages.

At first look, I thought that they solved the problem:

* I've used Compiz effects without problem
* I played OpenArena during 5 minutes (in medium configuration) without problem

BUT...

* When I've opened Blender, it froze instantly.
* When I was writing a message here about this behaviour, the system froze again (exactly when a Firefox's tooltip appeared).

If I remember correctly, the same used to happen in Jaunty. We know that the biggest problem is in version 7.6 of the Mesa. But version 7.5 also brings problems (though smaller).

I still think that the problem has something to do with transparency effects (mainly because of the problem of the tooltip).

In short, the problem persists. At least in my case.

Just complementing, the downgrade can be done through the apitude (just add the repository's entry and downgrade the packages).

Geir Ove Myhr (gomyhr) wrote :

Marco, the main point of downgrading is not to find a "better" version of mesa, but to try to identify when in the development cycle the problems were introduced. So I wouldn't worry about the Blender behaviour -- we know that a lot of bug in the Jaunty version of mesa that were affecting blender has been fixed in the Karmic version. The freeze is a bit more worrying, but if there is a very noticeable difference in how often the system freezes with mesa 7.5, we may still be able to find the point where it went from "almost good" to "bad" with respect to the freezes. What we want is to be able to tell the upstream developers that when they changed this or that, the frequent freezes appeared. Usually, identifying that is half the work of resolving the bug.

There is another confirmation at bug 450853 that downgrading to mesa 7.5 helps. The next step is to try and do some bisecting to find the bad commit. I will come back to that.

Changed in xserver-xorg-video-intel:
status: Unknown → In Progress
Geir Ove Myhr (gomyhr) wrote :

I have uploaded a newer version of mesa to my PPA (https://launchpad.net/~gomyhr/+archive/old/+packages). Whether this freezes or not will provide a good starting point for a git-bisect in order to find a bad commit.

There is a tutorial for bisecting mesa at https://wiki.ubuntu.com/X/BisectingMesa and a more detailed account at http://tuxpool.blogspot.com/2009/12/bisecting-mesa-bug-446632.html . Both web pages have ATI chipsets, so instead of r100, r200 and radeon drivers, i915 is probably the right driver for 945G chipsets.

It would also be useful if those that are affected by this bug could test Lucid to verify that the bug stil exist there (that is where it can potentially be fixed). With Lucid, we would also appreciate a batchbuffer dump. There are instructions for how to get that at https://wiki.ubuntu.com/X/Troubleshooting/Freeze .

Petar Velkovski (pvelkovski) wrote :

I am not sure which version of xserver-xorg-video-intel you are using for testing in Lucid, but I must warn you that there is a serious problem with xserver-xorg-video-intel 2.10.0 that also causes freezes. The bug was reported upstream since 6th of December and there is still no solution for it. This is the link for the bug report:

http://bugs.freedesktop.org/show_bug.cgi?id=25475

For the lazy ones :), the bug gives this message when you switch to virtual terminal (Ctrl+F1) and type dmesg:
.......
[drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged

Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] (UXA) Intel Corporation 82945G/GZ Integrated Graphics Controller
- [8086:2772] (rev 02) freezes
+ [i945] [i945] (UXA) Intel Corporation 82945G/GZ Integrated Graphics
+ Controller [8086:2772] (rev 02) freezes

(In reply to comment #16)
> I am the original reporter of the on Launchpad. Everything posted above by
> Petar and Marco is consistent with my experience.
...
> editing my xorg.conf file didn't actually do anything and there is currently no
> reason to believe that enabling EXA acceleration solves the problem. I
> apologize for the confusion about this.

Thanks for the clarifications.

And Christopher,

I'm delighted to have the original reporter here to track the issue.
We'll leave this bug open as long as you're having issues and close it
when your issues are resolved.

The Xorg.0.log file attached to this bug report shows an Intel driver
version of 2.8.1. Is that really accurate? That's old enough to have
lots of known bugs that have since been fixed.

Have you tested with newer versions of xf86-video-intel, (and libdrm
and the kernel)? If so, could you please report the latest versions
known to exhibit the bug?

Thanks,

-Carl

Carl: I tested the issue tonight using the development build of Ubuntu 10.04. Unfortunately, the behavior was the same. On the first try, my desktop froze within ten seconds of logging in. On the second try, it lasted about two minutes. Again, both times, it was only X that froze; I was able to ssh in and pull the log files, which I'm attaching here.

I realize that the Ubuntu 10.04 development kernel (2.6.32) and the Intel video driver that ships with Ubuntu 10.04 are not the most up-to-date (even though they are considerably newer than what was previously tested). If you have reason to believe that the very latest code would solve the problem, let me know and I'll compile a new kernel along with the latest version of X, etc.

Chris

Created an attachment (id=34337)
Xorg.0.log from Ubuntu 10.04 alpha

Created an attachment (id=34338)
dmesg from Ubuntu 10.04 alpha

Created an attachment (id=34339)
uname -a for Ubuntu 10.04 alpha

(In reply to comment #18)
> Carl: I tested the issue tonight using the development build of Ubuntu 10.04.
> Unfortunately, the behavior was the same. On the first try, my desktop froze
> within ten seconds of logging in. On the second try, it lasted about two
> minutes. Again, both times, it was only X that froze; I was able to ssh in and
> pull the log files, which I'm attaching here.

Thanks for testing.

> I realize that the Ubuntu 10.04 development kernel (2.6.32) and the Intel video
> driver that ships with Ubuntu 10.04 are not the most up-to-date (even though
> they are considerably newer than what was previously tested). If you have
> reason to believe that the very latest code would solve the problem, let me
> know and I'll compile a new kernel along with the latest version of X, etc.

There are regular bug fixes, so there definitely are advantages to testing the
latest code. You might be able to take advantage of the "xorg-edgers" repository
of packages that exists specifically to help users of Ubuntu test the latest
drivers, etc. (which might be easier than rebuilding everything from scratch).

I don't know if the xorg-edgers repository has a newer kernel or not, but if you
could run with 2.6.34-rc1 then there's a nice feature of the driver where it will
detect a GPU and save the most recent batch-buffer before the error into

/sys/kernel/debug/dri/0/i915_error_state

This assumes that debugfs is mounted which, if not, you can do with:

sudo mount -t debugfs debugfs /sys/kernel/debug

If you can't run 2.6.34-rc1 then you can try to similarly capture an error-
causing batchbuffer by triggering the error and then running the intel_gpu_dump
tool (from the intel-gpu-tools repository on freedesktop.org---I don't know
if Ubuntu packages it or not).

Let us know if you're able to capture a dump through either of those approaches,
(and please clear the NEEDINFO keyword when you do).

Thanks,

-Carl

@Christopher Tozzi

There is a place for downloading newer kernels built for Ubuntu.

The link is
http://kernel.ubuntu.com/~kernel-ppa/mainline/

open it in your webbrowser, choose v2.6.34-rc1/ and manualy download

linux-headers-2.6.34-020634rc1
linux-image-2.6.34-020634rc1
(i386 or amd64) depending from your system
and also linux-headers that finishes with "all"

If you downloaded the DEB packages to your Desktop, open console, type:
cd ~/Desktop
dpkg -i lin*.deb

That should install the latest kernel that you've downloaded. Reboot the system and do the testing.

Desde a versão 9.10 acontece este congelamento da tela, usando a versão 10.04 ela demora um pouco mais a acontecer mas congela da mesma forma.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Vinicius Marx (tupac-amaru-shakur-2pac)

I did some tests with kernel 2.6.35-020635rc1-generic. I've added three attachments:

1. VBIOS dump (/sys/devices/pci0000:00/0000:00:02.0/rom)
2. Register Dump (intel_reg_dump)
3. kern.log (the most interesting - there is a call trace at 10:58:43, I think it could help)

Created an attachment (id=36460)
VBIOS dump

Created an attachment (id=36461)
Register Dump

Created an attachment (id=36462)
kern.log

Compressed with bzip. Too big to be posted as plain text.

Additional test info:

kernel version: 2.6.35-020635rc1-generic
OS: Ubuntu 10.04

xorg-video-intel version: 2:2.9.1-3ubuntu5
libgl1-mesa version: 7.7.1-1ubuntu3
xserver-xorg version: 1:7.5+5ubuntu1

/sys/kernel/debug/dri/0/i915_error_state reported no errors (even with debugfs mounted)

Looking through the dmesg, we see the symptom of the hang in that the i915 kernel worker thread and Xorg are both blocked trying to acquire a mutex. This implies that a third unknown process is currently waiting on the GPU. As the hangcheck has not fired, it implies that the GPU is idle. So is this a case of missing interrupts? In which case the recent gen3 page-flipping patches from Jesse Barnes may be of use.

Created an attachment (id=36463)
Don't queue during flip pending

Created an attachment (id=36464)
i945 page-flipping fixes.

I think this is a i945 page-flipping bug which should have been fixed with 2010Q2 and this pair of patches from 2.6.35-rc5:

commit 1afe3e9d4335bf3bc5615e37243dc8fef65dac8f
Author: Jesse Barnes <email address hidden>
Date: Fri Mar 26 10:35:20 2010 -0700

    drm/i915: gen3 page flipping fixes

    Gen3 chips have slightly different flip commands, and also contain a bit
    that indicates whether a "flip pending" interrupt means the flip has
    been queued or has been completed.

    So implement support for the gen3 flip command, and make sure we use the
    flip pending interrupt correctly depending on the value of ECOSKPD bit
    0.

    Signed-off-by: Jesse Barnes <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

commit 83f7fd055eb3f1e843803cd906179d309553967b
Author: Jesse Barnes <email address hidden>
Date: Mon Apr 5 14:03:51 2010 -0700

    drm/i915: don't queue flips during a flip pending event

    Hardware will set the flip pending ISR bit as soon as it receives the
    flip instruction, and (supposedly) clear it once the flip completes
    (e.g. at the next vblank). If we try to send down a flip instruction
    while the ISR bit is set, the hardware can become very confused, and we
    may never receive the corresponding flip pending interrupt, effectively
    hanging the chip.

    Signed-off-by: Jesse Barnes <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

On kernel 2.6.35-14.19 (Ubuntu Maverick Alpha 3) the freeze still happening. The bug is not fixed yet.

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
status: In Progress → Confirmed
summary: - [i945] [i945] (UXA) Intel Corporation 82945G/GZ Integrated Graphics
- Controller [8086:2772] (rev 02) freezes
+ [i945] Intel Corporation 82945G/GZ Integrated Graphics Controller
+ [8086:2772] (rev 02) freezes
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical

this should be fixed in natty, could you try and confirm?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

As per last comment, this is believed fixed.

summary: - [i945] Intel Corporation 82945G/GZ Integrated Graphics Controller
- [8086:2772] (rev 02) freezes
+ [i945] Xorg freezes
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
Nick Zotov (noob) wrote :

As a newcomer to Ubnuntu, and using 11.04, I am unclear about why this bug is thought to be fixed. I am running a 945GME chipset. The usr/lib/dri folder does not have i945, nor does dri_alternates. By default, Ubuntu loaded i915. With that I am getting complete freezes form time to time with no discernible pattern.

If this bug has been fixed, I suggest that it should be available for download in the Additional Drives.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.