[i945] [Hardy] X crash when HorizEdgeDelta is set to "10" (i945)

Bug #199223 reported by Cleber Santz
4
Affects Status Importance Assigned to Milestone
xf86-video-intel
New
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

After lasted upgrade 2 days ago the X show black screen every time i try find more information but can`t find nothing

I get the "Black Screen" when change application, start java application, play sound or video, etc. There no apparent cause.

I think this is the same problem of bug https://bugs.launchpad.net/ubuntu/+source/icedtea-java7/+bug/199198

VGA: VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
uname: Linux clbr 2.6.24-11-generic #1 SMP Fri Feb 29 22:08:31 UTC 2008 i686 GNU/Linux
Machine: Note HP Pavilion DV 6130

Revision history for this message
Cleber Santz (clebersantz) wrote :
Revision history for this message
Cleber Santz (clebersantz) wrote :
Revision history for this message
naught101 (naught101) wrote :

I'd suggest submitting the output of dmesg too :)

Revision history for this message
Cleber Santz (clebersantz) wrote :

Ok, here is...

Revision history for this message
unggnu (unggnu) wrote : Re: [Hardy] X crash every time after update (i945)

Does it still happen if you disable desktop effects?

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Revision history for this message
Cleber Santz (clebersantz) wrote :

No, without compiz X dont crash anymore

Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel:
status: Incomplete → Triaged
Revision history for this message
xRaich[o]²x (raichoo) wrote :

I have the same problem under KDE4 (desktop effects are enabled, but no compiz i use the KDE4 effects) but i have less crashes. X only crashes when i play a video (using dragonplayer) for the first time after booting. After such a crash the shutdown bootsplash is corrupted.
I doesn't happen all the time, I'm not able to reproduce the bug completely by now.

lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Revision history for this message
unggnu (unggnu) wrote :

I guess it is the best to get a backtrace https://wiki.ubuntu.com/DebuggingXorg of the crash.

Changed in xserver-xorg-video-intel:
status: Triaged → Incomplete
Revision history for this message
eternicode (knexor2) wrote :

lsmod shows that I'm using the i915 module.

The only time X crashes is when I use KDE4 + Compiz, but then only when "Option HorizEdgeDelta" is set to 10 and "Option HorizEdgeScroll" is commented out in the "Synaptics Touchpad" section of my xorg.conf. Commenting HorizEdgeDelta and setting HorizEdgeScroll to 0 works fine.

What happens is I log into my account, all my startup apps load, then compiz loads and X immediately restarts, sending me back to the login screen.

I've attached my xorg.conf, Xorg.0.log and dmesg output will be in subsequent posts.

Revision history for this message
eternicode (knexor2) wrote :
Revision history for this message
eternicode (knexor2) wrote :
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Revision history for this message
Bryce Harrington (bryce) wrote :

Are you able to reproduce this issue on Jaunty? If so, please collect a full backtrace - see http://wiki.ubuntu.com/X/Backtracing for directions.

Changed in xserver-xorg-video-intel:
importance: Unknown → Undecided
status: Fix Released → New
status: Incomplete → New
status: New → Incomplete
Revision history for this message
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.