Dragging with touchpad unusable

Reported by Stuart Bishop on 2011-09-26
178
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Xserver Xorg Input Synaptics
Fix Released
Medium
xserver-xorg-input-synaptics (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Dragging with my touchpad has become much more difficult under Oneiric. It works, but it seems much stricter and rarely is my double-tap and drag good enough to initiate the drag. It seems now that I need to start the drag immediately after the touble tap. Wait too long and it fails. Start the drag too soon and it fails (the drag is absorbed into the double tap?).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.16.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,place,compiztoolbox,session,move,resize,gnomecompat,regex,animation,mousepoll,snap,grid,vpswitch,imgpng,workarounds,resizeinfo,wall,expo,unitymtgrabhandles,fade,ezoom,scale,unityshell]
Date: Mon Sep 26 14:12:28 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANGUAGE=en_AU:en_GB:en
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-25 (0 days ago)

Stuart Bishop (stub) wrote :
Changed in unity (Ubuntu):
status: New → Invalid
Stuart Bishop (stub) wrote :

Its become a triple tap.

Stuart Bishop (stub) wrote :

Nope, triple tap works for some things but always maximizes a window when I want to drag the window.

Changed in unity (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

the window to drag after the second tap is very small, it works but you have to be super fast.

Stefan Dringenberg (std) wrote :

Same here: With a very fast second tap I'm able to use the dragging.

From dmesg:
input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input7

From Xorg.0.log:
[ 22.786] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event7)
[ 22.786] (**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"
[ 22.786] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[ 22.786] (II) LoadModule: "synaptics"
[ 22.786] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 22.808] (II) Module synaptics: vendor="X.Org Foundation"
[ 22.808] compiled for 1.10.2, module version = 1.4.1
[ 22.808] Module class: X.Org XInput Driver
[ 22.808] ABI class: X.Org XInput driver, version 12.3
[ 22.808] (II) Using input driver 'synaptics' for 'ETPS/2 Elantech Touchpad'
[ 22.808] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 22.808] (**) ETPS/2 Elantech Touchpad: always reports core events
[ 22.808] (**) Option "Device" "/dev/input/event7"
[ 22.844] (--) ETPS/2 Elantech Touchpad: x-axis range 8 - 1144
[ 22.844] (--) ETPS/2 Elantech Touchpad: y-axis range 8 - 760
[ 22.844] (II) ETPS/2 Elantech Touchpad: device does not report pressure, will use touch data.
[ 22.844] (--) ETPS/2 Elantech Touchpad: buttons: left right double triple
[ 22.844] (--) ETPS/2 Elantech Touchpad: invalid pressure range. defaulting to 0 - 256
[ 22.844] (--) ETPS/2 Elantech Touchpad: invalid finger width range. defaulting to 0 - 16
[ 22.872] (--) ETPS/2 Elantech Touchpad: touchpad found
[ 22.872] (**) ETPS/2 Elantech Touchpad: always reports core events
[ 22.896] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input7/event7"
[ 22.896] (II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD)
[ 22.896] (**) ETPS/2 Elantech Touchpad: (accel) MinSpeed is now constant deceleration 2.5
[ 22.896] (**) ETPS/2 Elantech Touchpad: MaxSpeed is now 1.75
[ 22.896] (**) ETPS/2 Elantech Touchpad: AccelFactor is now 0.147
[ 22.897] (**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[ 22.897] (**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 1
[ 22.897] (**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[ 22.897] (**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[ 22.899] (--) ETPS/2 Elantech Touchpad: touchpad found
[ 22.900] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)

Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Confirmed
José Cabo (folcwine) wrote :

I have the same problem.

For reproduce it:
1 - You need a touchpad.
2 - Click and then make another click but don't up your finger for start to move.
3 - If you don't move instantly your drag will fail.

José Cabo (folcwine) wrote :

(Sorry)
The natural double click & drag is after you make double click you cant want all you want for to start to move (drag) meanwhile, for course, you don't up your finger from the touchpad at the end of the second click.

marcb_ro (marcb-ro) wrote :

I also ran into the same problem. I have a laptop and since the upgrade from 11.04 to 11.10 I find it very difficult to move windows around my desktop.

Not sure if it is a bug, though, due to the fact that it works as described in post #8, i.e. do not lift finger after second tap, but rather immediately start dragging the object that you wish to move. However, double tap dragging, in this case, would not be an appropriate name anymore, due to the fact that the second tap is technically no longer a tap.

sokai (sokai) wrote :

Since Oneiric I have this problem, too. - I need the "double tap and drag" because my left touchpad button is a little bit defect. (Also I find it very handy only using the touchpad for dragging things or marking text and text lines without the buttons...) I can't double-tap and drag anymore since my upgrade to Oneiric.

The explanation in post #8 I don't understand, sry! If I double-tap (very fast or slower) nothing happens if I move my cursor after the double-tap. If I double-tab on a word in an application (i.e. in Opera or Terminal, ...) the word becomes highlighted.

Here are my synclient options:
$> synclient -l | awk '/=/{printf "Option \"%s\" \"%s\"\n",$1,$3}'
Option "LeftEdge" "53"
Option "RightEdge" "1099"
Option "TopEdge" "48"
Option "BottomEdge" "720"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "FingerPress" "256"
Option "MaxTapTime" "180"
Option "MaxTapMove" "59"
Option "MaxDoubleTapTime" "180"
Option "SingleTapTimeout" "180"
Option "ClickTime" "100"
Option "FastTaps" "0"
Option "EmulateMidButtonTime" "75"
Option "EmulateTwoFingerMinZ" "282"
Option "EmulateTwoFingerMinW" "7"
Option "VertScrollDelta" "27"
Option "HorizScrollDelta" "27"
Option "VertEdgeScroll" "0"
Option "HorizEdgeScroll" "0"
Option "CornerCoasting" "0"
Option "VertTwoFingerScroll" "1"
Option "HorizTwoFingerScroll" "0"
Option "MinSpeed" "1"
Option "MaxSpeed" "1.75"
Option "AccelFactor" "0.146843"
Option "TrackstickSpeed" "40"
Option "EdgeMotionMinZ" "30"
Option "EdgeMotionMaxZ" "160"
Option "EdgeMotionMinSpeed" "1"
Option "EdgeMotionMaxSpeed" "108"
Option "EdgeMotionUseAlways" "0"
Option "TouchpadOff" "0"
Option "LockedDrags" "0"
Option "LockedDragTimeout" "5000"
Option "RTCornerButton" "2"
Option "RBCornerButton" "3"
Option "LTCornerButton" "0"
Option "LBCornerButton" "0"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
Option "ClickFinger1" "1"
Option "ClickFinger2" "1"
Option "ClickFinger3" "1"
Option "CircularScrolling" "0"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "0"
Option "CircularPad" "0"
Option "PalmDetect" "0"
Option "PalmMinWidth" "10"
Option "PalmMinZ" "200"
Option "CoastingSpeed" "20"
Option "CoastingFriction" "50"
Option "PressureMotionMinZ" "30"
Option "PressureMotionMaxZ" "160"
Option "PressureMotionMinFactor" "1"
Option "PressureMotionMaxFactor" "1"
Option "ResolutionDetect" "1"
Option "GrabEventDevice" "1"
Option "TapAndDragGesture" "0"
Option "AreaLeftEdge" "0"
Option "AreaRightEdge" "0"
Option "AreaTopEdge" "0"
Option "AreaBottomEdge" "0"

I also changed the option "TapAndDragGesture" to "1" but that made no changes for the missing "double tap and drag" behaviour.

Please fix it or give me/us a hint how we can establish the wanted behaviour.

Thanks & best regards!

Andrea Azzarone (andyrock) wrote :

Are you sure that this is a Unity bug? Can you check that this bug doesn't affect unity 2d and/or gnome shell please?
Marking as incomplete in the while....

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
sokai (sokai) wrote :

@Andy
Thanks for your reply! - I don't know if it's a "Unity bug" but I found this bug after digging a lot of time in the internet.

I can understand that the "Unity developer" don't care about bugs of other projects because they have to do a lot for Unity... - But please try to find the correct software this existing bug should be assigned, too!

I think it's not a good idea to close a bug that affects 10 people and has 10 responses only because it's assigned to the 'wrong' project. *ithinkuknowwhatimean*

Thanks!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

sokai (sokai) on 2011-10-16
affects: xserver-xorg-input-synaptics → xserver-xorg-input-synaptics (Ubuntu)
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Andrea Azzarone (andyrock) wrote :

«I think it's not a good idea to close a bug that affects 10 people and has 10 responses only because it's assigned to the 'wrong' project. *ithinkuknowwhatimean*»

Assigning it to the "wrong" project isn't a good idea too... ;) Feel free to assign it to the right project...

Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
Yuan Tao (a-purple-yuan) wrote :

Please reconsider invalidating this bug. I was able to confirm that it is a Unity issue by switching over to the gnome-shell and attempting to double-tap-and-drag. It worked perfectly well.

Andrea Azzarone (andyrock) wrote :

I mark as invalid as it is similar to bug #874675. As you can read, they told me that this is not only a unity bug so i marked it as invalid.

Andrea Azzarone (andyrock) wrote :

*I marked as invalid because....

Changed in unity:
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Confirmed
Juan Matias Granda (insulae) wrote :

I have the same problem, and i think "is not a unity problem", I tried doing " openbox --replace " to switch form unity to openbox and I have the same problem in openbox, I can't move a window using the touchpad.
My machine is a UL80VT (same as UL30VT but 14") the machine have Elantech touchpad.

sokai (sokai) wrote :

Again: I don't know which project to assign to.

But: I got a solution from https://bugs.launchpad.net/bugs/874675 .

If I do

/usr/bin/synclient TapButton1=1 TapButton2=2 TapButton3=3 VertTwoFingerScroll=1 TapAndDragGesture=1 SingleTapTimeout=320 FastTaps=1

as a background script on my ASUS EeePC 1000 with a "ETPS/2 Elantech Touchpad" I get the "double tap & drag" behaviour back.

Thanks a lot!

Yuan Tao (a-purple-yuan) wrote :

I'll confirm that changing to FastTaps=1 and SingleTapTimeout=320 solves this problem. Thanks all.

Stefan Dringenberg (std) wrote :

After reading Kai's posting I solved the problem permanently by adding the following lines to /usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "SHMConfig" "on"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "VertTwoFingerScroll" "1"
        Option "TapAndDragGesture" "1"
        Option "SingleTapTimeout" "320"
        Option "FastTaps" "1"
EndSection

Stuart Bishop (stub) wrote :

Although it sounds similar, I'm not going to mark this bug as a duplicate of Bug #774113 because this issue is with an Elantech touchpad and triggered by the Ubuntu 11.10 upgrade.

sokai (sokai) wrote :

To sum up my experiences to get "double tap and drag" working with my "ETPS/2 Elantech Touchpad" on Oneiric:

1. I have the following settings with GNOME system settings for my touchpad:
* "Disable touchpad while typing" = checked
* "Enable mouse clicks with touchpad" = checked
* Scrolling -> "Two-finger scrolling" = checked

2. After 1. I have to set the following options with "synclient" (in a terminal):
TapAndDragGesture=1
SingleTapTimeout=320

That's it!

3. If you wanna have a "middle click" by tap with two fingers and a "right click" by tap with three fingers you have to change the following options with synclient:
TapButton1=1
TapButton2=2
TapButton3=3

Best regards!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
sokai (sokai) wrote :

*damn*
After changing the settings like I wrote in #24 (I was sure that works!) I now noticed the following misbehavior with Pidgin.
If I click on the select box for changing my status in the "buddy list" the statuses swing out but immediately swing in again. So I can't select a status only using my touchpad because the status list doesn't stay open until I selected a status... :(

Sry for that - someone has a hint, maybe?
I have tried the option "FastTaps" set to "1". That changed the behaviour a little bit. - The status list doesn't swings in as fast as with "FastTaps=0". But also I'm not able to select a status.

Thanks & best regards!

.oO(Who of the Ubuntu team changed the default settings from Natty to Oneiric and why...!? *bump*)

Gareth Witty (garethwitty) wrote :

I have tried reverting to Gnome Shell and still have the problem, however I did try some other linux os and these worked fine. It seem to only effect Unity 3D and 2D as far as I can tell.

Also I did try XFCE 4.8 on my 11.10 system and this worked fine. I have also tried some settings but alas still not working as well as it used to.

I am sure it will be resolved very soon and I can work around it by using the left touch pad button and then move window as normal.

Andrea Azzarone (andyrock) wrote :

@Gareth Witty
You said: «It seem to only effect Unity 3d and 2d as far as i can tell...», but you also said: «I have tried reverting to Gnome Shell and still have the problem...»

Gareth Witty (garethwitty) wrote :

Sorry thats my bad typing and brain going in different dirctions lolz, Gnome Shell still had the same problem with the double tap and drag, as well as the Unity in 2D and 3D modes.

Other desktops seem to be fine such as XFCE, LXDE and even KDE.

I think I have downloaded so much today my system must be a right mess! I will reinstall the 11.10 from scratch later today and install all updates to see if this helps.

Lans (thelans) wrote :

I have the same problem on my eeepc.

Works well on my Dell Precision.

I'm also effected by this and it is not restricted to unity or gnome. I am having the same problem in xfce.

As has been explained by Alti El at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/874675 , the action to drag seems to have gone from (Tap)+(Press) to (Tap)+(Press and Drag)

The frustration is then initiating the drag on the second touch before the timeout. Increasing the timeout certainly makes it more possible, but there are many times when I would previously pause, whilst pressing my finger, before I'd initiate dragging. I now have to arbitrarily move to initiate the drag before the timeout before I can pause to work carefully.

There's no reason the action should require the drag to be initiated before a timeout. A double click can be represented by a double tap, so as long as the finger is removed on the second tap before a timeout it will register as a double click, and if the finger isn't removed before the timeout it registers as a drag.

AnSc (spam2-anschitech) wrote :

Worked for me, Thanks.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
jamboi (ninjacyclist) wrote :

After using the solution proposed by Stefan, I now have working dragging in xfce, but I have to triple tap instead of double tap to open anything.

jamboi (ninjacyclist) wrote :

Removing the following line returns me to normal double clicking:

Option "FastTaps" "1"

Dirk Mcbratney (djmcbratney) wrote :

For me, under Gnome Shell with an Elantech trackpad, doubling SingleTapTimeout fixed the issue, and the setting persists over suspend and resume (many Synclient settings don't.) Trackpad is completely usable again (aside from the unrelated bug regarding three-finger taps for Elantech on the 3.0 kernel.) 320 should be the default setting for this value.

Xiao-Long Chen (cxl) wrote :

It looks like those are the default settings for the synaptics Xorg driver (xf86-input-synaptics upstream or xserver-xorg-input-synaptics in Ubuntu). In the latest version of xf86-input-synaptics (1.50), src/synaptics.c contains the following lines:

pars->tap_time = xf86SetIntOption(opts, "MaxTapTime", 180);

and

pars->fast_taps = xf86SetBoolOption(opts, "FastTaps", FALSE);

which as said before, seem to be the culprit of this problem. A simple patch to change those values in the source code would fix this problem.

Is there a reason why these settings are not the default settings? if not, i guess it should be fixed with a patch

On behalf of Stuart Bishop:
Dragging with my touchpad has become much more difficult under Oneiric. It works, but it seems much stricter and rarely is my double-tap and drag good enough to initiate the drag. It seems now that I need to start the drag immediately after the touble tap. Wait too long and it fails. Start the drag too soon and it fails (the drag is absorbed into the double tap?).

Ahmed Shams (ashams) wrote :

Thank you for reporting this bug. I've just filled it upstream, hope they'll fix it soon.

Thanks.

no longer affects: unity (Ubuntu)
Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → Low

also happening on 12.04

tags: added: precise
Omer Akram (om26er) on 2011-12-05
no longer affects: unity

Although the solutions proposed to somewhat fix the problem, they don't do so very effectively. With just the SingleTapTimeout set to 360 click and drag is improved (although not fixed) however single taps get a noticeable delay (which is bearable). Enabling FastTaps seems to fix this for some people, however it makes double clicking quite difficult.

It does seem that the issue isn't so much the default configuration, but the gesture required to initiate the tap and drag. As I said previously, and even with the SingleTapTimeout set to 360, I still need to start dragging before that timeout is up otherwise it won't work. The gesture should be (Tap)+(Press), no dragging should be required to initiate the drag, as when you are trying to do sensitive dragging, arbitrarily dragging before the timeout to initiate the gesture is not an option. A (Tap)+(Press) gesture shouldn't be ambiguous, as a double click is a (Tap)+(Tap).

I have come across another situation in which the proposed solutions do not work. There are more than just dragging action that require the left mouse button to be held down. There's also the up and down arrows on scroll bars, or numerical input widgets with up and down arrows. To simulate holding down the left mouse button you are supposed to (Tap) + (Press and Hold). When holding the button down on the mouse to keep a button on screen pressed by the cursor, you are obviously not supposed to drag the mouse around. By extension, dragging itself shouldn't be initiated by dragging the finger, the drag should be initiated by the simulated holding down of the left mouse button, which should be the (Tap) + (Press and Hold)

(Sorry if my previous use of (Tap) + (Press) had been ambiguous on the (Press) also implying holding the finger on the touch pad until the action is complete)

As I've said on the Launchpad bug report:

There are more actions than just the dragging action that require the left mouse button to be held down. There's also the up and down arrows on scroll bars, or numerical input widgets with up and down arrows. To simulate holding down the left mouse button you are supposed to (Tap) + (Press and Hold). When holding the button down on the mouse to keep a button on screen pressed by the cursor, you are obviously not supposed to drag the mouse around. By extension, dragging itself shouldn't be initiated by dragging the finger, the drag should be initiated by the simulated holding down of the left mouse button, which should be the (Tap) + (Press and Hold)

Changed in xserver-xorg-input-synaptics:
importance: Unknown → Medium
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

There have been many changes to -synaptics this cycle, since the last comment. Is anyone on this bug still seeing this misbehavior?

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Confirmed → Incomplete
Simon P. (simpre) wrote :

11.10: still same old problem
12.04 Beta 2: touchpad working fine

Bryce Harrington (bryce) on 2012-04-06
Changed in xserver-xorg-input-synaptics (Ubuntu Precise):
status: Incomplete → Fix Released
Changed in xserver-xorg-input-synaptics (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Low
Stuart Bishop (stub) wrote :

Original reporter here, and yes, things now seem fine in 12.04 beta with no need for manual tweaking.

whoah, that one flew under the radar. sorry for the silence. it's been two years, I'm gonna close this now as fixed (latest master has a bunch of fixes here), please open a new bug if this persists.

Changed in xserver-xorg-input-synaptics:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.