Freeze after login with KMS enabled on Radeon HD6310

Bug #715330 reported by mrmagos on 2011-02-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Medium
linux (Ubuntu)
High
Andy Whitcroft
xserver-xorg-video-ati (Ubuntu)
High
Robert Hooker

Bug Description

Binary package hint: xserver-xorg-video-ati

I'm using Natty on an HP dm1z-3000 series, which has an AMD Radeon HD 6310 on-board graphics. The system boots as expected, but once I log in the system becomes completely unresponsive. This seems due to hardware acceleration, because if I choose either 'safe mode' option, I get a useable desktop without hardware acceleration. The same is true if I disable KMS with radeon.modeset=0 at boot time; I get a useable desktop, albeit without hardware acceleration.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
Uname: Linux 2.6.38-2-generic x86_64
Architecture: amd64
Date: Tue Feb 8 13:25:55 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GdmLog2:

GraphicsCard: Subsystem: Hewlett-Packard Company Device [103c:1611]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110207)
MachineType: Hewlett-Packard HP Pavilion dm1 Notebook PC
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 LC_MESSAGES=en_CA.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic root=UUID=b2e83bd6-b452-41d7-987b-20c8a49898e5 ro quiet splash vt.handoff=7 radeon.modeset=0
SourcePackage: xserver-xorg-video-ati
dmi.bios.date: 12/20/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.03
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1611
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 96.19
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.03:bd12/20/2010:svnHewlett-Packard:pnHPPaviliondm1NotebookPC:pvr0589100000252B00000320100:rvnHewlett-Packard:rn1611:rvr96.19:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion dm1 Notebook PC
dmi.product.version: 0589100000252B00000320100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu9
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

mrmagos (mrmagos) wrote :
Bryce Harrington (bryce) wrote :

Reproduce the issue, log in, and with the system frozen collect the output of dmesg, your /var/log/Xorg.0.log, and your /var/log/kern.log.

Also, avivotool can be used to assist in debugging this issue. avivotool is provided with the radeontool package, so to install it run:

    sudo apt-get install radeontool

After installing it, you run it like this:

    avivotool regs all > regdump_good.txt
    avivotool regs all > regdump_broke.txt

Run it two times. Once when you have a working screen, and once in the broken case (either from the tty console or logged into the sick box remotely). Attach both of those to this bug report.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
mrmagos (mrmagos) wrote :
mrmagos (mrmagos) wrote :
mrmagos (mrmagos) wrote :
mrmagos (mrmagos) wrote :
mrmagos (mrmagos) wrote :

I'm not able to produce a regdump in the broken environment; avivotool segfaults when I try.

Bryce Harrington (bryce) on 2011-02-18
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Hi, just now we've uploaded the new -ati 6.14.0 as well as a switch of defaults from the r600 to the r600g driver. The r600g is a reimplementation of the driver using the Gallium framework, which particularly affects 3D behavior. I don't know whether this is a fix for your bug, but it would be worth retesting at this point. Especially for your bug, r600g could make a huge difference. It will probably take some hours before the packages are built and distributed to mirrors, so could you plan tomorrow (Feb 19th) to update to latest Natty and retest your bug?

If it does still occur, please upload your /var/log/Xorg.0.log from reproducing the issue, since this will now have the r600g debug log messages in it. Thanks ahead of time.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
bugbot (bugbot) on 2011-02-20
tags: added: freeze
mrmagos (mrmagos) wrote :

It does not fix the issue. In fact, it's worse; I now have static with KMS enabled. I'll attach the Xorg.0.log (and dmesg) shortly, but looking it over it appears that it's still loading the r600 driver. I can try it with the ForceGallium option and see what happens.

mrmagos (mrmagos) wrote :
mrmagos (mrmagos) wrote :
mrmagos (mrmagos) wrote :

The ForceGallium option wasn't used, and I'm seeing the same behavior as described above. I suppose this is probably expected since galluim is enabled by default, correct?

Actually @mrmagos, the static came in with the kernel upgrade, not the 6.14.0 driver. If you boot with the 2.6.38-3 kernel, you won't get static.

But this bug isn't fixed by the driver upgrade.

Sorry, I'm not helpful enough to attach any files.

Bryce Harrington (bryce) on 2011-03-02
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → High
status: Incomplete → Confirmed
Jorge Castro (jorge) wrote :

I get this on a new Thinkpad X120e, which has the same chipset as the original reporter.

I'm not sure how this driver relates to the kernel, however I can confirm that I get this crash both using the 2.6.38-5 kernel in Natty and the vanilla mainline 2.6.38 (dated #201103060905) from the mainline PPA.

In my case the system is completely unresponsive, I can't get any kind of apport thing to popup and there's nothing there when I reboot.

Jorge Castro (jorge) wrote :

As it turns out the graphics are totally frozen but I can ssh to it! Here's the information from the logs:

Jorge Castro (jorge) wrote :
Jorge Castro (jorge) wrote :

From the upstream bug I was able to glean a workaround: My /etc/X11/xorg.conf looks like this:

Section "Device"
        Identifier "Default Device"
        Driver "radeon"
        Option "EnablePageFlip" "False"
EndSection

and it loaded Unity right up on login. adam/mrmagos, can you guys try this on your laptops and confirm? Thanks!

Download full text (3.8 KiB)

Indeed it launches! I'm in Unity right now.

On Mon, Mar 7, 2011 at 5:39 PM, Jorge O. Castro <email address hidden> wrote:
> >From the upstream bug I was able to glean a workaround: My
> /etc/X11/xorg.conf looks like this:
>
> Section "Device"
>        Identifier      "Default Device"
>        Driver  "radeon"
>        Option  "EnablePageFlip"        "False"
> EndSection
>
> and it loaded Unity right up on login. adam/mrmagos, can you guys try
> this on your laptops and confirm? Thanks!
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/715330
>
> Title:
>  Freeze after login with KMS enabled on Radeon HD6310
>
> Status in X.org XServer - ATI gfx chipset driver:
>  Unknown
> Status in “linux” package in Ubuntu:
>  New
> Status in “xserver-xorg-video-ati” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Binary package hint: xserver-xorg-video-ati
>
>  I'm using Natty on an HP dm1z-3000 series, which has an AMD Radeon HD
>  6310 on-board graphics. The system boots as expected, but once I log
>  in the system becomes completely unresponsive. This seems due to
>  hardware acceleration, because if I choose either 'safe mode' option,
>  I get a useable desktop without hardware acceleration. The same is
>  true if I disable KMS with radeon.modeset=0 at boot time; I get a
>  useable desktop, albeit without hardware acceleration.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
>  ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
>  Uname: Linux 2.6.38-2-generic x86_64
>  Architecture: amd64
>  Date: Tue Feb  8 13:25:55 2011
>  DistUpgraded: Fresh install
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  GdmLog2:
>
>  GraphicsCard:   Subsystem: Hewlett-Packard Company Device [103c:1611]
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110207)
>  MachineType: Hewlett-Packard HP Pavilion dm1 Notebook PC
>  ProcEnviron:
>   LANGUAGE=en_CA:en
>   LANG=en_CA.UTF-8
>   LC_MESSAGES=en_CA.utf8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic root=UUID=b2e83bd6-b452-41d7-987b-20c8a49898e5 ro quiet splash vt.handoff=7 radeon.modeset=0
>  SourcePackage: xserver-xorg-video-ati
>  dmi.bios.date: 12/20/2010
>  dmi.bios.vendor: Hewlett-Packard
>  dmi.bios.version: F.03
>  dmi.board.asset.tag: Base Board Asset Tag
>  dmi.board.name: 1611
>  dmi.board.vendor: Hewlett-Packard
>  dmi.board.version: 96.19
>  dmi.chassis.asset.tag: Chassis Asset Tag
>  dmi.chassis.type: 10
>  dmi.chassis.vendor: Hewlett-Packard
>  dmi.chassis.version: Chassis Version
>  dmi.modalias: dmi:bvnHewlett-Packard:bvrF.03:bd12/20/2010:svnHewlett-Packard:pnHPPaviliondm1NotebookPC:pvr0589100000252B00000320100:rvnHewlett-Packard:rn1611:rvr96.19:cvnHewlett-Packard:ct10:cvrChassisVersion:
>  dmi.product.name: HP Pavilion dm1 Notebook PC
>  dmi.product.version: 0589100000252B00000320100
>  dmi.sys.vendor: Hewlett-Packard
>  version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu9
>  version.libdrm2: libdrm2 2.4.23-1ubuntu3
>  version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
> ...

Read more...

Changed in xserver-xorg-driver-ati:
importance: Unknown → Medium
status: Unknown → Confirmed
mrmagos (mrmagos) wrote :

The workaround works for me as well. Thanks.

Robert Hooker (sarvatt) on 2011-03-08
tags: added: hwe-blocker
Robert Hooker (sarvatt) on 2011-03-09
Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
Bryce Harrington (bryce) wrote :

<Sarvatt> real fix for jcastro's pageflip problem - http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commit;h=fdc315a19a2c33da29dd87d4ca88f4e4407bd42d

Looks like this patch needs cherrypicked to the Ubuntu kernel or verification it's in a newer rc.

Changed in linux (Ubuntu):
assignee: nobody → Jeremy Foshee (jeremyfoshee)
importance: Undecided → High
status: New → Triaged
Robert Hooker (sarvatt) wrote :

Closing the x-x-v-ati task since the userspace workaround won't need to be applied once the kernel side is fixed.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Invalid
Bryce Harrington (bryce) on 2011-03-11
Changed in xserver-xorg-video-ati (Ubuntu):
status: Invalid → In Progress
status: In Progress → Invalid
mrmagos (mrmagos) wrote :

I can confirm the patch for the kernel module works. I no longer need the userspace workaround, and it has also fixed some stability issues that I had run across while running games (Minecraft addict) and other tasks that tax the video.

Andy Whitcroft (apw) on 2011-03-14
Changed in linux (Ubuntu):
assignee: Jeremy Foshee (jeremyfoshee) → Andy Whitcroft (apw)
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

This fix has now hit upstream, and will be in the next kernel upload.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-7.35

---------------
linux (2.6.38-7.35) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to 2fbfac4e053861925fa3fffcdc327649b09af54c
  * rebase fixes bug #715330
  * [Config] disable CONFIG_SCSI_QLA_ISCSI for powerpc 32bit to fix FTBS
  * rebase to v2.6.38 final

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: Apply OPTION_BLACKLIST_SENDSETUP also for ZTE MF626
    - LP: #636091

  [ Tim Gardner ]

  * [Confg] CONFIG_BOOT_PRINTK_DELAY=y

  [ Upstream Kernel Changes ]

  * Yama: use thread group leader when creating match
    - LP: #729839
  * (drop after 2.6.38) ahci: AHCI mode SATA patch for Intel Patsburg SATA
    RAID controller
    - LP: #735240
  * (drop after v2.6.38) x86, quirk: Fix SB600 revision check

  [ Major Kernel Changes ]

  * rebase from v2.6.38-rc8 to v2.6.38 final
    - LP: #715330
 -- Andy Whitcroft <email address hidden> Tue, 15 Mar 2011 19:04:19 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.