[rs690m] [Gateway] Graphics corruption with ati x1200

Bug #556782 reported by Brian Visel on 2010-04-06
172
This bug affects 29 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
High
linux (Ubuntu)
Undecided
Unassigned

Bug Description

[Edit]
This bug has been around for a bit over a year now, and has gotten rather long, so this is a brief summary.
There is a memory corruption issue that affects users of the rs690m, to varying degrees.
For many most people, it makes the desktop unusable.

Workaround: *Note: This is a workaround, not a fix. It will give you a usable system.
[Natty]: Regression: This workaround now only provides 2d/software rendering, and one must either:
   * Choose choose the "Ubuntu Classic" session from the GDM Login screen
   or
   * Install the "unity-2d" package.

[code]
sudo su
echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf
exit
[/code]
Note that this doesn't totally fix the issue, but brings your desktop to a workable state.

Freedesktop.org has dealt with one bug having to do with graphics corruption on the rs690m. That bug has been fixed, but the issue of graphics corruption in general has not been resolved. A new bug has been opened with freedesktop.org to continue pushing through the resolution of this issue.
[/edit]

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+3ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
Date: Tue Apr 6 12:58:29 2010
DkmsStatus: Error: [Errno 2] No such file or directory
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Gateway LT31
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-19-generic root=UUID=617a7a50-d35f-4b03-8bf1-f91ec024381b ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 06/18/2009
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: v1.3201
dmi.board.name: SJM11-YK
dmi.board.vendor: Gateway
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Gateway
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrv1.3201:bd06/18/2009:svnGateway:pnLT31:pvrNotApplicable:rvnGateway:rnSJM11-YK:rvrNotApplicable:cvnGateway:ct10:cvrN/A:
dmi.product.name: LT31
dmi.product.version: Not Applicable
dmi.sys.vendor: Gateway
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-19-generic

[lspci]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS690M [Radeon X1200 Series] [1002:791f]
     Subsystem: Acer Incorporated [ALI] Device [1025:028c]

Brian Visel (eode) wrote :
Brian Visel (eode) wrote :

First: I've upgraded from 9.10 to 10.04 beta. My system updates are current.
  I have a radeon rs690m (x1200)

This is the problem I ran into:
  * Small, horizontal white lines that appear a bit like static. Not very noticeable, and not present currently.
  * Medium and large horizontal lines / areas of corruption.
    * Stripes are often screen-wide
    * Stripes can be scrolled, e.g., in Firefox or Nautilus.
    * Refresh of graphical object clears up corruption -- E.g., a mouseover of a link or highlighting an icon
  * Mouse Pointer gets corrupted at some points, until refreshed (e.g., when the cursor changes from pointer to question mark, or to a hand, or from hand to arrow, etc.).
    * Corruption occurs regardless of whether or not Desktop Effects are enabled (important later)
      * Corruption might only occur after desktop effects *have* been enabled during this run.
  * Some fonts become corrupted. If they do, the letters corrupted stay corrupt. I.e., if "k" gets corrupted, and I type "k" elsewhere in the same font, that too will be corrupted.

It would be really nice to fix this before the release of Lucid -- I can't imagine what would happen with all the rs690 users out there. Not that there are a lot, but, there are enough.

Workaround (sort of):
In /etc/modprobe.d/radeon-kms.conf, I set:
 options radeon modeset=0

Why just "sort of"?
  * Logging into the (only) account created when the system was 9.10 fails, at best booting me back to the login screen.
  * Logging into an account created since the system has been upgraded to 10.04 works fine, desktop effects and all, no graphics glitches.
  * Logging into the 9.10-made account with desktop effects disabled works fine.
  * Enabling desktop effects once logged in makes the system visually unusable -- cannot switch to console, graphical screen black except for mouse, but the system is still running. I can ctrl-alt-delete from a 'text' console, although there is no text -- it just shows what was last in the graphics buffer (a black screen with the mouse pointer present).

Note that although there were glitches graphically, desktop effects or not, the system worked with desktop effects enabled when kms was enabled.

I think there are probably two problems here:
1) KMS causing or making visible some kind of horrible memory badness that I don't understand
2) Desktop Effects config in 9.10 can be set to a state that doesn't play nicely in 10.04 with KMS disabled.

Any further information I will be happy to provide. I have a workable system, I can just transfer everything over to a new account on my system, but I want to make sure others aren't affected problematically -- and it would be nice just to use my old account.

-Brian

Note: Included screenshots are *screenshots*, not photos. The actual images in memory are corrupt.

Brian Visel (eode) wrote :
Brian Visel (eode) wrote :
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Brian Visel (eode) wrote :
Brian Visel (eode) wrote :

..please let me know if I can be of further assistance.

Thanks, this looks suitable to be forwarded upstream to bugs.freedesktop.org

summary: - Graphics corruption with ati x1200 (rs690m)
+ [rs690m] Graphics corruption with ati x1200
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → High
status: New → Triaged

If this is of any help, I believe, I am too suffering from this bug on a freshly installed beta-1 of Lucid.
The video card is reported as:
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon X2300.

I noticed the static-like blinking horizontal ~6-12 pixels long artifacts during installation. The static is noticeable even during system bootup, even before the X is started. I cannot capture this static while taking snapshots.

The workaround suggested by the reporter relieves me from the ugly static.

Bryce Harrington (bryce) wrote :

Brian Visel - I've forwarded this bug upstream to http://bugs.freedesktop.org/show_bug.cgi?id=27529 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Psy[H[] (vovik-wfa) wrote :

I have "static", it does not show up on screenshots.
Another interesting thing: "static" is dependent on color. There are absolutely no glitches on clean colors (red, green, blue). Corruption begins on tones closer to gray, and on the perfect gray there is the heaviest "static".
By gray's lightness: there are no glitches on black, they become visible on gray approximately lighter than 60 (of 256).

"static" itself appears white.

zEn (der-eremit) wrote :

Posted a video, to check if its the same Bug i'm getting.

got this since somewhere in between Alpha3 and Beta1 of lucid.
No problems in Karmic at all.

Bryce Harrington (bryce) on 2010-04-11
tags: added: corruption
Psy[H[] (vovik-wfa) wrote :

with last package update amount of "static" increased heavily.

Bryce Harrington (bryce) on 2010-04-13
description: updated
Psy[H[] (vovik-wfa) wrote :

to zEn: yes this is the same thing
same shape, different color

zEn (der-eremit) wrote :

@Psy: thanks for the confirmation.

My corruption is gone since 2 days:
I believe this was when kernel .20 arrived.

btw:
ATI Technologies Inc M52 [Mobility Radeon X1300] on a HP compaq nc6400

Psy[H[] (vovik-wfa) wrote :

installed kernel upgrade 2.6.32-21 (metapackage 2.6.32-22 - is it normal?) nothing changed.

Psy[H[] (vovik-wfa) wrote :

...radeon HD2400 on asus A8Sr

After upgrading kernel to 2.6.32-20 the static is gone.

Bryce Harrington (bryce) wrote :

Brian, two people have reported that with the -20 kernel the static is gone. Is this the case for you as well?

Brian Visel (eode) wrote :

I don't know that the static is the same issue. The thing I'm terming "static" is stuff that looks like analogue static. E.g., stuff that is active around window borders or between significant changes of color. That *particular* issue has gone away, or isn't manifesting.

What I'm terming "Corruption", which is a significantly worse problem, is corruption of the image(s) in memory which aren't fixed until the image is refreshed by the program; e.g., mouseover an icon, etc. I don't think I ever saw the -20 kernel upgrade, but I'm on 2.6.32-21. I just booted without the workaround, and have the same problem still. It's virtually unuseable (currently, my "t" is corrupt, parts of the firefox pane are totally corrupt, corruptions rampant across the screen).

zEn (der-eremit) wrote :

Still don't know if this was the right bug description for me.
The things I had and are visible in the video i posted earlier are still present if i boot in kernel -19 gone with >-20.

so for my bug obiviously was a kernel issue and not radeon!

But this was the closest bug report i could find...

Brian Visel (eode) wrote :

zEn: I think that you had the static issue, not the corruption issue. The static issue isn't bothering me, either.

The Corruption issue is still present, though.

Brian Visel (eode) wrote :

Bryce, should I try to compile the kernel with the patch on fd.o bugzilla 27529? If so, do you offhand know a good link on patching and compiling the kernel? I don't mind searching that myself, but figure if you know one offhand and I need to compile, that will reduce my search time, and therefore give me more time to work on compiling and reporting back the results of the patch.

Bryce Harrington (bryce) wrote :

Hi Brian, I don't have an authoritative link offhand. I think you can basically apt-get the source, apply the patch inline, and do a regular rebuild. I don't typically do kernel builds so am not totally up on the procedure.

Bryce Harrington (bryce) wrote :

Given the upstream bug has a linux patch, it sounds likely this is a kernel drm bug, so am going to turn this bug report over to the kernel team for further tracking.

Once a viable patch comes to light, if the kernel team doesn't pick it up, please ping JFo (jeremyfoshee) to get the issue some SRU attention if appropriate.

affects: xserver-xorg-video-ati (Ubuntu) → linux (Ubuntu)
tags: added: lucd xorg-needs-kernel-fix
removed: lucid
Jack Labus (jacklabus) wrote :

I believe I'm having this exact same bug on a similar machine. LT3108h. I'm not too well adjusted to linux but if you'd like me to run any reports to see if I can help let me know. Screenshot matches similar issues I am getting, the corruption seems more random on my side and gets heavier the longer I leave it alone.

Jack Labus (jacklabus) wrote :

http://ubuntuone.com/p/1uI/

What happens after a while.

madbiologist (me-again) wrote :

According to the changelog, this has been fixed upstream in kernel 2.6.35-rc4:

commit 0888e883ea5ff8fac27e813256d6c1eaede5a234
Author: Alex Deucher
Date: Sat Jun 12 11:50:13 2010 -0400

    drm/radeon/kms: fix bandwidth calculation when sideport is present

    Fixes fdo bug 27529:
    https://bugs.freedesktop.org/show_bug.cgi?id=27529

    Reported-by: steckdenis
    Signed-off-by: Alex Deucher
    Signed-off-by: Dave Airlie

madbiologist (me-again) wrote :

A PPA of the abovementioned kernel can be found at http://kernel.ubuntu.com/~kernel-ppa/mainline/

Ian! D. Allen (idallen) wrote :
Download full text (47.9 KiB)

Ubuntu 10.4 user with a pair of ATI FireMV 2250 cards (RV516 chip)
running Xinerama across three monitors (one monitor output is unused)
using radeon driver on an AMD-64 2.6.32-24-generic.

Over time, single characters in Firefox get mangled - in tab titles and
on the displayed web pages. Typing those characters into text boxes also
shows the mangling. Changing the Firefox font size up or down (CTRL-plus,
CTRL-minus) restores the characters to good at the new size; setting the
font back to the original size (CTRL-zero) returns the mangling again.
Sometimes the characters disappear entirely. Restarting Firefox didn't
help until I added "Option "AccelMethod" "XAA" to my xorg.conf file;
now, restarting Firefox clears the font problem. (It didn't before -
I had to restart the X server.)

Also, while paging through photos in Facebook, twice now (separate
instances of Firefox some time apart) a photo has drawn itself about 200
pixels up and to the left of where it should be in on Facebook web page,
even outside of the browser window. Dragging other windows across the
corrupt area cleared out the ghost photo.

Also, a few times going to a video in YouTube (in Firefox) would
display a non-functional static image of slewed black-on-white, similar to
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/556782/+attachment/1283506/+files/Screenshot-3.png.
(Other people have called this "video static", but it is seems to be a wrongly
displayed image, not white noise.) Restarting Firefox cleared that up.

I didn't have any of these problems when I ran a single FireMV 2250 with
an Nvidia card for the third monitor, but that was on a previous kernel
(2.6.32-23-generic) as well. It's the dual 2250 (on the new kernel)
that is now misbehaving.

Downloading the xorg-edgers radeon driver 6.13.99 didn't help.

From my Xorg.0.log (full log below):

    X.Org X Server 1.7.6
    Release Date: 2010-03-17
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
    Current Operating System: Linux idallen-oak.home.idallen.ca
       2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:21:58 UTC 2010 x86_64
    Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-24-generic
       root=UUID=dc727a13-5170-4697-aad8-849090d05426 ro text
    Build Date: 21 July 2010 01:03:39PM
    xorg-server 2:1.7.6-2ubuntu7.3 (For technical support please see
       http://www.ubuntu.com/support)
    Current version of pixman: 0.16.4
    (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
    (II) Module radeon: vendor="X.Org Foundation"
       compiled for 1.7.6, module version = 6.13.99
       Module class: X.Org Video Driver
       ABI class: X.Org Video Driver, version 6.0

xorg.conf:

The "AccelMethod" "XAA" were added to try to get rid of the font corruption.
It didn't eliminate it, but it might have made it go away with a Firefox
restart, whereas restarting Firefox previously didn't help.

Section "ServerLayout"
 Identifier "Ian"
 Screen "Screen Right" 0 0
 Screen "Screen Middle" LeftOf "Screen Right"
 Screen "Screen Left" LeftOf "Screen Middle"
 Option "Xinerama"
EndSection

Section "Screen"
 Identifier "Sc...

1 comments hidden view all 193 comments
madbiologist (me-again) wrote :

Ian - I'm not sure that you have the same bug, as I don't imagine your ATI FireMV 2250 cards (RV516 chip) have sideport memory, but does this issue still occur with the Ubuntu 10.10 "Maverick Meerkat" beta Live CD available at http://www.ubuntu.com/testing/maverick/beta ?

Ian! D. Allen (idallen) wrote :

madbiologist - alas, I don't have a "non-production" machine on which to try the beta.

The corruption does disappear when I slide the window containing the corruption onto either of the other monitors,
which are on the second FireMV 2250 card. I suppose I should swap cards and see if the corruption swaps, in the
off chance that it might be hardware.

If the bug report doesn't belong grouped here, I wonder where it should go. I didn't see anything obvious other than this bug.

madbiologist (me-again) wrote :

Swapping the cards sounds like a worthwhile test.

You can run the beta from the Live CD if you want. Just download the .iso image and then burn it to a blank CD. When you reboot Ubuntu 10.10 "Maverick Meerkat" beta will offer you the option to try without installing. If you choose that option it will run from the CD in conjunction with a RAMdisk in your system's memory. Your hard disks will not be touched, they will be mounted in read-only mode. When you shut down the CD will be ejected and you will be prompted to remove it and close the CD tray (if it exists) before power-off. The next time you boot your system it will be as you left it before using the Live CD.

Ian! D. Allen (idallen) wrote :

madbiologist - yea, I know all that (Unix user since 1976, sysadmin for
30 years). Two things work against trying it:

- I'd need to bring over my custom xorg.conf file and restart X to enable
  the two cards to work together - I can't just run the CD as is

- the problem is intermittent and may or may not appear for an hour or
  two - I can't commit that time this week

Ian! D. Allen (idallen) wrote :

I said:

> The corruption does disappear when I slide the window containing the
> corruption onto either of the other monitors,

Today, I have some corruption (on the zero glyph in a particular font at
a particular size) that stays corrupt when I slide the Firefox window
from the Right monitor to the Middle monitor (which crosses from the
first FireMV to the second). But this corruption vanishes when I keep
sliding from the Middle to the Left monitor, both of which are on the
same FireMV card. (And the corruption returns when I slide the window
back to Middle or to Right.) I don't think this is a hardware problem
peculiar to one of the cards.

Changed in xserver-xorg-driver-ati:
importance: Unknown → High
status: Unknown → Confirmed
Patrik (tsup) wrote :

Hi! I just upgraded to 10.10 via upgrade-manager -u and then updated the system again. And still, by just visiting http://www.wissenschaftsjournalismus.ch the screen reliably crashes to the look I attached... Well, I can very well steer around this site, which belongs to the swiss association of science journalists... but anyhow...

Simona Diatto (simona-diatto) wrote :

At last I found the bug affecting me!
I first run into the bug while testing Lucid Lynx from the very beginning, then found out some way to bypass it (don't remeber how, it was a real mess). I have just installed Maverick Meerkat RC on my netbook and the problem is here again.

Here's my graphic card and my hardware specs and some screenshots attached
lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]

Changed in xserver-xorg-driver-ati:
importance: High → Unknown
Brian Visel (eode) on 2011-03-10
description: updated
Changed in xserver-xorg-driver-ati:
importance: Unknown → High
status: Confirmed → Fix Released
Changed in linux:
importance: Unknown → Critical
status: Unknown → Confirmed
Brian Visel (eode) on 2011-05-07
description: updated
Bryce Harrington (bryce) on 2011-05-07
tags: added: natty
Brian Visel (eode) on 2011-05-09
description: updated
Bryce Harrington (bryce) on 2011-06-27
tags: removed: xorg-needs-kernel-fix
tags: added: kernel-handoff-graphics
Brian Visel (eode) on 2012-04-27
tags: added: oneiric precise quantal
115 comments hidden view all 193 comments
lotuspsychje (thatwhatis) wrote :

I confirm that adding GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset" to /etc/default/grub
removes the screen corruption and square mouse pointer at pc boot, but compiz is unworkable, wobbly windows
are disabled, unity icon laucher size default as in 2D, screen lags etc...

If anyone know a fix to have compiz enabled without nomodeset please let me know

madbiologist (me-again) wrote :

A good rule of thumb to follow is separate hardware=separate bugs.

The X1200 (mobile/integrated chip) problem seems rather intractable, although some people have had success disabling/reducing the amount of sideport RAM - see comments. #138 and #149.

The X800 problem should be easier to fix, althought the fact that it only happens when the hardware is cold could mean a hardware bug - does that card work OK on Windows? Can you please attach the output of lspci -vvnn for the X800 card?

lotuspsychje (thatwhatis) wrote :

@madbiologist: the card worked well on windows yes, here's the output of lspci:

http://paste.ubuntu.com/1183794/

*** Bug 54704 has been marked as a duplicate of this bug. ***

I will try this patch later but, AFAIK, dma32 is only used on 64 bits systems, isn't it?
I have the same problem (having to disable modeseting) with both 32 and 64 bits kernels (Ubuntu 12.04).

Unfortunately, this patch changed nothing here.
I'm still enable to start unity/gnome-shell and I have some graphic corruptions when using a fallback such as Unity 2D.

This is on a Acer Emachine e625 laptop. I tested the patch on both 32 and 32-pae kernels from Ubuntu 12.04 (3.2.0-31.50).

maybe this is due to irq problems? See bug 37679. Perhaps your boards need similar msi quirks?

@Alex Deucher: it's weird in fact.

I changed the WIFI card of this laptop last week (because of regular disconnections) and now I'm able to start Unity 3D and Gnome-Shell. I don't understand what happened. Note that everything worked fine on Windows with the old WIFI card.

I posted on the other bug regarding enabling MSI.

I put the old WIFI card back in the laptop for testing (nb. everything works on Windows, the card does not seem to be defective)

Without MSI: Compiz starts but the desktop is a fixed image. I see no special error in .xsession-errors.
With MSI: Compiz and Unity 3D start.

With or without MSI, Unity 3D starts when putting the other WIFI card in.

I should add that, with or without MSI, I get regular network disconnections (both WIFI cards, the replacement one used to work well with Linux on its former laptop).

So yes, enabling MSI is a win on this laptop. But I don't quite get why the WIFI card can affect the GPU. There might be some other bug somewhere, but I don't know what it is and where I should report it.

I realize that the last comment was almost a year ago, but apparently this bug is still around. I have it with my Gateway LT31xx laptop, with the same graphics card as the bug title. I was able to find a solution to this problem. It requires a BIOS flash with a modified bios file that enables certain options (North Bridge, IIRC).

The solution was based on this post --> http://ubuntuforums.org/showthread.p...2#post11682072 .

I went to the thread they referenced (http://forum.notebookreview.com/acer...ml#post6368072), and found the modified bios file for my laptop, a Gateway LT31xx. The modified bios file gives you an option to select only 'UMA' rather than 'UMA+Sideport'. I flashed this new bios file, after using the correct phlash.exe command (found in the first post of the notebookreview thread), and when I rebooted, there was the option. I changed that and everything looks great --- no tearing at all. I don't know if I have 3D compositing, but I do have xcompmgr running, so I think compositing works fine.

I think this is the solution that everyone is looking for in regard to the screen tearing problem. If you have a different laptop, I would suggest searching the notebookreview thread to see if a modified bios file was created for your specific model.

Created attachment 84746
possible fix

Does the attached patch help?

Hi Alex,

I'm afraid I don't have access to this laptop anymore, so I can't test your patch.
Hopefully someone from the CC list may be able to help?

Thanks anyway.

I just had time to try this latest patch.
Unfortunately it does not correct the issue.
Is there any way to check or change the beginning and ending addresses of
sideport memory and stolen system memory once the system is up?
If there are registers I can read or write to experiment I will be happy to
try it,but I am afraid I was unable to comprehend a lot of the register
documentation from AMD.

Brian Visel, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily kernel folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11.1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
kuntergunt (kuntergunt) wrote :

I have problems with a clean install of 13.04 x64 and an ATI RS690M graphics card.
Everything is slow, menu shows artifacts and random patterns.
Proprietary drivers do not seem to support this version of ubuntu any more.

HP Compaq 6715b
lspci: VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS690M [Radeon Xpress 1200/1250/1270]

kuntergunt, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

summary: - [rs690m] Graphics corruption with ati x1200
+ [rs690m] [Gateway] Graphics corruption with ati x1200

35998 is exactly same bug.

*** Bug 35998 has been marked as a duplicate of this bug. ***

Dear Developers!!

Please tell us what are the chances that this bug can be fixed? Do you want paypal tips? Is this bug really not worth the time that selling the machines is a better way to go?

If you respond that its probably unfixable, please mark the radeon feature page correspondingly, that this Card (1250) is NOT supported, because this bug really makes the machine unusable.

Also affected notebooks: Samsung R20

Kind regards

I have installed 2 GiB of SODIMM DDR2 today, replacing the old 1 GiB module.
At OpenSuse Tumbleweed (13.1; knel 3.11/Mesa 9.2) at login screen AFTER Xorg has started I have hexagon (8x8) colored squares, each of them made of two triangles.
Each time I move mouse or type something, the triangles in approximate area change colors.

After login, the screen is back to normal, sans gnome-shell specific font corruption and some extra (below).

This defects are not present with 1GiB.

Also, the Gnome3 gnome-shell border right now has "flightmode" symbol, which is completely white square and sound icon that is divided in four pieces.

I suggest this is strictly bug of Xorg driver, this is strictly bug within Mesa texture transfer, the content of those triangles is NOT copied right, this bug does NOT appear outside of Xorg or outside of OpenGL (Grub2 boots perfectly with zero errors via VESA) this bug's effects repeat themselves unless memory configuration change. With different memory config other sorts pop up, but previous stay. This is not bug due to insufficient memory. This bug does not change if different memory window is set in BIOS (I have 128 or 256, I have NO sideport or similar).

Please help me fix the bug! I am no programmer or developer, but give me some tools to run on the machine or I can give you VNC/root at any time + paypal tip and a thank you.

Please do not be ignorant!! :(((((

I have observed the case a bit more.
When machine is coming out of hibernation - the opensuse boot screen experiences corruption: 1/4 of the screen is drawn correct - the rest contains garbage. The pattern is pretty same - the screen is cut by four triangles with basements along the sides.

Important thing I noticed - the screen recovers itself after some time. Although font damage in gnome-shell is permanent, refreshing parts of the screen with some content has some chance to make it work as it should. THEN it stays correct.

Also,
I suspect that initial four triangle show right after login, is gnome 3 trying to blend-in, by applying a four-triangle surface filled with black and then increasing the alpha. The moment alpha is all way up, gnome removes them. With this bug - it looks like triangle flash which then suddenly correct.

To sum up,
I am totally sure this is about texture memory transfer within OpenGL context, I am nearly sure it happens because the texture memory IS NOT CLEARED when its asked or the content is overwritten when stored, or the memory is not protected from being overwritten by garbage. However, the system is fully stable even when I used it with 1GiB constantly swapping.

Please, help.

..agreed, this really shouldn't be marked as a supported card since it's
not actually functional.

(In reply to comment #63)
> ..agreed, this really shouldn't be marked as a supported card since it's
> not actually functional.

It works just fine a quite a few RS690 boards.

> It works just fine a quite a few RS690 boards.

ah. ..well, it also doesn't work for quite a few RS690 boards.

I guess it's academic for me, at this point, though -- I've long since
moved on, since I had to keep working and current, and the old driver
was dropped.

If you're reading this bug and have this issue, it's been open for
nearly three years, and isn't likely to be fixed, as far as I can tell.
If 3d acceleration is important to you, it's almost definitely worth it
to get some hardware that is better supported. I went with Intel
graphics -- there's a lot less likelihood that support will be dropped
for that, since Intel's more helpful than ATI regarding open-source
drivers for their graphics hardware.

(In reply to comment #65)
> I guess it's academic for me, at this point, though -- I've long since
> moved on, since I had to keep working and current, and the old driver
> was dropped.
>
> If you're reading this bug and have this issue, it's been open for
> nearly three years, and isn't likely to be fixed, as far as I can tell.
> If 3d acceleration is important to you, it's almost definitely worth it
> to get some hardware that is better supported. I went with Intel
> graphics -- there's a lot less likelihood that support will be dropped
> for that, since Intel's more helpful than ATI regarding open-source
> drivers for their graphics hardware.

Well, Brian, its true regarding older hardware, lets not be blind about all the post x1*** - 6*** cards, they are actually okay.

Also, "3D is important" is a bit exaggerated, because 3D pipeline and *everything* except this bug work really fine. There are many factors in play on modern desktop for it to "just work", but this only one bug really damages it.

On the other hand, its so damn shame that no one wants to give a look, even if offered full remote access to affected machine, in do what you want, ask what you wish, mode. :(

(In reply to comment #64)
> (In reply to comment #63)
> > ..agreed, this really shouldn't be marked as a supported card since it's
> > not actually functional.
>
> It works just fine a quite a few RS690 boards.

Hello Mr Deucher, could you please be a bit more specific which mobile xpress x1250 are not affected? Right now I have R60 and R20, both of which show same issues...

Can you please suggest any patch to clear the texture memory when asked prior to submitting it for writing (within the OpenGL-specific context)?

Right now, the more one works, the more triangle surface is flawless.

Only freshly booted or freshly hibernated under go it and as time passes these surfaces are eventually clear, except for those that never get a chance of rewrite, like fonts textures in gnome-shell.

Also, switching TTYs is still an issue as system can simply become unable to switch back to Xorg TTY, with screen constantly flashing/pulsating in black. But this is not a huge blocker.

Thank you!

Setting radeon.vramlimit=64 is also a workaround.

> > If you're reading this bug and have this issue, it's been open for
> > nearly three years, and isn't likely to be fixed, as far as I can tell.
> > If 3d acceleration is important to you, it's almost definitely worth it
> > to get some hardware that is better supported. I went with Intel
> > graphics -- there's a lot less likelihood that support will be dropped
> > for that, since Intel's more helpful than ATI regarding open-source
> > drivers for their graphics hardware.
>
> Well, Brian, its true regarding older hardware, lets not be blind about all the
> post x1*** - 6*** cards, they are actually okay.

Regardless, the RS690M was listed as supported, I bought hardware that I
thought would be supported for that specific reason, and then that
changed, and that leaves me with no experience or reason to recommend
ATI or the radeon driver at this point, and plenty of reason to
recommend against it. ..the stuff that is new now becomes old
later. ..why should I think that my experience with any other ATI card
should be different? ..at least on the Intel side, there's the blessing
(and support) of the chip maker.

> Also, "3D is important" is a bit exaggerated, because 3D pipeline and
> *everything* except this bug work really fine.

No disagreement there. I've got an Intel graphics card that works
superbly, and there are others out there with nVidia and ATI cards that
run great, too. What I was said was saying was (indented, so that the
if statements and their subjective clauses are more apparent):

* If you're reading this and have this issue
 * This issue has been open for nearly three years
 * It isn't likely to be fixed, from what I can tell
 * If 3d is important to you
  * It is almost definitely worth it to get some hardware that is better
supported.

..I stand by that statement.

> There are many factors in play
> on modern desktop for it to "just work", but this only one bug really damages
> it.

*nod* and a lot of them work fine, and this one doesn't. ..a perfectly
functional car with a broken drive shaft that no one knows how to fix is
still valuable -- it's just not valuable to someone who wants to drive a
car, unless that person knows how to fix it, or can sell that car, and
get another car which many people know how to fix, and which appears
less likely to break.

..I'm not looking at this and thinking "That's bad work they've done",
I'm looking at it and saying "No one has had the time, know-how, and
the access to the hardware to fix this, so if you are waiting for it to
get done, my opinion is that you're better off buying more compatible
hardware in this particular case."

..then again, all it takes is someone who does have the time, know-how,
and hardware to fix this, and who wishes to donate their work. ..if
someone does do that -- thank you. ..that specifically won't benefit me
at this point, but thank you just on the general principle of it, and
for the people that it will benefit. ..and thank you to everyone else
who has contributed to Linux, X, and all the layers in between and on
top -- it's phenomenal work that provides a genuine alternative to the
proprietary operating systems that are out there.

On Wed, 2013-11-27 at 04:45 +0000, <email address hidden>
wrote:
> Comment # 68 on bug 35457 from Alex Deucher
> Setting radeon.vramlimit=64 is also a workaround.
>
> ______________________________________________________________________
> You are receiving this mail because:
> * You reported the bug.

If setting the vramlimit does work (I'm unable to test it at this point
since I no longer have the hardware) than that's a reasonable option.
Up until the time I had to get something else, none of the proposed
solutions had worked for me -- but if a functional workaround is
present, that's often preferable to buying new hardware.

Created attachment 89886
possible fix

Does this patch help?

(In reply to comment #70)
> If setting the vramlimit does work (I'm unable to test it at this point
> since I no longer have the hardware) than that's a reasonable option.
> Up until the time I had to get something else, none of the proposed
> solutions had worked for me -- but if a functional workaround is
> present, that's often preferable to buying new hardware.

It is reported as a valid workaround on this very bug report. Has anyone else tried it?

Created attachment 89895
Samsung R60, xpress 1250, OpenSuse Tumbleweed, kernel 3.11, Mesa 9.2.2, login corruption

Dear Mr. Deutcher, thank you for will and readiness to help in this problem!!

I am using radeon.gart=1024, it does not help.
Then I upgraded to Tumbleweed (3.11)
Glxinfo reports:

OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RS600
OpenGL version string: 2.1 Mesa 9.2.2
OpenGL shading language version string: 1.20

Then I added radeon.dpm=1, there are no information about dpm or powermanagement what so ever in dmesg (unlike 5850 card that I have). I suggest dpm is not supported on this chip. Not great deal, but for example, 5850 is unstable withOUT dpm in 3.11.

Lastly, of course I read all patches and responses from people in these two bugs, and tested first switching from 256 VGA memory to 128 via BIOS (only two options), it didn't help.

Then I appended "radeon.vramlimit=64" to grub2 kernel line, updated grub, rebooted. Nothing changed. I attach the screenshot showing the issue with gnome-shell corruption and the login triangle issue, that is even more agressive when system comes out of hibernation.

dmesg | grep -i radeon says:

[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.11.6-4-desktop root=UUID=29100748-63ff-45a1-8642-b795f20d4aea resume=/dev/disk/by-id/ata-WDC_WD1200BEVS-22UST0_WD-WXC208783969-part2 splash=silent quiet showopts radeon.dpm=1 radeon.gartsize=1024 radeon.vramlimit=64
[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.6-4-desktop root=UUID=29100748-63ff-45a1-8642-b795f20d4aea resume=/dev/disk/by-id/ata-WDC_WD1200BEVS-22UST0_WD-WXC208783969-part2 splash=silent quiet showopts radeon.dpm=1 radeon.gartsize=1024 radeon.vramlimit=64
[ 2.276384] [drm] radeon kernel modesetting enabled.
[ 2.276584] fb: conflicting fb hw usage radeondrmfb vs EFI VGA - removing generic driver
[ 2.279337] radeon 0000:01:05.0: VRAM: 128M 0x0000000078000000 - 0x000000007FFFFFFF (64M used)
[ 2.279345] radeon 0000:01:05.0: GTT: 1024M 0x0000000080000000 - 0x00000000BFFFFFFF
[ 2.281879] [drm] radeon: 64M of VRAM memory ready
[ 2.281885] [drm] radeon: 1024M of GTT memory ready.
[ 2.304378] [drm] radeon: 1 quad pipes, 1 z pipes initialized.
[ 2.309271] radeon 0000:01:05.0: WB enabled
[ 2.309286] radeon 0000:01:05.0: fence driver on ring 0 use gpu addr 0x0000000080000000 and cpu addr 0xffff880036bbe000
[ 2.309352] [drm] radeon: irq initialized.
[ 2.310247] [drm] radeon: ring at 0x0000000080001000
[ 2.312584] [drm] radeon atom DIG backlight initialized
[ 2.312592] [drm] Radeon Display Connectors
[ 2.902375] fbcon: radeondrmfb (fb0) is primary device
[ 3.227074] radeon 0000:01:05.0: fb0: radeondrmfb frame buffer device
[ 3.227080] radeon 0000:01:05.0: registered panic notifier
[ 3.227124] [drm] Initialized radeon 2.34.0 20080528 for 0000:01:05.0 on minor 0

I will test the patch today.
At your will, I will give you remote login to the notebook for any kind of testing you so desire.

1 comments hidden view all 193 comments

Brian Visel, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/556782/comments/184 regarding you no longer have the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

no longer affects: linux (Ubuntu)
affects: linux → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Critical → Undecided
status: Confirmed → New
status: New → Invalid
madbiologist (me-again) wrote :

According to https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=35eecf052250f663f07a4cded7d3503fd1b50729 and https://bugs.freedesktop.org/show_bug.cgi?id=35457 this bug is finally fixed in the upstream 3.13-rc5 kernel. A PPA of this kernel is available at http://kernel.ubuntu.com/~kernel-ppa/mainline/ and instructions on how to install and uninstall it are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds

ShinobiTeno (lct-mail) wrote :

This bug was NOT ressolved even in Kernel 3.17!

Even with latest Enlighment (E19), I experience text corruption when enabling hardware acceleration in Compositing window.
When switching to Software rendering, there is no issue.

KDE freezes simply after certain period of work if hardware acceleration is used.

ShinobiTeno, thank you for your comment. Unfortunately, this bug report is not scoped to you, your problem, or your hardware. So your problem and hardware may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Displaying first 40 and last 40 comments. View all 193 comments or add a comment.