delete last note shows hidden note

Bug #1783053 reported by a1291762 on 2018-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xpad
Low
Arthur Borsboom

Bug Description

I have used Xpad for a number of years now. I recently upgraded from Ubuntu 14.04 to 18.04 and have noticed that when deleting the last visible pad, Xpad finds an invisible pad and shows that.

This is not useful, nor desirable.

I use focus follows mouse so it's also completely pointless to do this when there are other visible pads (though I suppose it doesn't hurt).

I couldn't find an upstream project to report this to.

I have solved this for myself by editing the Xpad source code and removing the code that finds and shows another pad when deleting a pad.

Related branches

I guess you are right about this behavior. It does feel a bit awkward.
I remember implementing this functionality in the past. The purpose was to create and delete many pads in a very fast time, to speed up debugging of resource leaks and something else I cannot remember exactly.

I will comment out this piece of code to disable this functionality. However, since it might prove useful for debugging, I will leave the code in place.

Changed in xpad:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Arthur Borsboom (arthurborsboom)
milestone: none → 5.1.0
Changed in xpad:
status: Confirmed → Fix Committed
Changed in xpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers