shift delete + enter is too easy to type

Bug #1783052 reported by a1291762 on 2018-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xpad
Medium
Arthur Borsboom

Bug Description

I have used Xpad for a number of years now. I recently upgraded from Ubuntu 14.04 to 18.04 and have noticed that Xpad now treats shift delete as a "delete current pad" shortcut. It does put up a confirmation window, but while editing text, it is EXTREMELY common to select text with shift, delete and then enter a new line. I have already lost one note due to this and have unintentionally triggered it many times.

I couldn't find an upstream project to report this to.

I have solved this for myself by editing the Xpad source code and removing the shift delete shortcut.

Related branches

IMHO [shift]+[delete] followed by [Enter] is not a one-key press that happens by accident. Also, [shift]+[delete] is a common key combination for this action.

However, I do believe we could improve this by making the default button on the delete confirmation window set to [Cancel] instead of [Delete].

How does that sound?

Changed in xpad:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Arthur Borsboom (arthurborsboom)
milestone: none → 5.1.0

I have implemented my own suggestion already in Xpad x5.1.
This results in the following key combinations to delete a pad.

[shift]+[delete] - [tab]+[enter].

Please let me know if that is satisfactory to you.

Changed in xpad:
status: Confirmed → Fix Committed
Changed in xpad:
status: Fix Committed → Fix Released
a1291762 (a1291762) wrote :

Hi,

Sorry for the late reply. I was only able to check out this change today.

My usage of xpad may be a little unusual since I use it akin to a "text editor" that saves temporary text documents for me. I got into this habbit after losing data from actual text editors with "unsaved" changes. Because of this usage, I regularly do editing in an xpad window and shift+delete, enter is a surprisingly common keypress. I hold down shift to select some lines, press delete (apparently without lifting my finger off the shift key - probably because no other editor has required that), then press enter to insert a blank line.

As the new prompt is no longer destructive by default, it's probably fine. If it annoys me, I'll just keep running a patched binary :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers