"delete" and "cancel" buttons not translated

Bug #1455888 reported by Jean-Marc on 2015-05-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xpad
Low
Arthur Borsboom

Bug Description

Hello,

"delete" and "cancel" buttons are not translated in French (see attachment) and do not appear in translation template.

Thank you

Jean-Marc

Jean-Marc (m-balthazar) wrote :

Hi Jean-Marc,

I just looked in the source code of the last Xpad version and it looks like it that the button texts are translatable.
Or there is something wrong in the program, or it has been fixed in the past and you are using an older version.

The latest released version is v4.5

Which version of Xpad are you using?

Changed in xpad:
assignee: nobody → Arthur Borsboom (arthurborsboom)

Now thinking longer than 5 minutes and reading your message again, I realize the translation templates might not have been updated. Still I am curious about the version you are using. :)

Jean-Marc (m-balthazar) wrote :

Hi Arthur,

I use the version 4.5

Regards

Hi Jean-Marc,

The workings of the translation mechanism are not totally clear to me, so I am looking for some advice.
I noticed that all the .po files (one for each language) are not updated; they are not aligned with the source code.

According to this article I should not update the PO files myself; it should be performed by the translators.
https://wiki.gnome.org/TranslationProject/DevGuidelines/Localize%20using%20gettext%20and%20intltool

I also noticed that the .pot file is missing in the po folder.

Do you have any experience with the intltool?
Do you know who has to run which command?

Changed in xpad:
status: New → Confirmed
milestone: none → 4.6
importance: Undecided → Low
Jean-Marc (m-balthazar) wrote :

Sorry Arthur,

I have no experience with intltool and could not explain you the working.

Jean-Marc

Jean-Marc (m-balthazar) wrote :

I downloaded the PO folder.
I think the POT template file is not updated.
As I understood, PO translations files are automatically updated by Launchpad Translations.

Hi Jean-Marc,

I have recreated the missing POT file and added it to the 4.6 branch.
Let's see if this fixes the issue overnight.

To be continued...

Changed in xpad:
status: Confirmed → Fix Committed

For the Dutch language, the template seems to be up-to-date.
I have been able to translate the new items.

How does this work out for you?

Jean-Marc (m-balthazar) wrote :

Hi Arthur,

It works fine for me, I just make some suggestions in French.

Thank you

Changed in xpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers