Xpad isn't returned back to the Ubuntu Desktop screen.

Bug #1310291 reported by imnotbug on 2014-04-20
26
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Xpad
High
Arthur Borsboom

Bug Description

Ubuntu14.04LTS;
When use 'Show Desktop' -> Again -> Hidden Xpad isn't returned back on the Ubuntu Desktop screen.

Hi,

I am not too familiar with Ubuntu / Unity, so I need a little help.

The options "Show desktop -> Again -> Hidden" sounds like an option of Ubuntu, am I right?

Can you describe me what you would expect to happen?
Do you click these options in the Unity menu bar?

Changed in xpad:
status: New → Incomplete
Sagar Ghuge (ghugesss) wrote :

Hi,

You mean using the super+d for showing desktop and hiding applications. ?

If yes then in that case - xpad window is focused then it will gets appeared.

I am not able to produce problem. can you specify which version are you using ?

abhilash tuse (abhilashtuse) wrote :

Using xpad version 4.1 on ubuntu 13.10. Yes, after pressing super+d to hide everything and show desktop even if xpad window is focused it does not return back to screen.

Sagar Ghuge (ghugesss) wrote :

H Abhilash,

In 4.3 this got solved. I think you should give a try using xpad 4.3

abhilash tuse (abhilashtuse) wrote :

Tried v4.3. Still facing same issue.

G (c0ffeeartc) wrote :

Downloaded v4.3.
$./configure
$make
$sudo make install
$xpad --version
>>Xpad 4.3
$xpad
create new note
hit Ctrl+Super+D twice -> All windows reappear, except notes.
No way to bring them back by rerun or show all.

Sagar Ghuge (ghugesss) wrote :

I am using the xpad 4.4 and I am not experencing this issue.

If focus is on xpad then it shows me the window, if not and If I do alt+tab then I get the xpad.

Try using the xpad 4.4 ( this is under development version, so you need to install few dependancies )

G (c0ffeeartc) wrote :

I am on Ubuntu 14.04 with Unity. Bug persists in 4.4.
 Hit Ctrl+Super+D twice and stickers don't reappear.
Though I found that running
 $xpad -q
 and restarting xpad shows stickers alright.

Hi,
I use 14.10 with gnome. I need to check. Across unity.
Thanks for pointing out.
On Nov 10, 2014 10:31 PM, "G" <email address hidden> wrote:

> I am on Ubuntu 14.04 with Unity. Bug persists in 4.4.
> Hit Ctrl+Super+D twice and stickers don't reappear.
> Though I found that running
> $xpad -q
> and restarting xpad shows stickers alright.
>
> --
> You received this bug notification because you are subscribed to Xpad.
> Matching subscriptions: Sagar Ghuge
> https://bugs.launchpad.net/bugs/1310291
>
> Title:
> Xpad isn't returned back to the Ubuntu Desktop screen.
>
> Status in Xpad:
> Incomplete
>
> Bug description:
> Ubuntu14.04LTS;
> When use 'Show Desktop' -> Again -> Hidden Xpad isn't returned back on
> the Ubuntu Desktop screen.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/xpad/+bug/1310291/+subscriptions
>

Changed in xpad:
importance: Undecided → Medium

Hi G (c0ffeeartc),

Yesterday and today I have finished a couple of improvements regarding showing the pads after minimization.

Are you able to try the xpad from the source (since it has not been released yet), to see if your issue has been solved?

In your home directory:

bzr branch lp:xpad (= Download latest source)
./autogen.sh
./configure
make
make install

Changed in xpad:
milestone: none → 4.6
assignee: nobody → Arthur Borsboom (arthurborsboom)

Confirmed for Ubuntu 15.10 with Xpad 4.5

Changed in xpad:
status: Incomplete → Confirmed
Changed in xpad:
importance: Medium → High

After analysis it seemed that the pads are not returning to the desktop, because they are hidden from the taskbar. The pads are hidden when the window decorations are turned off. This relationship sounds nice, however it is nicer if you can just set your preference yourself.

Therefore I have added two new options in the preferences (regardless of the window decorations setting):

* hide from taskbar and task switcher (alt-tab)
* hide from workspace switcher

So, for Ubuntu users it is probably interesting to turn the option "hide from taskbar" off, so the pads can be returned as before.

Will be released with v4.6

Changed in xpad:
status: Confirmed → Fix Committed
Changed in xpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers