Option to skip tasklist for note windows

Bug #1029202 reported by mrkramps on 2012-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xpad
Wishlist
Arthur Borsboom

Bug Description

There are tools like DevilsPie or wmctrl to work around this issue, but providing this feature on its own would a good thing to have. I do not know how other people feel about this, but personally I see no good reason to have an entry for each individual note window in the tasklist. That is why I suggest an option in the preferences.

Xpad currently is the only reason why I run DevilsPie on my systems. Would be nice to finally being able to stop this additional daemon.

Related branches

Hi mrkramps,

Thanks for helping out about improving Xpad. I am not sure if I understand you well, so I am going to rephrase it.

You would like to add a feature where the user can set in the preferences, if the notes appear as a task in the taskbar, or if they should be hidden from the taskbar. If the notes are not visible on the taskbar, the way to find them is:

- by sticking the notes on the desktop
- by right clicking the tray icon

Do I understand you correctly?
If not, would you mind to elaborate?

Regards,
Arthur Borsboom.

Changed in xpad:
status: New → Incomplete
tags: added: taskbar ui
mrkramps (mrkramps) wrote :

Hey Arthur,

sorry for my abstruse description. But, you got it right. This is excactly what I was asking for.

Thanks,
mrkramps

Changed in xpad:
importance: Undecided → Wishlist
Changed in xpad:
milestone: none → 4.3
Sachin Raut (sachinr) wrote :

Hi mrkramps,

I think, there is one way to do it.
Right click on any note > View > Window Decorations > uncheck this.
This will hide xpads from taskbar.

Will this work out for you?

Cheers,
Sachin

mrkramps (mrkramps) wrote :

Sorry Sachin,

if removing Window Decorations works for me I would not have posted this request. Indeed, it is hiding the windows from taskbar, but for me it makes managing notes more difficult. With visible Window Decoration it is way easier to move notes and apply other window manager hints (like sticky, always top and such) for single ones.

As already mentioned in my initial post it is pretty easy to work around it with a tool like Devil's Pie to set the skip_taskbar_hint. Nevertheless I would really like to see gtk_window_set_skip_pager_hint yes/no as a native option in the View menu.

After all, it is only me but this is how Xpad works best for me.

Thanks again,
mrkramps

Sachin Raut (sachinr) on 2013-10-10
Changed in xpad:
assignee: nobody → Sachin Raut (sachinr)
Changed in xpad:
milestone: 4.3 → 4.4

Just a note for myself while researching other topics for xpad.
The function to implement seems to be: gtk_window_set_skip_taskbar_hint ()

Changed in xpad:
status: Incomplete → Confirmed
Sagar Ghuge (ghugesss) on 2014-08-27
Changed in xpad:
assignee: Sachin Raut (sachinr) → nobody
Changed in xpad:
milestone: 4.4 → 4.5
Changed in xpad:
milestone: 4.5 → 4.6
Changed in xpad:
milestone: 4.6 → 4.7

After analysis it seemed that the pads are not visible in the workspace switcher and the taskbar, when window decorations are turned off. This relationship sounds nice, however it is nicer if you can just set your preference yourself.

Therefore I have added two new options in the preferences (regardless of the window decorations setting):

* hide from taskbar and task switcher (alt-tab)
* hide from workspace switcher

Will be released with v4.6

Changed in xpad:
assignee: nobody → Arthur Borsboom (arthurborsboom)
milestone: 4.7 → 4.6
status: Confirmed → Fix Committed
Changed in xpad:
status: Fix Committed → Fix Released
mrkramps (mrkramps) wrote :

Thank you very much, Arthur!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers