X randomly restarts

Reported by muhalifsirin on 2012-04-28
This bug report is a duplicate of:  Bug #973096: Nvidia driver causes xorg crash. Edit Remove
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
X.Org X server
New
Undecided
Unassigned
xorg (Ubuntu)
High
Unassigned

Bug Description

Edit: I thought this was a flashplayer issue, but it happens randomly

I am using 12.04 64bit, Nvidia 8600gt. I get the problem during both nouveau and nvidia propretary drivers. I had the problem on beta and also final release (clean installs).

Summary:
X randomly restarts (I am logged out). I have not experienced the problem on Unity 2d, but I have tried it only a couple of hours.
---
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 295.40 Thu Apr 5 21:37:00 PDT 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu6
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
DistUpgraded: Fresh install
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 295.40, 3.2.0-23-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation G84 [GeForce 8600 GT] [10de:0402] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:3452]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: xorg 1:7.6+12ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=3789fa86-4679-4baa-b656-5ccd9c52073d ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Tags: precise ubuntu compiz-0.9
Uname: Linux 3.2.0-23-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 03/23/2010
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2N-E ACPI BIOS Revision 5001
dmi.board.name: M2N-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2N-EACPIBIOSRevision5001:bd03/23/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N-E:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.7.6-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please run the command 'apport-collect 990357' which will attach necessary information for debugging this as an Xorg problem. Thanks in advance.

Changed in ubuntu:
status: New → Incomplete
affects: ubuntu → xorg (Ubuntu)

apport information

tags: added: apport-collected compiz-0.9 precise ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Thanks for the help Fabio. Those are the reports I got. I hope it will be helpful.

muhalifsirin (alperense) on 2012-04-28
summary: - X randomly restarts during flash player use
+ X randomly restarts
description: updated
description: updated
Bryce Harrington (bryce) wrote :

Please collect a full backtrace on this crash - see http://wiki.ubuntu.com/X/Backtracing for guidance.

Changed in xorg (Ubuntu):
importance: Undecided → High
status: Incomplete → New
status: New → Incomplete
muhalifsirin (alperense) wrote :

OK, I did my best to do what I am being told on http://wiki.ubuntu.com/X/Backtracing.

You can see the attachment.

Note: I don't get the logouts anymore. X just stops responding. I have installed Nvidia Proprietary drivers, then went back to Nouveau, behaviour is same. System just freezes, and does not respond. But I can connect through ssh and run commands.

muhalifsirin (alperense) wrote :

Also I generated this log file on during my Nvidia proprietary driver use (Not Nouveau). I was using Nouveau drivers for the previous gdb-Xorg.txt file.

I don't know if it has any use, but I am attaching it.

Piotr Kopec (pkopec17) on 2012-05-09
Changed in xorg (Ubuntu):
assignee: nobody → Piotr Kopec (pkopec17)
assignee: Piotr Kopec (pkopec17) → nobody
Piotr Kopec (pkopec17) wrote :

I've installed Flash-Aid plugin for firefox and installed beta flash from adobe lab repo using this plugin. Works well so far, flash crushes sometimes but X doesn't restart randomly.

Stephen Allen (stephen6ipa) wrote :

This bug is in it's own league. Has anyone personally seen a bug through to its fixed conclusion on this website? There are so many different Bug Report (#'s) for the same issue. I also have a problem with duel monitors and I am just not seeing any progress. So I am wondering if these bugs get fixed in an update ie one day update manager will be the ubuntu bug messiah and magically fix the bug? Is that the way it works? Or do I have to be more proactive and look for and apply the bug fixes? Seriously considering going back to 11.10 where things worked. Never - Never - never (since i have been using ubuntu from version 8) have I ever lost work or time because of a nasty bug like this one. Is there a way you can pay for a working ubuntu 12.04? Anybody care to comment?

To post a comment you must log in.