Xorg instability and freezes : nvidia-current 256.44 - amd64 and ubuntu maverick

Reported by Joel Wirāmu Pauling (aenertia) on 2010-08-29
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
MPlayer with VDPAU support
Fix Released
Undecided
Unassigned
X.Org X server
Undecided
auto-linux-bugs
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Hi there,

latest drivers installed by either distro repo or by the installer
with Ubuntu maverick fail often and regularly.

Always reproducable using x264 video and vdpau output via mplayer and
doing resizes ff/rwd of video.

Also occurs doing simple things (open firefox/ view menu of
application launcher).

DPMS "off" makes slightly more stable although still crashes with mplayer test.

Have tested against 2.6.35-17 and 2.6.35-19 maverick amd64 kernels.

Have also tested with xorg-edgers ppa xorg versions but with same results as described here.

System hangs, often still able to get in via network, however doing
intensive things (cat large syslog ) will hang the process.

Xorg and any offending triggering application cannot be killed
manually. gdm restart also does not work.

shutdown now and reboot will not trigger reboot. Power must be cycled.

Attached are various dump I was able to obtain during a freeze.

nvidia-bug report hangs during collection so may be incomplete.

Also the ABI for the 256.44 drivers is out of date and needs updating,
but this is a seperate issue to the general instability.

Have attempted using xorg-edgers ppa with same result. Also attempted
to use the 256.35 drivers but it complains of missing linux-vdso.so.1
library and X does not load.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 256.44 Thu Jul 29 01:22:44 PDT 2010
 GCC version: gcc version 4.4.5 20100824 (prerelease) (Ubuntu/Linaro 4.4.4-9ubuntu2)
Architecture: amd64
Date: Sun Aug 29 19:00:58 2010
DkmsStatus: nvidia-current, 256.44, 2.6.35-19-generic, x86_64: installed
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406)
MachineType: Gigabyte Technology Co., Ltd. GA-MA785GT-UD3H
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic root=UUID=4e928070-2f23-4c94-b552-baad67d80d38 ro
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
dmi.bios.date: 05/25/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F8
dmi.board.name: GA-MA785GT-UD3H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF8:bd05/25/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GT-UD3H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GT-UD3H:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA785GT-UD3H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
nvidia-settings:

system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-19-generic
xkbcomp:
 Error: command ['xkbcomp', ':0', '-w0', '-'] failed with exit code 1: Error: Cannot open display ":0"
                   Exiting

Dumps of various relevant system info during a freeze (oops output etc in kern.log running processes etc)

Please note that the installer log info in the nvidia bug report shows the old installer log where attempted manual install of .35 beta driver. This was removed and the dump relates to the repo supplied nvidia-current (256.44) drivers, it is valid just a little misleading at the top.

I manually verified all the manual nvidia installer components had been removed.

Bryce Harrington (bryce) on 2010-08-29
affects: xorg (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Bryce Harrington (bryce) on 2010-08-29
tags: added: edgers

Will attempt tonight with fix proposed here :

I am unsure if Arturs, comment relates just to the x screen issue or the general instabilities reported here.

On 30 August 2010 07:02, Artur Rona <email address hidden> wrote:
> nVidia 256.52 has fixed this issue. The test driver is available in Ubuntu-X-Swat PPA:
> https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
>
> --
> nVidia card : X won't start since 1.9 update, no screens found
> https://bugs.launchpad.net/bugs/616023
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Am hopeful based on this changelog:

Changelog from upstream 256.52

  * New upstream release. Changes since 265.44: [sic: 256.44]
   - Fixed a bug that prevented XvMC from initializing in most cases.
   - Added support for xorg-server video driver ABI version 8, which will
     be included in the xorg-server-1.9 series of releases.
   - Fixed a bug that caused extremely slow rendering of OpenGL
     applications on X screens other than screen 0 when using a compositing
     manager.
   - Fixed a regression introduced after 256.35 that caused stability
     problems on GPUs such as GeForce GT 240.
   - Fixed a slow kernel virtual address space leak observed when starting
     and stopping OpenGL, CUDA, or VDPAU applications.
   - Fixed a bug that left the system susceptible to hangs when running
     two or more VDPAU applications simultaneously.

Laurent (syrius-no-log) wrote :

I can reproduce it by running emacs23 with its gtk gui.
maverick/amd64/nvidia 256.52-0ubuntu0sarvatt

Laurent (syrius-no-log) wrote :

but i might be encountering another bug, i'm using both xinerama and twinview, i can't trigger it when xinerama is disabled

Running stable under test conditions reported above with 256.52. vdpau now does not lock up computer, have not had locks ups during normal compiz enabled ubuntu-desktop settings. Switching VT's also is ok.

I have not however tested with DPMS turned back on as of yet. And have not tested with Twinview.

I have in the past turned off xinerama as it has caused issues for me.

Will do some more testing with the .52 release over the next couple of days.

Also;
ignoreABI is no longer required with .52

Would recommend this goes into Maverick base and possibly Lucid.

Laurent (syrius-no-log) wrote :

downgraded xserver-xorg and nvidia*, not crashing anymore with the ones from lucid.

Artur Rona (ari-tczew) wrote :

I say that nvidia 256.52 fixes support for xserver 1.9.

Extender (msveshnikov) on 2010-10-01
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Extender (msveshnikov) on 2010-10-16
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2011-04-06
Changed in mplayer-vdpau:
status: New → Fix Released
Changed in xorg-server:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-linux-bugs Edit

Bug watches keep track of this bug in other bug trackers.