X crashes on key press

Bug #597895 reported by Luke
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
xorg-server (Ubuntu)
Medium
Bryce Harrington
Natty
Medium
Bryce Harrington

Bug Description

Conditions: gdm, fluxbox, xbmc, A PS3 remote controller
Action: press cross button inside XBMC in fullscreen-mode

/var/log/Xorg.0.log:

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e937b]
1: /usr/bin/X (0x8048000+0x61c7d) [0x80a9c7d]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xc68410]
3: /usr/bin/X (mieqProcessDeviceEvent+0xd3) [0x80e8633]
4: /usr/bin/X (mieqProcessInputEvents+0x6c) [0x80e87dc]
5: /usr/bin/X (ProcessInputEvents+0x17) [0x80b57e7]
6: /usr/bin/X (0x8048000+0x2a1a0) [0x80721a0]
7: /usr/bin/X (0x8048000+0x1ed7a) [0x8066d7a]
8: /lib/tls/i686/cmov/libc.so.6 (__libc_start_main+0xe6) [0x199bd6]
9: /usr/bin/X (0x8048000+0x1e961) [0x8066961]
Segmentation fault at address 0x64

Caught signal 11 (Segmentation fault). Server aborting

Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) Video Bus: Close
(II) UnloadModule: "evdev"
(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) Logitech Optical USB Mouse: Close
(II) UnloadModule: "evdev"
(II) NOVATEK USB Keyboard: Close
(II) UnloadModule: "evdev"
(II) NOVATEK USB Keyboard: Close
(II) UnloadModule: "evdev"
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
(II) PS3 Remote Controller: Close
(II) UnloadModule: "evdev"
(II) AIGLX: Suspending AIGLX clients for VT switch

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-core 2:1.7.6-2ubuntu7.1
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
Date: Thu Jun 24 00:20:11 2010
DkmsStatus: Error: [Errno 2] No such file or directory
ExecutablePath: /usr/bin/Xorg
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=177eb462-4768-40c6-96d3-cc875fefcc4c ro quiet splash
ProcEnviron:
 LANG=de_AT.UTF-8
 PATH=(custom, no user)
SourcePackage: xorg-server
dmi.bios.date: 12/18/2009
dmi.bios.vendor: Intel Corp.
dmi.bios.version: JT94510H.86A.0040.2009.1218.1345
dmi.board.name: D945GSEJT
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE57850-401
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrJT94510H.86A.0040.2009.1218.1345:bd12/18/2009:svn:pn:pvr:rvnIntelCorporation:rnD945GSEJT:rvrAAE57850-401:cvn:ct3:cvr:
glxinfo:
 Error: couldn't find RGB GLX visual or fbconfig
 name of display: localhost:11.0
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-22-generic

Related branches

Revision history for this message
Luke (lukaswillfort) wrote :
Bryce Harrington (bryce)
tags: added: crash
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Revision history for this message
Bob (loosen) wrote :

I have similar crashes when running XBMC fullscreen, I don't have a ps3 remote.
The crashes seem to happen at random times.

Revision history for this message
Bob (loosen) wrote :
Revision history for this message
Bob (loosen) wrote :

I disconnected my bluetooth keyboard, and now it doesn't seem to crash anymore.
It's interesting that xorg crashes in DGAProcessPointerEvent, even with the mouse disconnected.

Revision history for this message
Bob (loosen) wrote :

This patch is from http://bugs.freedesktop.org/show_bug.cgi?id=27573
It seems to have fixed it.

tags: added: patch
Revision history for this message
Bob (loosen) wrote :

Spoke too soon, yesterday it ran stable for over 3 hours but today it crashed twice again.

Revision history for this message
Bob (loosen) wrote :

A very friendly Xorg developer made a patch for my issue, apparently my bluetooth keyboard exposes 4 axes but no buttons.
The first axis is the battery voltage, when that goes down the keyboard sends an axis event, causing Xorg to dereference a NULL pointer on the button.

I don't know for sure if this patch will fix the issue in this ticket until I see a backtrace with debug symbols or the output of evtest on the ps3 remote.

Revision history for this message
Bob (loosen) wrote :

And now it crashes differently.
The very friendly Xorg developer is working on it.

Revision history for this message
Jack Deslippe (jdeslip) wrote :

I have a similar problem with the d-link boxee remote when I try to use Boxee full screen. Whenever I press a button on the remote, X segfaults and dies.

This is in Ubuntu 10.10 (32 bit). I get a backtrace very similar to the one reported in the first post. Did anyone find a solution to this?

Revision history for this message
Jack Deslippe (jdeslip) wrote :

For further info, it also occurs on XBMC when full screen. Here is the backtrace I get from my xorg log

Backtrace:
[ 10271.990] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e82fb]
[ 10271.990] 1: /usr/bin/X (0x8048000+0x5da8d) [0x80a5a8d]
[ 10271.990] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0x91640c]
[ 10271.990] 3: /usr/bin/X (mieqProcessDeviceEvent+0xd3) [0x80e75b3]
[ 10271.991] 4: /usr/bin/X (mieqProcessInputEvents+0x6c) [0x80e775c]
[ 10271.991] 5: /usr/bin/X (ProcessInputEvents+0x17) [0x80b1797]
[ 10271.991] 6: /usr/bin/X (0x8048000+0x25d2e) [0x806dd2e]
[ 10271.991] 7: /usr/bin/X (0x8048000+0x1a5ba) [0x80625ba]
[ 10271.991] 8: /lib/libc.so.6 (__libc_start_main+0xe7) [0x15fce7]
[ 10271.991] 9: /usr/bin/X (0x8048000+0x1a191) [0x8062191]
[ 10271.991] Segmentation fault at address 0x6
[ 10271.991]
Caught signal 11 (Segmentation fault). Server aborting
[ 10271.991]

Revision history for this message
Bob (loosen) wrote :

Jack Deslippe, if you follow https://wiki.ubuntu.com/DebuggingXorg you can make a backtrace with debug symbols, which is far more useful to the developers.

Revision history for this message
Bob (loosen) wrote :

This patch prevents my second crash.

Revision history for this message
Bob (loosen) wrote :

This patch prevents the mousepointer from moving on an input device with a "misc" axis, in other words an input device with an axis that has no specified direction.

Revision history for this message
Sebastien Bacher (seb128) wrote :

thank you for your work on the issue, you listed several patches are all those in upstream git now and required to fix your bug?

Changed in xorg-server (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Bob: have you given those patches for Peter to review?

Changed in xorg-server (Ubuntu):
importance: High → Undecided
status: Triaged → Incomplete
Revision history for this message
Bob (loosen) wrote :

These patches I got from peter:
0001-xfree86-Check-for-existance-of-button-class-before-d.patch
master_device.patch
dix_dont_create_core_motion_events_for_non_xy_valuators.diff

I talked with him on irc a while back, I'm bobo1on1 from XBMC, he probably remembers me (he emailed me master_device.patch).
I don't know if he committed these patches upstream.
master_device.patch should also fix the issue where xorg crashes when XBMC or boxee runs fullscreen and one uses the boxee remote,

I don't know for sure if 0001-xfree86-dga-needs-to-use-the-master-keyboard-state-2.patch has fixed my issue, or does anything useful for me at all, because (I found this out later) my keyboard has the battery voltage on an analog axis, and an event on this axis would crash xorg, since I don't know when the battery voltage changes, the crashes appeared random to me.

Revision history for this message
Robert Hooker (sarvatt) wrote :

The fourth patch: dix_dont_create_core_motion_events_for_non_xy_valuators.diff caused quite a few regressions when it was introduced as well as made the test suite which is run at build time fail.

https://bugs.freedesktop.org/show_bug.cgi?id=30267

Revision history for this message
Bob (loosen) wrote :

dix_dont_create_core_motion_events_for_non_xy_valuators.diff doesn't fix any crashes, it just prevents the mouse pointer moving when the battery voltage on my keyboard changes.

Revision history for this message
Bryce Harrington (bryce) wrote :

Alright, since there's issues with that one, would you mind handling that as a separate bug? For this bug report we'll focus on the crash fixes since that seems to be the thrust of the original bug report.

Revision history for this message
Bryce Harrington (bryce) wrote :

I've verified the changes for these two patches are already present in natty's xserver:
  * 0001-xfree86-Check-for-existance-of-button-class-before-d.patch
  * 0001-xfree86-dga-needs-to-use-the-master-keyboard-state-2.patch

Revision history for this message
Bryce Harrington (bryce) wrote :

The one remaining patch, master_device.patch, is present in the xserver git tree, but not in natty's xserver. I'll go ahead and backport that, and I *think* that should be sufficient to close this bug report.

Revision history for this message
Bryce Harrington (bryce) wrote :

Patch added to git, testing build and then will upload.

Changed in xorg-server (Ubuntu Natty):
assignee: nobody → Bryce Harrington (bryce)
importance: Undecided → Medium
status: Incomplete → Fix Committed
Revision history for this message
Bryce Harrington (bryce) wrote :

Right, built fine. Uploading.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.9.0.902-1ubuntu3

---------------
xorg-server (2:1.9.0.902-1ubuntu3) natty; urgency=low

  * Add 207_dga_master_device.patch: Cherrypick from upstream xserver git
    to fix crash with a bluetooth keyboard when using XBMC full screen.
    (LP: #597895)
 -- Bryce Harrington <email address hidden> Thu, 06 Jan 2011 12:17:16 -0800

Changed in xorg-server (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in xorg-server:
status: Unknown → Fix Released
Changed in xorg-server:
importance: Unknown → Medium
Revision history for this message
Dmitry (pfzim) wrote :

I don't understand, this bug fixed only in natty and later releases?
I have same error then connect bluetooth keyboard in ubuntu 10.04.3 lucid

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.